- updated to 5.15.3 auto/th/kp5-kde-cli-tools-5.15.3-1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 25 Mar 2019 08:01:31 +0000 (09:01 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 25 Mar 2019 08:01:31 +0000 (09:01 +0100)
kp5-kde-cli-tools.spec

index 727c0bc7bc57cb1e0ba232610496f081d3f68e92..ef780670d3bd61eacf4991b2e28b4203d87716de 100644 (file)
@@ -1,14 +1,14 @@
-%define                kdeplasmaver    5.14.5
+%define                kdeplasmaver    5.15.3
 %define                qtver           5.9.0
 %define                kpname          kde-cli-tools
 Summary:       Tools based on KDE Frameworks 5 to better interact with the system
 Name:          kp5-%{kpname}
-Version:       5.14.5
+Version:       5.15.3
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: be9fe02e19e8e815b9b50b05b25faf0e
+# Source0-md5: 882890f64e5143e67e061f6267feea5f
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
@@ -22,7 +22,8 @@ BuildRequires:        kf5-ki18n-devel
 BuildRequires: kf5-kiconthemes-devel
 BuildRequires: kf5-kitemmodels-devel
 BuildRequires: kf5-kwindowsystem-devel
-BuildRequires: kp5-plasma-workspace-devel >= 5.14.5
+BuildRequires: kp5-plasma-workspace-devel >= %{version}
+BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: tar >= 1:1.22
@@ -38,15 +39,14 @@ Tools based on KDE Frameworks 5 to better interact with the system.
 %build
 install -d build
 cd build
-%cmake \
+%cmake -G Ninja \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang kde-cli-tools --all-name --with-kde
 
This page took 0.240248 seconds and 4 git commands to generate.