]> git.pld-linux.org Git - packages/kodi.git/blob - xbmc.spec
- release 2
[packages/kodi.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #
11 # Conditional build:
12 %bcond_without  goom    # build without goom visualisation
13 %bcond_with     hal                     # build with HAL
14
15 Summary:        XBMC is a free and open source media-player and entertainment hub
16 Name:           xbmc
17 Version:        11.0
18 Release:        2
19 License:        GPL v2+ and GPL v3+
20 Group:          Applications/Multimedia
21 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  9e8a26ee25173c7268abea7f1d82d428
23 URL:            http://xbmc.org/
24 BuildRequires:  Mesa-libGLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL-devel
27 BuildRequires:  SDL_image-devel
28 BuildRequires:  SDL_mixer-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  avahi-devel
33 BuildRequires:  bluez-libs-devel >= 4.99
34 BuildRequires:  boost-devel
35 BuildRequires:  bzip2-devel
36 BuildRequires:  cmake
37 BuildRequires:  curl-devel
38 BuildRequires:  dbus-devel
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  flac-devel
41 BuildRequires:  fontconfig-devel
42 BuildRequires:  freetype-devel
43 BuildRequires:  fribidi-devel
44 BuildRequires:  gawk
45 BuildRequires:  gettext-autopoint
46 BuildRequires:  gettext-devel
47 BuildRequires:  glew-devel
48 BuildRequires:  gperf
49 %if %{with hal}
50 BuildRequires:  hal-devel
51 %endif
52 BuildRequires:  jasper-devel
53 BuildRequires:  libass-devel
54 BuildRequires:  libbluray-devel
55 BuildRequires:  libcdio-devel
56 BuildRequires:  libgcrypt-devel
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libmad-devel
59 BuildRequires:  libmicrohttpd-devel
60 BuildRequires:  libmodplug-devel
61 BuildRequires:  libmpeg2-devel
62 BuildRequires:  libogg-devel
63 BuildRequires:  libplist-devel
64 BuildRequires:  libpng-devel
65 BuildRequires:  librtmp-devel
66 BuildRequires:  libsamplerate-devel
67 BuildRequires:  libsmbclient-devel
68 BuildRequires:  libssh-devel
69 BuildRequires:  libtiff-devel
70 BuildRequires:  libtool
71 BuildRequires:  libva-devel
72 BuildRequires:  libvdpau-devel
73 BuildRequires:  libvorbis-devel
74 BuildRequires:  lzo-devel
75 BuildRequires:  mysql-devel
76 %ifarch %{ix86}
77 BuildRequires:  nasm
78 %endif
79 BuildRequires:  openssl-devel
80 BuildRequires:  pcre-cxx-devel
81 BuildRequires:  pcre-devel
82 BuildRequires:  pkgconfig
83 BuildRequires:  pulseaudio-devel
84 BuildRequires:  python-devel >= 2.4
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.566
87 # used internally
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel
90 BuildRequires:  udev-devel
91 BuildRequires:  unzip
92 BuildRequires:  xorg-lib-libX11-devel
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXmu-devel
96 BuildRequires:  xorg-lib-libXrandr-devel
97 BuildRequires:  xorg-lib-libXt-devel
98 BuildRequires:  xorg-lib-libXtst-devel
99 BuildRequires:  yajl-devel
100 BuildRequires:  zip
101 BuildRequires:  zlib-devel
102 #https://github.com/sahlberg/libnfs
103 #BuildRequires: libnfs-devel
104 #http://sites.google.com/site/alexthepuffin/home
105 #BuildRequires: afpfs-ng-devel
106 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
107 #https://github.com/albertz/shairport
108 #BuildRequires: libshairport
109 #http://www.broadcom.com/support/crystal_hd/
110 #BuildRequires: crystalhd-devel
111 #http://libcec.pulse-eight.com/
112 #BuildRequires: libcec-devel >= 1.1.0
113 Requires:       /usr/bin/glxinfo
114 Requires:       SDL >= 1.2.14-5
115 Requires:       lsb-release
116 Requires:       xorg-app-xdpyinfo
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %description
120 XBMC media center is a free cross-platform media-player jukebox and
121 entertainment hub. XBMC can play a spectrum of of multimedia formats,
122 and featuring playlist, audio visualizations, slideshow, and weather
123 forecast functions, together third-party plugins.
124
125 %prep
126 %setup -q
127
128 %build
129 ./bootstrap
130 %configure \
131         --disable-debug \
132         --enable-external-libraries \
133         --enable-udev \
134         --disable-libcec \
135         --disable-libusb \
136         --disable-nfs \
137         --disable-afpclient \
138         --disable-airtunes \
139         --disable-crystalhd \
140         %{__enable_disable goom} \
141         %{__enable_disable hal}
142
143 %{__make} V=1
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/*
156 %{_datadir}/%{name}
157 %attr(755,root,root) %{_libdir}/%{name}
158 %{_docdir}/%{name}
159 %{_desktopdir}/%{name}.desktop
160 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
161 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
162 %{_datadir}/xsessions/XBMC.desktop
This page took 0.069706 seconds and 3 git commands to generate.