]> git.pld-linux.org Git - packages/kodi.git/blob - xbmc.spec
2f8d15a9fe987210f3588cd89c46dfa680e8f347
[packages/kodi.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #  - check how it works with external python libraries
11 #
12 # Conditional build:
13 %bcond_with     external_python
14 %bcond_without  goom
15
16 Summary:        XBMC
17 Name:           xbmc
18 Version:        10.0
19 Release:        0.2
20 License:        GPL v3
21 Group:          Applications/Multimedia
22 Source0:        http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
23 # Source0-md5:  728fb514e5f43f27bb880305061b4e72
24 URL:            http://xbmc.org
25 Patch0:         %{name}-nobash.patch
26 Patch1:         %{name}-python27.patch
27 Patch2:         %{name}-subtitle_tags.patch
28 BuildRequires:  SDL_image-devel
29 BuildRequires:  SDL_mixer-devel
30 BuildRequires:  a52dec-libs-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  avahi-devel
35 BuildRequires:  boost-devel
36 BuildRequires:  bzip2-devel
37 BuildRequires:  cmake
38 BuildRequires:  curl-devel
39 BuildRequires:  dbus-devel
40 BuildRequires:  enca-devel
41 BuildRequires:  faac-devel
42 BuildRequires:  faad2-devel
43 BuildRequires:  ffmpeg-devel
44 BuildRequires:  flac-devel
45 BuildRequires:  fontconfig-devel
46 BuildRequires:  freetype-devel
47 BuildRequires:  fribidi-devel
48 BuildRequires:  gawk
49 BuildRequires:  gettext-autopoint
50 BuildRequires:  gettext-devel
51 BuildRequires:  glew-devel
52 BuildRequires:  gperf
53 BuildRequires:  gtk+-devel
54 BuildRequires:  hal-devel
55 BuildRequires:  jasper-devel
56 BuildRequires:  libao-devel
57 BuildRequires:  libcdio-devel
58 BuildRequires:  libdts-devel
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libmad-devel
61 BuildRequires:  libmicrohttpd-devel
62 BuildRequires:  libmms-devel
63 BuildRequires:  libmodplug-devel
64 BuildRequires:  libmpeg2-devel
65 BuildRequires:  libogg-devel
66 BuildRequires:  libpng-devel
67 BuildRequires:  libsamplerate-devel
68 BuildRequires:  libsmbclient-devel
69 BuildRequires:  libtiff-devel
70 BuildRequires:  libtool
71 BuildRequires:  libvdpau-devel
72 BuildRequires:  libvorbis-devel
73 BuildRequires:  lzo-devel
74 BuildRequires:  mysql-devel
75 %ifarch %{ix86}
76 BuildRequires:  nasm
77 %endif
78 BuildRequires:  openssl-devel
79 BuildRequires:  pcre-cxx-devel
80 BuildRequires:  pkgconfig
81 BuildRequires:  pulseaudio-devel
82 BuildRequires:  python-devel
83 BuildRequires:  rpm-pythonprov
84 # used internally
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  sqlite3-devel
87 BuildRequires:  unzip
88 BuildRequires:  wavpack-devel
89 BuildRequires:  xmms-devel
90 BuildRequires:  xorg-lib-libXinerama-devel
91 BuildRequires:  xorg-lib-libXrandr-devel
92 BuildRequires:  xorg-lib-libXtst-devel
93 BuildRequires:  zip
94 BuildRequires:  zlib-devel
95 Requires:       /usr/bin/glxinfo
96 Requires:       lsb-release
97 Requires:       xorg-app-xdpyinfo
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
106 %patch1 -p1
107 %patch2 -p1
108
109 %build
110 ./bootstrap
111 %configure \
112         --disable-debug \
113         --enable-external-libraries \
114         --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
115         --%{?with_goom:en}%{!?with_goom:dis}able-goom
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %posttrans
128 %banner -e xbmc <<EOF
129 WARNING!
130 If you use nvidia binary drivers be sure that SDL is compiled without
131 XRandR and VidMode gamma ramps support.
132 This means that you need to rebuild it with command:
133 builder -bb --without new_gamma_ramp SDL
134 EOF
135
136 %files
137 %defattr(644,root,root,755)
138 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
139
140 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
141 %attr(755,root,root) %{_bindir}/*
142 %{_datadir}/%{name}
143 %attr(755,root,root) %{_libdir}/%{name}
144 %{_docdir}/%{name}
145 %{_desktopdir}/%{name}.desktop
146 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
147 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
148 %{_datadir}/xsessions/XBMC.desktop
This page took 0.032874 seconds and 2 git commands to generate.