]> git.pld-linux.org Git - packages/kodi.git/blob - xbmc.spec
14c2be3e0eb36a73f80a37118d13135bc892d2e7
[packages/kodi.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #
11 # Conditional build:
12 %bcond_without  goom    # build without goom visualisation
13 %bcond_with     hal                     # build with HAL
14
15 Summary:        XBMC is a free and open source media-player and entertainment hub
16 Name:           xbmc
17 Version:        11.0
18 Release:        2
19 License:        GPL v2+ and GPL v3+
20 Group:          Applications/Multimedia
21 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  9e8a26ee25173c7268abea7f1d82d428
23 Patch0:         %{name}-format-security.patch
24 Patch1:         %{name}-ffmpeg10.patch
25 URL:            http://xbmc.org/
26 BuildRequires:  Mesa-libGLU-devel
27 BuildRequires:  OpenGL-devel
28 BuildRequires:  SDL-devel
29 BuildRequires:  SDL_image-devel
30 BuildRequires:  SDL_mixer-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  avahi-devel
35 BuildRequires:  bluez-libs-devel >= 4.99
36 BuildRequires:  boost-devel
37 BuildRequires:  bzip2-devel
38 BuildRequires:  cmake
39 BuildRequires:  curl-devel
40 BuildRequires:  dbus-devel
41 BuildRequires:  ffmpeg-devel
42 BuildRequires:  flac-devel
43 BuildRequires:  fontconfig-devel
44 BuildRequires:  freetype-devel
45 BuildRequires:  fribidi-devel
46 BuildRequires:  gawk
47 BuildRequires:  gettext-autopoint
48 BuildRequires:  gettext-devel
49 BuildRequires:  glew-devel
50 BuildRequires:  gperf
51 %if %{with hal}
52 BuildRequires:  hal-devel
53 %endif
54 BuildRequires:  jasper-devel
55 BuildRequires:  libass-devel
56 BuildRequires:  libbluray-devel
57 BuildRequires:  libcdio-devel
58 BuildRequires:  libgcrypt-devel
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libmad-devel
61 BuildRequires:  libmicrohttpd-devel
62 BuildRequires:  libmodplug-devel
63 BuildRequires:  libmpeg2-devel
64 BuildRequires:  libogg-devel
65 BuildRequires:  libplist-devel
66 BuildRequires:  libpng-devel
67 BuildRequires:  librtmp-devel
68 BuildRequires:  libsamplerate-devel
69 BuildRequires:  libsmbclient-devel
70 BuildRequires:  libssh-devel
71 BuildRequires:  libtiff-devel
72 BuildRequires:  libtool
73 BuildRequires:  libva-devel
74 BuildRequires:  libvdpau-devel
75 BuildRequires:  libvorbis-devel
76 BuildRequires:  lzo-devel
77 BuildRequires:  mysql-devel
78 %ifarch %{ix86}
79 BuildRequires:  nasm
80 %endif
81 BuildRequires:  openssl-devel
82 BuildRequires:  pcre-cxx-devel
83 BuildRequires:  pcre-devel
84 BuildRequires:  pkgconfig
85 BuildRequires:  pulseaudio-devel
86 BuildRequires:  python-devel >= 2.4
87 BuildRequires:  rpm-pythonprov
88 BuildRequires:  rpmbuild(macros) >= 1.566
89 # used internally
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel
92 BuildRequires:  udev-devel
93 BuildRequires:  unzip
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xorg-lib-libXext-devel
96 BuildRequires:  xorg-lib-libXinerama-devel
97 BuildRequires:  xorg-lib-libXmu-devel
98 BuildRequires:  xorg-lib-libXrandr-devel
99 BuildRequires:  xorg-lib-libXt-devel
100 BuildRequires:  xorg-lib-libXtst-devel
101 BuildRequires:  yajl-devel
102 BuildRequires:  zip
103 BuildRequires:  zlib-devel
104 #https://github.com/sahlberg/libnfs
105 #BuildRequires: libnfs-devel
106 #http://sites.google.com/site/alexthepuffin/home
107 #BuildRequires: afpfs-ng-devel
108 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
109 #https://github.com/albertz/shairport
110 #BuildRequires: libshairport
111 #http://www.broadcom.com/support/crystal_hd/
112 #BuildRequires: crystalhd-devel
113 #http://libcec.pulse-eight.com/
114 #BuildRequires: libcec-devel >= 1.1.0
115 Requires:       /usr/bin/glxinfo
116 Requires:       SDL >= 1.2.14-5
117 Requires:       lsb-release
118 Requires:       xorg-app-xdpyinfo
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %description
122 XBMC media center is a free cross-platform media-player jukebox and
123 entertainment hub. XBMC can play a spectrum of of multimedia formats,
124 and featuring playlist, audio visualizations, slideshow, and weather
125 forecast functions, together third-party plugins.
126
127 %prep
128 %setup -q
129 %patch0 -p1
130 %patch1 -p1
131
132 %build
133 ./bootstrap
134 %configure \
135         --disable-debug \
136         --enable-external-libraries \
137         --enable-udev \
138         --disable-libcec \
139         --disable-libusb \
140         --disable-nfs \
141         --disable-afpclient \
142         --disable-airtunes \
143         --disable-crystalhd \
144         %{__enable_disable goom} \
145         %{__enable_disable hal}
146
147 %{__make} V=1
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/*
160 %{_datadir}/%{name}
161 %attr(755,root,root) %{_libdir}/%{name}
162 %{_docdir}/%{name}
163 %{_desktopdir}/%{name}.desktop
164 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
165 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
166 %{_datadir}/xsessions/XBMC.desktop
This page took 0.076673 seconds and 2 git commands to generate.