]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
a0b4a4f8d8aa2e8eab65a40af0b79077823449a9
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  gl              # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  libgif          # gif support via libgif
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  non_free        # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_without  system_dvdread  # build with system dvdread
54
55 %define codename Jarvis
56 Summary:        Kodi is a free and open source media-player and entertainment hub
57 Name:           kodi
58 Version:        16.1
59 Release:        2
60 License:        GPL v2+ and GPL v3+
61 Group:          Applications/Multimedia
62 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
63 Source0:        https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
64 # Source0-md5:  79358ad5f77f42c5498a9412d5a78dd5
65 Patch0:         jpeglib-boolean.patch
66 Patch1:         disable-static.patch
67 Patch2:         dvdread.patch
68 Patch3:         ffmpeg3.patch
69 Patch4:         gcc5.patch
70 URL:            http://kodi.tv/
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-devel
73 BuildRequires:  SDL2-devel
74 BuildRequires:  alsa-lib-devel
75 BuildRequires:  autoconf >= 2.59
76 BuildRequires:  automake
77 BuildRequires:  avahi-devel
78 BuildRequires:  bluez-libs-devel >= 4.99
79 BuildRequires:  boost-devel
80 BuildRequires:  bzip2-devel
81 BuildRequires:  cmake
82 BuildRequires:  crossguid-devel
83 BuildRequires:  curl-devel
84 BuildRequires:  dbus-devel
85 BuildRequires:  dcadec-devel
86 BuildRequires:  doxygen
87 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
88 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
89 BuildRequires:  flac-devel
90 BuildRequires:  fontconfig-devel
91 BuildRequires:  freetype-devel
92 BuildRequires:  fribidi-devel
93 BuildRequires:  gawk
94 BuildRequires:  gettext-autopoint
95 BuildRequires:  gettext-tools
96 BuildRequires:  giflib-devel
97 %{?with_libgif:BuildRequires:   giflib-devel}
98 BuildRequires:  glew-devel
99 BuildRequires:  gperf
100 BuildRequires:  jasper-devel
101 BuildRequires:  jre
102 BuildRequires:  libass-devel
103 BuildRequires:  libbluray-devel >= 0.7.0
104 BuildRequires:  libcap-devel
105 BuildRequires:  libcdio-devel
106 %{?with_libcec:BuildRequires:   libcec-devel >= 3.0.0}
107 BuildRequires:  libdrm-devel
108 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
109 %ifarch i686 pentium4 athlon %{x8664}
110 BuildRequires:  libcrystalhd-devel
111 %endif
112 BuildRequires:  libgcrypt-devel
113 BuildRequires:  libjpeg-devel
114 BuildRequires:  libltdl-devel
115 BuildRequires:  libmicrohttpd-devel
116 BuildRequires:  libmodplug-devel
117 BuildRequires:  libmpeg2-devel
118 BuildRequires:  libogg-devel
119 BuildRequires:  libplist-devel
120 BuildRequires:  libpng-devel
121 BuildRequires:  librtmp-devel
122 BuildRequires:  libsamplerate-devel
123 BuildRequires:  libsmbclient-devel
124 BuildRequires:  libssh-devel
125 BuildRequires:  libstdc++-devel
126 BuildRequires:  libtiff-devel
127 BuildRequires:  libtool
128 BuildRequires:  libuuid-devel
129 BuildRequires:  libva-devel
130 BuildRequires:  libva-x11-devel
131 BuildRequires:  libvdpau-devel
132 BuildRequires:  libvorbis-devel
133 BuildRequires:  libxml2-devel >= 2.0
134 BuildRequires:  libxslt-devel
135 BuildRequires:  lzo-devel
136 BuildRequires:  mysql-devel
137 %ifarch %{ix86}
138 BuildRequires:  nasm
139 %endif
140 BuildRequires:  openssl-devel
141 BuildRequires:  pcre-cxx-devel
142 BuildRequires:  pkgconfig
143 BuildRequires:  pulseaudio-devel >= 1.0
144 BuildRequires:  python-devel >= 1:2.6
145 BuildRequires:  rpm-pythonprov
146 BuildRequires:  rpmbuild(macros) >= 1.566
147 BuildRequires:  sed >= 4.0
148 BuildRequires:  sqlite3-devel
149 BuildRequires:  swig
150 BuildRequires:  taglib-devel >= 1.8
151 BuildRequires:  tinyxml-devel >= 2.6.2
152 BuildRequires:  udev-devel
153 BuildRequires:  unzip
154 BuildRequires:  xorg-lib-libX11-devel
155 BuildRequires:  xorg-lib-libXext-devel
156 BuildRequires:  xorg-lib-libXrandr-devel
157 BuildRequires:  yajl-devel >= 2
158 BuildRequires:  zip
159 BuildRequires:  zlib-devel
160 # kodi uses it's own, modified squish
161 BuildConflicts: squish-devel
162 #https://github.com/sahlberg/libnfs
163 BuildRequires:  libnfs-devel
164 #http://sites.google.com/site/alexthepuffin/home
165 #BuildRequires: afpfs-ng-devel
166 #BuildRequires: shairplay-devel
167 Requires:       /usr/bin/glxinfo
168 Requires:       SDL >= 1.2.14-5
169 Requires:       lsb-release
170 Requires:       xorg-app-xdpyinfo
171 # dlopened libraries:
172 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
173 Requires:       curl-libs
174 Requires:       libass
175 Requires:       libbluray
176 Requires:       libmodplug
177 Requires:       libmpeg2-libs
178 Requires:       libogg
179 Requires:       libplist
180 Requires:       libvorbis
181 Obsoletes:      xbmc < 14.0
182 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
183
184 %description
185 Kodi Entertainment Center (formerly XBMC) is a free and open-source
186 media player software developed by the XBMC Foundation, a non-profit
187 technology consortium. Kodi is available for multiple operating
188 systems and hardware platforms, with a software 10-foot user interface
189 for use with televisions and remote controls. It allows users to play
190 and view most videos, music, such as podcasts from the internet, and
191 all common digital media files from local and network storage media.
192
193 %prep
194 %setup -q -n xbmc-%{version}-%{codename}
195 %patch0 -p1
196 %patch1 -p1
197 %{?with_system_dvdread:%patch2 -p1}
198 %patch3 -p1
199 %patch4 -p1
200
201 %{__rm} -r lib/cximage-6.0/zlib
202 #%{__rm} -r lib/libhdhomerun
203 %{__rm} -r lib/libmpeg2
204 %{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
205 %{__rm} -r lib/libbluray
206 %{__rm} -r lib/librtmp
207 %{__rm} -r lib/win32
208 %{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
209
210 %if %{without system_ffmpeg}
211 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
212 %endif
213
214 %build
215 %{__make} -C tools/depends/native/libsquish-native \
216         CXX="%{__cxx}"
217
218 ./bootstrap
219 %configure \
220         ac_cv_type__Bool=yes \
221         --disable-silent-rules \
222         --disable-debug \
223         --disable-ccache \
224         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
225         %{__enable_disable afpclient} \
226         %{__enable_disable airplay} \
227         %{__enable_disable airtunes} \
228         %{__enable_disable alsa} \
229         %{__enable_disable asap_codec asap-codec} \
230         %{__enable_disable avahi} \
231         %{__enable_disable dbus} \
232         %{__enable_disable dvdcss} \
233         %{__enable_disable gles} \
234         %{__enable_disable gl} \
235         %{__enable_disable gtest} \
236         %{__enable_disable joystick} \
237         %{__enable_disable libbluray} \
238         %{__enable_disable libcap} \
239         %{__enable_disable libcec} \
240         %{__enable_disable libgif} \
241         %{__enable_disable libusb} \
242         %{__enable_disable mdnsembedded} \
243         %{__enable_disable mid} \
244         %{__enable_disable mysql} \
245         %{__enable_disable nfs} \
246         %{__enable_disable non_free non-free} \
247         %{__enable_disable openmax} \
248         %{__enable_disable optical_drive optical-drive} \
249         %{__enable_disable profiling} \
250         %{__enable_disable pulse} \
251         %{__enable_disable rtmp} \
252         %{__enable_disable samba} \
253         %{__enable_disable sdl} \
254         %{__enable_disable ssh} \
255         %{__enable_disable tegra} \
256         %{__enable_disable texturepacker} \
257         %{__enable_disable udev} \
258         %{__enable_disable upnp} \
259         %{__enable_disable vaapi} \
260         %{__enable_disable vdpau} \
261         %{__enable_disable vtbdecoder} \
262         %{__enable_disable wayland} \
263         %{__enable_disable webserver} \
264         %{__enable_disable x11} \
265         %{__enable_disable xrandr} \
266         %{nil}
267
268 %{__make} V=1
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 %{__make} install \
273         DESTDIR=$RPM_BUILD_ROOT
274
275 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
276
277 # no -devel package yet
278 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
279 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
280
281 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
282 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
283 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
284
285 %clean
286 rm -rf $RPM_BUILD_ROOT
287
288 %files
289 %defattr(644,root,root,755)
290 %doc README.md docs/README.linux
291 %attr(755,root,root) %{_bindir}/kodi
292 %attr(755,root,root) %{_bindir}/kodi-standalone
293 %{_datadir}/%{name}
294 %attr(755,root,root) %{_libdir}/%{name}
295 %{_desktopdir}/kodi.desktop
296 %{_iconsdir}/hicolor/*/apps/%{name}.png
297 %{_datadir}/xsessions/kodi.desktop
298
299 # legacy xbmc compatibility links
300 %attr(755,root,root) %{_bindir}/xbmc
301 %attr(755,root,root) %{_bindir}/xbmc-standalone
302 %{_datadir}/xsessions/xbmc.desktop
This page took 1.173916 seconds and 2 git commands to generate.