]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
BR dcadec-devel
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  fishbmc         # FishBMC visualisation
17 %bcond_without  gl              # OpenGL rendering
18 %bcond_without  goom            # GOOM visualisation
19 %bcond_with     gtest           # configure Google Test Framework
20 %bcond_without  joystick        # SDL joystick support
21 %bcond_without  libcap          # libcap support
22 %bcond_with     libcec          # libcec support
23 %bcond_without  libusb          # libusb support
24 %bcond_with     mdnsembedded    # mDNSEmbedded support
25 %bcond_without  mysql           # MySQL
26 %bcond_without  nfs             # NFS support via libnfs
27 %bcond_without  non_free        # componentents with non-compliant licenses
28 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
29 %bcond_without  optical_drive   # optical drive
30 %bcond_without  projectm        # ProjectM visualisation
31 %bcond_without  pulse           # PulseAudio support
32 %bcond_without  rsxs            # really slick X screensavers
33 %bcond_without  rtmp            # RTMP support via librtmp
34 %bcond_without  samba           # SAMBA support
35 %bcond_without  sdl             # SDL
36 %bcond_without  spectrum        # Spectrum visualisation
37 %bcond_without  ssh             # SSH SFTP support
38 %bcond_without  texturepacker   # texturepacker support
39 %bcond_without  udev            # udev support
40 %bcond_without  upnp            # UPnP support
41 %bcond_without  vaapi           # VAAPI decoding
42 %bcond_without  vdpau           # VDPAU decoding
43 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
44 %bcond_without  waveform        # Waveform visualisation
45 %bcond_without  webserver       # webserver
46 %bcond_without  x11             # x11 'Linux Only'
47 %bcond_without  xrandr          # XRandR support
48 %bcond_with     asap_codec      # ASAP ADPCM support
49 %bcond_with     gles            # OpenGLES rendering
50 %bcond_without  libbluray       # libbluray support
51 %bcond_without  mid             # MID support
52 %bcond_with     profiling       # gprof profiling
53 %bcond_with     tegra           # Tegra2 arm
54 %bcond_with     wayland         # wayland
55 # System libs:
56 %bcond_without  system_ffmpeg   # build with system ffmpeg
57 %bcond_without  system_dvdread  # build with system dvdread
58
59 %define codename Jarvis
60 Summary:        Kodi is a free and open source media-player and entertainment hub
61 Name:           kodi
62 Version:        16.1
63 Release:        1
64 License:        GPL v2+ and GPL v3+
65 Group:          Applications/Multimedia
66 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
67 Source0:        https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
68 # Source0-md5:  79358ad5f77f42c5498a9412d5a78dd5
69 Patch0:         jpeglib-boolean.patch
70 Patch1:         disable-static.patch
71 Patch2:         dvdread.patch
72 Patch3:         ffmpeg3.patch
73 Patch4:         gcc5.patch
74 URL:            http://kodi.tv/
75 BuildRequires:  Mesa-libGLU-devel
76 BuildRequires:  OpenGL-devel
77 BuildRequires:  SDL2-devel
78 BuildRequires:  SDL_image-devel
79 BuildRequires:  SDL_mixer-devel
80 BuildRequires:  alsa-lib-devel
81 BuildRequires:  autoconf
82 BuildRequires:  automake
83 BuildRequires:  avahi-devel
84 BuildRequires:  bluez-libs-devel >= 4.99
85 BuildRequires:  boost-devel
86 BuildRequires:  bzip2-devel
87 BuildRequires:  cmake
88 BuildRequires:  crossguid-devel
89 BuildRequires:  curl-devel
90 BuildRequires:  dbus-devel
91 BuildRequires:  dcadec-devel
92 BuildRequires:  doxygen
93 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
94 BuildRequires:  flac-devel
95 BuildRequires:  fontconfig-devel
96 BuildRequires:  freetype-devel
97 BuildRequires:  fribidi-devel
98 BuildRequires:  gawk
99 BuildRequires:  gettext-autopoint
100 BuildRequires:  gettext-tools
101 BuildRequires:  giflib-devel
102 BuildRequires:  glew-devel
103 BuildRequires:  gperf
104 BuildRequires:  jasper-devel
105 BuildRequires:  jre
106 BuildRequires:  libass-devel
107 BuildRequires:  libbluray-devel >= 0.2.1
108 BuildRequires:  libcap-devel
109 BuildRequires:  libcdio-devel
110 %{?with_libcec:BuildRequires:   libcec-devel}
111 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
112 %ifarch i686 pentium4 athlon %{x8664}
113 BuildRequires:  libcrystalhd-devel
114 %endif
115 BuildRequires:  libgcrypt-devel
116 BuildRequires:  libjpeg-devel
117 BuildRequires:  libltdl-devel
118 BuildRequires:  libmad-devel
119 BuildRequires:  libmicrohttpd-devel
120 BuildRequires:  libmodplug-devel
121 BuildRequires:  libmpeg2-devel
122 BuildRequires:  libogg-devel
123 BuildRequires:  libplist-devel
124 BuildRequires:  libpng-devel
125 BuildRequires:  librtmp-devel
126 BuildRequires:  libsamplerate-devel
127 BuildRequires:  libsmbclient-devel
128 BuildRequires:  libssh-devel
129 BuildRequires:  libtiff-devel
130 BuildRequires:  libtool
131 BuildRequires:  libva-devel
132 BuildRequires:  libva-glx-devel
133 BuildRequires:  libvdpau-devel
134 BuildRequires:  libvorbis-devel
135 BuildRequires:  libxslt-devel
136 BuildRequires:  lzo-devel
137 BuildRequires:  mysql-devel
138 %ifarch %{ix86}
139 BuildRequires:  nasm
140 %endif
141 BuildRequires:  openssl-devel
142 BuildRequires:  pcre-cxx-devel
143 BuildRequires:  pkgconfig
144 BuildRequires:  pulseaudio-devel
145 BuildRequires:  python-devel >= 2.4
146 BuildRequires:  rpm-pythonprov
147 BuildRequires:  rpmbuild(macros) >= 1.566
148 BuildRequires:  sed >= 4.0
149 BuildRequires:  sqlite3-devel
150 BuildRequires:  swig
151 BuildRequires:  taglib-devel >= 1.8
152 BuildRequires:  tinyxml-devel
153 BuildRequires:  udev-devel
154 BuildRequires:  unzip
155 BuildRequires:  xorg-lib-libX11-devel
156 BuildRequires:  xorg-lib-libXext-devel
157 BuildRequires:  xorg-lib-libXinerama-devel
158 BuildRequires:  xorg-lib-libXmu-devel
159 BuildRequires:  xorg-lib-libXrandr-devel
160 BuildRequires:  xorg-lib-libXt-devel
161 BuildRequires:  xorg-lib-libXtst-devel
162 BuildRequires:  yajl-devel
163 BuildRequires:  yasm
164 BuildRequires:  zip
165 BuildRequires:  zlib-devel
166 # kodi uses it's own, modified squish
167 BuildConflicts: squish-devel
168 #https://github.com/sahlberg/libnfs
169 BuildRequires:  libnfs-devel
170 #http://sites.google.com/site/alexthepuffin/home
171 #BuildRequires: afpfs-ng-devel
172 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
173 #https://github.com/albertz/shairport
174 #BuildRequires: libshairport
175 Requires:       /usr/bin/glxinfo
176 Requires:       SDL >= 1.2.14-5
177 Requires:       lsb-release
178 Requires:       xorg-app-xdpyinfo
179 # dlopened libraries:
180 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
181 Requires:       curl-libs
182 Requires:       libass
183 Requires:       libbluray
184 Requires:       libmodplug
185 Requires:       libmpeg2-libs
186 Requires:       libogg
187 Requires:       libplist
188 Requires:       libvorbis
189 Obsoletes:      xbmc < 14.0
190 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
191
192 %description
193 Kodi Entertainment Center (formerly XBMC) is a free and open-source
194 media player software developed by the XBMC Foundation, a non-profit
195 technology consortium. Kodi is available for multiple operating
196 systems and hardware platforms, with a software 10-foot user interface
197 for use with televisions and remote controls. It allows users to play
198 and view most videos, music, such as podcasts from the internet, and
199 all common digital media files from local and network storage media.
200
201 %prep
202 %setup -q -n xbmc-%{version}-%{codename}
203 %patch0 -p1
204 %patch1 -p1
205 %{?with_system_dvdread:%patch2 -p1}
206 %patch3 -p1
207 #%patch4 -p1
208
209 rm -r lib/cximage-6.0/zlib
210 #rm -r lib/libhdhomerun
211 rm -r lib/libmpeg2
212 rm -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
213 rm -r lib/libbluray
214 rm -r lib/librtmp
215 rm -r lib/win32
216 %{?with_system_dvdread:rm -r lib/libdvd/libdvdread}
217
218 %if %{without system_ffmpeg}
219 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
220 %endif
221
222 %build
223 %{__make} -C tools/depends/native/libsquish-native \
224         CXX="%{__cxx}"
225
226 ./bootstrap
227 %configure \
228         ac_cv_type__Bool=yes \
229         --disable-silent-rules \
230         --disable-debug \
231         --disable-ccache \
232         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
233         %{__enable_disable afpclient} \
234         %{__enable_disable airplay} \
235         %{__enable_disable airtunes} \
236         %{__enable_disable alsa} \
237         %{__enable_disable asap_codec asap-codec} \
238         %{__enable_disable avahi} \
239         %{__enable_disable dbus} \
240         %{__enable_disable dvdcss} \
241         %{__enable_disable fishbmc} \
242         %{__enable_disable gles} \
243         %{__enable_disable gl} \
244         %{__enable_disable goom} \
245         %{__enable_disable gtest} \
246         %{__enable_disable joystick} \
247         %{__enable_disable libbluray} \
248         %{__enable_disable libcap} \
249         %{__enable_disable libcec} \
250         %{__enable_disable libusb} \
251         %{__enable_disable mdnsembedded} \
252         %{__enable_disable mid} \
253         %{__enable_disable mysql} \
254         %{__enable_disable nfs} \
255         %{__enable_disable non_free non-free} \
256         %{__enable_disable openmax} \
257         %{__enable_disable optical_drive optical-drive} \
258         %{__enable_disable profiling} \
259         %{__enable_disable projectm} \
260         %{__enable_disable pulse} \
261         %{__enable_disable rsxs} \
262         %{__enable_disable rtmp} \
263         %{__enable_disable samba} \
264         %{__enable_disable sdl} \
265         %{__enable_disable spectrum} \
266         %{__enable_disable ssh} \
267         %{__enable_disable tegra} \
268         %{__enable_disable texturepacker} \
269         %{__enable_disable udev} \
270         %{__enable_disable upnp} \
271         %{__enable_disable vaapi} \
272         %{__enable_disable vdpau} \
273         %{__enable_disable vtbdecoder} \
274         %{__enable_disable waveform} \
275         %{__enable_disable wayland} \
276         %{__enable_disable webserver} \
277         %{__enable_disable x11} \
278         %{__enable_disable xrandr} \
279         %{nil}
280
281 %{__make} V=1
282
283 %install
284 rm -rf $RPM_BUILD_ROOT
285 %{__make} install \
286         DESTDIR=$RPM_BUILD_ROOT
287
288 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
289
290 # no -devel package yet
291 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
292 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
293
294 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
295 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
296 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
297
298 %clean
299 rm -rf $RPM_BUILD_ROOT
300
301 %files
302 %defattr(644,root,root,755)
303 %doc README.md docs/README.linux
304 %attr(755,root,root) %{_bindir}/kodi
305 %attr(755,root,root) %{_bindir}/kodi-standalone
306 %{_datadir}/%{name}
307 %attr(755,root,root) %{_libdir}/%{name}
308 %{_desktopdir}/kodi.desktop
309 %{_iconsdir}/hicolor/*/apps/%{name}.png
310 %{_datadir}/xsessions/kodi.desktop
311
312 # legacy xbmc compatibility links
313 %attr(755,root,root) %{_bindir}/xbmc
314 %attr(755,root,root) %{_bindir}/xbmc-standalone
315 %{_datadir}/xsessions/xbmc.desktop
This page took 0.086954 seconds and 3 git commands to generate.