]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
specifiy libmicrohttpd required version
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  gl              # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  libgif          # gif support via libgif
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  non_free        # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_with     system_dvdread  # build with system dvdread
54
55 %define codename Leia
56 %define subver  a2
57 Summary:        Kodi is a free and open source media-player and entertainment hub
58 Name:           kodi
59 Version:        18.0
60 Release:        0.1
61 License:        GPL v2+ and GPL v3+
62 Group:          Applications/Multimedia
63 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
64 Source0:        https://github.com/xbmc/xbmc/archive/%{version}%{subver}-%{codename}.tar.gz
65 # Source0-md5:  6e2262d8b38d4ed28f0b102e51eb9a8e
66 Patch0:         jpeglib-boolean.patch
67 Patch1:         disable-static.patch
68 Patch2:         dvdread.patch
69 Patch3:         ffmpeg3.patch
70 Patch4:         gcc5.patch
71 Patch5:         libdvd.patch
72 URL:            http://kodi.tv/
73 BuildRequires:  Mesa-libEGL-devel
74 BuildRequires:  OpenGL-GLU-devel
75 BuildRequires:  OpenGL-devel
76 BuildRequires:  SDL2-devel
77 BuildRequires:  alsa-lib-devel
78 BuildRequires:  avahi-devel
79 BuildRequires:  bluez-libs-devel >= 4.99
80 BuildRequires:  bzip2-devel
81 BuildRequires:  cmake >= 3.4
82 BuildRequires:  crossguid-devel
83 BuildRequires:  curl-devel
84 BuildRequires:  dbus-devel
85 BuildRequires:  libfmt-devel >= 3.0.1
86 BuildRequires:  rapidjson-devel >= 1.1.0
87 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
88 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
89 BuildRequires:  flac-devel
90 BuildRequires:  fontconfig-devel
91 BuildRequires:  freetype-devel
92 BuildRequires:  fribidi-devel
93 BuildRequires:  gawk
94 BuildRequires:  gettext-autopoint
95 BuildRequires:  gettext-tools
96 BuildRequires:  giflib-devel
97 %{?with_libgif:BuildRequires:   giflib-devel}
98 BuildRequires:  gperf
99 BuildRequires:  jre
100 BuildRequires:  lcms2-devel
101 BuildRequires:  libass-devel
102 BuildRequires:  libatomic-devel
103 BuildRequires:  libbluray-devel >= 0.7.0
104 BuildRequires:  libcap-devel
105 BuildRequires:  libcdio-devel
106 %{?with_libcec:BuildRequires:   libcec-devel >= 3.0.0}
107 BuildRequires:  libdrm-devel
108 BuildRequires:  libdvdcss-devel >= 1.4.1
109 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
110 BuildRequires:  libgcrypt-devel
111 BuildRequires:  libjpeg-devel
112 BuildRequires:  libltdl-devel
113 BuildRequires:  libmicrohttpd-devel >= 0.9.40
114 BuildRequires:  libogg-devel
115 BuildRequires:  libplist-devel
116 BuildRequires:  libpng-devel
117 BuildRequires:  librtmp-devel
118 BuildRequires:  libsmbclient-devel
119 BuildRequires:  libssh-devel
120 BuildRequires:  libstdc++-devel
121 BuildRequires:  libtool
122 BuildRequires:  libuuid-devel
123 BuildRequires:  libva-devel
124 BuildRequires:  libva-x11-devel
125 BuildRequires:  libvdpau-devel
126 BuildRequires:  libvorbis-devel
127 BuildRequires:  libxml2-devel >= 2.0
128 BuildRequires:  libxslt-devel
129 BuildRequires:  lzo-devel
130 BuildRequires:  mysql-devel
131 %ifarch %{ix86}
132 BuildRequires:  nasm
133 %endif
134 BuildRequires:  openssl-devel
135 BuildRequires:  pcre-cxx-devel
136 BuildRequires:  pkgconfig
137 BuildRequires:  pulseaudio-devel >= 1.0
138 BuildRequires:  python-devel >= 1:2.6
139 BuildRequires:  rpm-pythonprov
140 BuildRequires:  rpmbuild(macros) >= 1.566
141 BuildRequires:  sed >= 4.0
142 BuildRequires:  sqlite3-devel
143 BuildRequires:  swig
144 BuildRequires:  taglib-devel >= 1.8
145 BuildRequires:  tinyxml-devel >= 2.6.2
146 BuildRequires:  udev-devel
147 BuildRequires:  unzip
148 BuildRequires:  xorg-lib-libX11-devel
149 BuildRequires:  xorg-lib-libXext-devel
150 BuildRequires:  xorg-lib-libXrandr-devel
151 BuildRequires:  yajl-devel >= 2
152 BuildRequires:  zip
153 BuildRequires:  zlib-devel
154 # kodi uses it's own, modified squish
155 BuildConflicts: squish-devel
156 #https://github.com/sahlberg/libnfs
157 BuildRequires:  libnfs-devel
158 #http://sites.google.com/site/alexthepuffin/home
159 #BuildRequires: afpfs-ng-devel
160 #BuildRequires: shairplay-devel
161 Requires:       /usr/bin/glxinfo
162 Requires:       SDL >= 1.2.14-5
163 Requires:       lsb-release
164 Requires:       xorg-app-xdpyinfo
165 # dlopened libraries:
166 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
167 Requires:       curl-libs
168 Requires:       libass
169 Requires:       libbluray
170 Requires:       libmodplug
171 Requires:       libmpeg2-libs
172 Requires:       libogg
173 Requires:       libplist
174 Requires:       libvorbis
175 Obsoletes:      xbmc < 14.0
176 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
177
178 # extracting debug info from /home/users/glen/tmp/kodi-18.0-root-glen/usr/lib64/kodi/kodi-x11
179 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
180 %define         _noautostrip    kodi-x11
181 %define         _enable_debug_packages  0
182
183 %description
184 Kodi Entertainment Center (formerly XBMC) is a free and open-source
185 media player software developed by the XBMC Foundation, a non-profit
186 technology consortium. Kodi is available for multiple operating
187 systems and hardware platforms, with a software 10-foot user interface
188 for use with televisions and remote controls. It allows users to play
189 and view most videos, music, such as podcasts from the internet, and
190 all common digital media files from local and network storage media.
191
192 %prep
193 %setup -q -n xbmc-%{version}%{?subver}-%{codename}
194 #%patch0 -p1
195 %patch1 -p1
196 %{?with_system_dvdread:%patch2 -p1}
197 #%patch3 -p1
198 #%patch4 -p1
199 %patch5 -p1
200
201 #%{__rm} -r lib/cximage-6.0/zlib
202 #%{__rm} -r lib/libhdhomerun
203 #%{__rm} -r lib/libmpeg2
204 #%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
205 #%{__rm} -r lib/libbluray
206 #%{__rm} -r lib/librtmp
207 %{__rm} -r lib/win32
208 #%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
209
210 %if %{without system_ffmpeg}
211 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
212 %endif
213
214 %build
215 install -d build
216 cd build
217 # cmake not picking up include path from pkgconfig
218 # https://trac.kodi.tv/ticket/16861
219 %define specflags -I/usr/include/freetype2
220 %cmake \
221         -DENABLE_INTERNAL_LIBDVD=OFF \
222         -DENABLE_INTERNAL_CROSSGUID=OFF \
223         -DENABLE_DVDCSS=%{__true_false dvdcss} \
224         ..
225 %if 0
226 %configure \
227         ac_cv_type__Bool=yes \
228         --disable-silent-rules \
229         --disable-debug \
230         --disable-ccache \
231         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
232         %{__enable_disable afpclient} \
233         %{__enable_disable airplay} \
234         %{__enable_disable airtunes} \
235         %{__enable_disable alsa} \
236         %{__enable_disable asap_codec asap-codec} \
237         %{__enable_disable avahi} \
238         %{__enable_disable dbus} \
239         %{__enable_disable gles} \
240         %{__enable_disable gl} \
241         %{__enable_disable gtest} \
242         %{__enable_disable joystick} \
243         %{__enable_disable libbluray} \
244         %{__enable_disable libcap} \
245         %{__enable_disable libcec} \
246         %{__enable_disable libgif} \
247         %{__enable_disable libusb} \
248         %{__enable_disable mdnsembedded} \
249         %{__enable_disable mid} \
250         %{__enable_disable mysql} \
251         %{__enable_disable nfs} \
252         %{__enable_disable non_free non-free} \
253         %{__enable_disable openmax} \
254         %{__enable_disable optical_drive optical-drive} \
255         %{__enable_disable profiling} \
256         %{__enable_disable pulse} \
257         %{__enable_disable rtmp} \
258         %{__enable_disable samba} \
259         %{__enable_disable sdl} \
260         %{__enable_disable ssh} \
261         %{__enable_disable tegra} \
262         %{__enable_disable texturepacker} \
263         %{__enable_disable udev} \
264         %{__enable_disable upnp} \
265         %{__enable_disable vaapi} \
266         %{__enable_disable vdpau} \
267         %{__enable_disable vtbdecoder} \
268         %{__enable_disable wayland} \
269         %{__enable_disable webserver} \
270         %{__enable_disable x11} \
271         %{__enable_disable xrandr} \
272         %{nil}
273 %endif
274
275 %{__make}
276
277 %install
278 rm -rf $RPM_BUILD_ROOT
279 %{__make} -C build install \
280         DESTDIR=$RPM_BUILD_ROOT
281
282 %{__rm} $RPM_BUILD_ROOT%{_docdir}/{version.txt,copying.txt,README.linux,LICENSE.GPL}
283
284 # not packaged
285 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/firewalld/services/kodi-*.xml
286
287 # no -devel package yet
288 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
289
290 %clean
291 rm -rf $RPM_BUILD_ROOT
292
293 %files
294 %defattr(644,root,root,755)
295 %doc README.md docs/README.linux
296 %attr(755,root,root) %{_bindir}/TexturePacker
297 %attr(755,root,root) %{_bindir}/kodi
298 %attr(755,root,root) %{_bindir}/kodi-standalone
299 %{_datadir}/%{name}
300 %attr(755,root,root) %{_libdir}/%{name}
301 %{_desktopdir}/kodi.desktop
302 %{_iconsdir}/hicolor/*/apps/%{name}.png
303 %{_datadir}/xsessions/kodi.desktop
This page took 0.074679 seconds and 3 git commands to generate.