]> git.pld-linux.org Git - packages/kodi.git/blame - kodi.spec
build without dvd support if without system dvd
[packages/kodi.git] / kodi.spec
CommitLineData
18b90c81 1# TODO:
3a71016a 2# - fix build flags - some files are compiled with -O3 and without rpm*flags
92b96980 3# - add and/or fix users/groups permissions
63ff963e 4# - split to subpackages?
928406b7 5# - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
18b90c81 6#
92b96980 7# Conditional build:
ceb94d36 8# Features:
c0d69361
ER
9%bcond_with afpclient # AFP support via libafpclient
10%bcond_without airplay # AirPlay support
11%bcond_with airtunes # AirTunes support
e148a10d
ER
12%bcond_without alsa # ALSA support
13%bcond_without avahi # Avahi support
ceb94d36
ER
14%bcond_without dbus # DBUS support
15%bcond_without dvdcss # DVDCSS support
98f23c16 16%bcond_without gl # OpenGL rendering
ceb94d36 17%bcond_with gtest # configure Google Test Framework
98f23c16 18%bcond_without joystick # SDL joystick support
c0d69361
ER
19%bcond_without libcap # libcap support
20%bcond_with libcec # libcec support
296d79de 21%bcond_without libgif # gif support via libgif
8ea15fa3 22%bcond_without libusb # libusb support
c0d69361 23%bcond_with mdnsembedded # mDNSEmbedded support
ceb94d36 24%bcond_without mysql # MySQL
8ea15fa3 25%bcond_without nfs # NFS support via libnfs
ceb94d36 26%bcond_without non_free # componentents with non-compliant licenses
c0d69361 27%bcond_with openmax # OpenMax decoding, requires OpenGLES
ceb94d36 28%bcond_without optical_drive # optical drive
98f23c16 29%bcond_without projectm # ProjectM visualisation
c0d69361 30%bcond_without pulse # PulseAudio support
c0d69361 31%bcond_without rtmp # RTMP support via librtmp
e148a10d 32%bcond_without samba # SAMBA support
c0d69361 33%bcond_without sdl # SDL
e148a10d 34%bcond_without ssh # SSH SFTP support
98f23c16 35%bcond_without texturepacker # texturepacker support
c0d69361 36%bcond_without udev # udev support
e148a10d 37%bcond_without upnp # UPnP support
c0d69361
ER
38%bcond_without vaapi # VAAPI decoding
39%bcond_without vdpau # VDPAU decoding
40%bcond_with vtbdecoder # VTBDecoder decoding (VTB Decoder not supported on this platform)
ceb94d36 41%bcond_without webserver # webserver
98f23c16
ER
42%bcond_without x11 # x11 'Linux Only'
43%bcond_without xrandr # XRandR support
e148a10d
ER
44%bcond_with asap_codec # ASAP ADPCM support
45%bcond_with gles # OpenGLES rendering
46%bcond_without libbluray # libbluray support
47%bcond_without mid # MID support
48%bcond_with profiling # gprof profiling
49%bcond_with tegra # Tegra2 arm
50%bcond_with wayland # wayland
ceb94d36 51# System libs:
6e5f6f0e 52%bcond_without system_ffmpeg # build with system ffmpeg
900271e7 53%bcond_with system_dvdread # build with system dvdread
92b96980 54
6b5f5f8f 55%define codename Krypton
d61811e9 56Summary: Kodi is a free and open source media-player and entertainment hub
92b53b2c 57Name: kodi
6b5f5f8f 58Version: 17.6
fd935248 59Release: 1
68612b1e 60License: GPL v2+ and GPL v3+
18b90c81 61Group: Applications/Multimedia
b7bd3c34
ER
62#Source0: http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
63Source0: https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
6b5f5f8f 64# Source0-md5: a64c2fc56ddc41b9b0dded55eaabf170
d2f0f4c7 65Patch0: jpeglib-boolean.patch
af2a7b89 66Patch1: disable-static.patch
e25cf996 67Patch2: dvdread.patch
3b89f97e
JR
68Patch3: ffmpeg3.patch
69Patch4: gcc5.patch
900271e7 70Patch5: libdvd.patch
92b53b2c 71URL: http://kodi.tv/
a7c53f4c 72BuildRequires: Mesa-libEGL-devel
8fa5c2e4 73BuildRequires: OpenGL-GLU-devel
b85db44b 74BuildRequires: OpenGL-devel
658b3aff 75BuildRequires: SDL2-devel
18b90c81 76BuildRequires: alsa-lib-devel
8fa5c2e4 77BuildRequires: autoconf >= 2.59
18b90c81
SP
78BuildRequires: automake
79BuildRequires: avahi-devel
b85db44b 80BuildRequires: bluez-libs-devel >= 4.99
5a2f2b01 81BuildRequires: boost-devel
18b90c81
SP
82BuildRequires: bzip2-devel
83BuildRequires: cmake
c3c3c480 84BuildRequires: crossguid-devel
18b90c81
SP
85BuildRequires: curl-devel
86BuildRequires: dbus-devel
6069f65f 87BuildRequires: dcadec-devel
501e1d3e 88BuildRequires: doxygen
8fa5c2e4 89# libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
64d462c0 90%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.4.4}
5a2f2b01 91BuildRequires: flac-devel
18b90c81
SP
92BuildRequires: fontconfig-devel
93BuildRequires: freetype-devel
94BuildRequires: fribidi-devel
95BuildRequires: gawk
63ff963e 96BuildRequires: gettext-autopoint
0747666f 97BuildRequires: gettext-tools
a1f637af 98BuildRequires: giflib-devel
3a358a3c 99%{?with_libgif:BuildRequires: giflib-devel}
18b90c81
SP
100BuildRequires: glew-devel
101BuildRequires: gperf
5a2f2b01 102BuildRequires: jasper-devel
37fbe511 103BuildRequires: jre
b85db44b 104BuildRequires: libass-devel
a7c53f4c 105BuildRequires: libatomic-devel
296d79de 106BuildRequires: libbluray-devel >= 0.7.0
37fbe511 107BuildRequires: libcap-devel
18b90c81 108BuildRequires: libcdio-devel
8fa5c2e4
JB
109%{?with_libcec:BuildRequires: libcec-devel >= 3.0.0}
110BuildRequires: libdrm-devel
e25cf996 111%{?with_system_dvdread:BuildRequires: libdvdread-devel}
1aef2bca 112%ifarch i686 pentium4 athlon %{x8664}
5f83fc0f 113BuildRequires: libcrystalhd-devel
1aef2bca 114%endif
b85db44b 115BuildRequires: libgcrypt-devel
18b90c81 116BuildRequires: libjpeg-devel
45a200ab 117BuildRequires: libltdl-devel
63ff963e 118BuildRequires: libmicrohttpd-devel
63ff963e 119BuildRequires: libmodplug-devel
c462fd57 120BuildRequires: libmpeg2-devel
18b90c81 121BuildRequires: libogg-devel
b85db44b 122BuildRequires: libplist-devel
5a2f2b01 123BuildRequires: libpng-devel
b85db44b 124BuildRequires: librtmp-devel
18b90c81
SP
125BuildRequires: libsamplerate-devel
126BuildRequires: libsmbclient-devel
b85db44b 127BuildRequires: libssh-devel
8fa5c2e4 128BuildRequires: libstdc++-devel
5a2f2b01 129BuildRequires: libtiff-devel
130BuildRequires: libtool
f99f2533 131BuildRequires: libuuid-devel
b85db44b 132BuildRequires: libva-devel
f99f2533 133BuildRequires: libva-x11-devel
5a2f2b01 134BuildRequires: libvdpau-devel
18b90c81 135BuildRequires: libvorbis-devel
8fa5c2e4 136BuildRequires: libxml2-devel >= 2.0
501e1d3e 137BuildRequires: libxslt-devel
5a2f2b01 138BuildRequires: lzo-devel
139BuildRequires: mysql-devel
c1b45330 140%ifarch %{ix86}
26cae375 141BuildRequires: nasm
c1b45330 142%endif
18b90c81 143BuildRequires: openssl-devel
63ff963e 144BuildRequires: pcre-cxx-devel
5a2f2b01 145BuildRequires: pkgconfig
8fa5c2e4
JB
146BuildRequires: pulseaudio-devel >= 1.0
147BuildRequires: python-devel >= 1:2.6
3a71016a 148BuildRequires: rpm-pythonprov
6f41c837 149BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 150BuildRequires: sed >= 4.0
18b90c81 151BuildRequires: sqlite3-devel
37fbe511
KK
152BuildRequires: swig
153BuildRequires: taglib-devel >= 1.8
8fa5c2e4 154BuildRequires: tinyxml-devel >= 2.6.2
b85db44b 155BuildRequires: udev-devel
5a2f2b01 156BuildRequires: unzip
b85db44b
AF
157BuildRequires: xorg-lib-libX11-devel
158BuildRequires: xorg-lib-libXext-devel
18b90c81 159BuildRequires: xorg-lib-libXrandr-devel
8fa5c2e4 160BuildRequires: yajl-devel >= 2
18b90c81
SP
161BuildRequires: zip
162BuildRequires: zlib-devel
af2a7b89
JR
163# kodi uses it's own, modified squish
164BuildConflicts: squish-devel
b85db44b 165#https://github.com/sahlberg/libnfs
57d594cf 166BuildRequires: libnfs-devel
b85db44b
AF
167#http://sites.google.com/site/alexthepuffin/home
168#BuildRequires: afpfs-ng-devel
8fa5c2e4 169#BuildRequires: shairplay-devel
63ff963e 170Requires: /usr/bin/glxinfo
f4f8f308 171Requires: SDL >= 1.2.14-5
a58652d4
SP
172Requires: lsb-release
173Requires: xorg-app-xdpyinfo
06c1bb12 174# dlopened libraries:
d61811e9 175# grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
06c1bb12
ER
176Requires: curl-libs
177Requires: libass
178Requires: libbluray
179Requires: libmodplug
180Requires: libmpeg2-libs
181Requires: libogg
182Requires: libplist
183Requires: libvorbis
92b53b2c 184Obsoletes: xbmc < 14.0
18b90c81
SP
185BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
186
187%description
d61811e9
ER
188Kodi Entertainment Center (formerly XBMC) is a free and open-source
189media player software developed by the XBMC Foundation, a non-profit
190technology consortium. Kodi is available for multiple operating
191systems and hardware platforms, with a software 10-foot user interface
192for use with televisions and remote controls. It allows users to play
193and view most videos, music, such as podcasts from the internet, and
194all common digital media files from local and network storage media.
18b90c81
SP
195
196%prep
92b53b2c 197%setup -q -n xbmc-%{version}-%{codename}
6b5f5f8f 198#%patch0 -p1
af2a7b89 199%patch1 -p1
900271e7 200%{?with_system_dvdread:%patch2 -p1}
6b5f5f8f
ER
201#%patch3 -p1
202#%patch4 -p1
900271e7 203%{!?with_system_dvdread:%patch5 -p1}
18b90c81 204
6b5f5f8f 205#%{__rm} -r lib/cximage-6.0/zlib
8fa5c2e4 206#%{__rm} -r lib/libhdhomerun
6b5f5f8f
ER
207#%{__rm} -r lib/libmpeg2
208#%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
209#%{__rm} -r lib/libbluray
b2628f52 210#%{__rm} -r lib/librtmp
8fa5c2e4 211%{__rm} -r lib/win32
b2628f52 212#%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
5d47de93 213
72cf5436 214%if %{without system_ffmpeg}
c3c3c480 215#ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
928406b7
ER
216%endif
217
18b90c81 218%build
b2628f52
ER
219#%{__make} -C tools/depends/native/libsquish-native \
220# CXX="%{__cxx}"
c3c3c480 221
18b90c81 222./bootstrap
65712ad3 223%configure \
57d594cf 224 ac_cv_type__Bool=yes \
ace9791d 225 --disable-silent-rules \
51b524ca 226 --disable-debug \
ace9791d 227 --disable-ccache \
928406b7 228 --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
c0d69361
ER
229 %{__enable_disable afpclient} \
230 %{__enable_disable airplay} \
231 %{__enable_disable airtunes} \
ceb94d36 232 %{__enable_disable alsa} \
e148a10d 233 %{__enable_disable asap_codec asap-codec} \
ceb94d36
ER
234 %{__enable_disable avahi} \
235 %{__enable_disable dbus} \
98f23c16 236 %{__enable_disable dvdcss} \
e148a10d 237 %{__enable_disable gles} \
98f23c16 238 %{__enable_disable gl} \
98f23c16 239 %{__enable_disable gtest} \
98f23c16 240 %{__enable_disable joystick} \
e148a10d 241 %{__enable_disable libbluray} \
c0d69361 242 %{__enable_disable libcap} \
98f23c16 243 %{__enable_disable libcec} \
296d79de 244 %{__enable_disable libgif} \
c0d69361
ER
245 %{__enable_disable libusb} \
246 %{__enable_disable mdnsembedded} \
e148a10d 247 %{__enable_disable mid} \
ceb94d36 248 %{__enable_disable mysql} \
c0d69361 249 %{__enable_disable nfs} \
ceb94d36 250 %{__enable_disable non_free non-free} \
c0d69361 251 %{__enable_disable openmax} \
ceb94d36 252 %{__enable_disable optical_drive optical-drive} \
e148a10d 253 %{__enable_disable profiling} \
c0d69361 254 %{__enable_disable pulse} \
c0d69361 255 %{__enable_disable rtmp} \
ceb94d36 256 %{__enable_disable samba} \
c0d69361 257 %{__enable_disable sdl} \
ceb94d36 258 %{__enable_disable ssh} \
e148a10d
ER
259 %{__enable_disable tegra} \
260 %{__enable_disable texturepacker} \
c0d69361 261 %{__enable_disable udev} \
ceb94d36 262 %{__enable_disable upnp} \
c0d69361
ER
263 %{__enable_disable vaapi} \
264 %{__enable_disable vdpau} \
265 %{__enable_disable vtbdecoder} \
e148a10d 266 %{__enable_disable wayland} \
ceb94d36 267 %{__enable_disable webserver} \
98f23c16
ER
268 %{__enable_disable x11} \
269 %{__enable_disable xrandr} \
270 %{nil}
68612b1e 271
00f4b5ab 272%{__make} V=1
18b90c81
SP
273
274%install
275rm -rf $RPM_BUILD_ROOT
18b90c81 276%{__make} install \
92b96980 277 DESTDIR=$RPM_BUILD_ROOT
18b90c81 278
25890c53
ER
279%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
280
281# no -devel package yet
282%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
283%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
284
a5bfc3a3
ER
285# no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
286%{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
287%{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
288
18b90c81
SP
289%clean
290rm -rf $RPM_BUILD_ROOT
291
292%files
293%defattr(644,root,root,755)
25890c53
ER
294%doc README.md docs/README.linux
295%attr(755,root,root) %{_bindir}/kodi
296%attr(755,root,root) %{_bindir}/kodi-standalone
18b90c81 297%{_datadir}/%{name}
92b96980 298%attr(755,root,root) %{_libdir}/%{name}
25890c53
ER
299%{_desktopdir}/kodi.desktop
300%{_iconsdir}/hicolor/*/apps/%{name}.png
301%{_datadir}/xsessions/kodi.desktop
302
303# legacy xbmc compatibility links
304%attr(755,root,root) %{_bindir}/xbmc
305%attr(755,root,root) %{_bindir}/xbmc-standalone
25890c53 306%{_datadir}/xsessions/xbmc.desktop
This page took 0.163437 seconds and 4 git commands to generate.