]> git.pld-linux.org Git - packages/kodi.git/blame - kodi.spec
disable-silent-rules does not work, use make V=1
[packages/kodi.git] / kodi.spec
CommitLineData
18b90c81 1# TODO:
3a71016a 2# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 3# - fix linking argument order
92b96980 4# - add and/or fix users/groups permissions
63ff963e 5# - split to subpackages?
928406b7
ER
6# - system ffmpeg (--with-ffmpeg=shared), DVDDemuxFFmpeg.cpp:542:41: error: 'av_read_frame_flush' was not declared in this scope
7# - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
18b90c81 8#
92b96980 9# Conditional build:
ceb94d36 10# Features:
c0d69361
ER
11%bcond_with afpclient # AFP support via libafpclient
12%bcond_without airplay # AirPlay support
13%bcond_with airtunes # AirTunes support
ceb94d36
ER
14%bcond_without alsa # ALSA support (only for linux/freebsd)
15%bcond_without avahi # Avahi support (default is enabled if libavahi-common and libavahi-client is found)
16%bcond_without dbus # DBUS support
17%bcond_without dvdcss # DVDCSS support
98f23c16
ER
18%bcond_without fishbmc # FishBMC visualisation
19%bcond_without gl # OpenGL rendering
20%bcond_without goom # GOOM visualisation
ceb94d36 21%bcond_with gtest # configure Google Test Framework
98f23c16 22%bcond_without joystick # SDL joystick support
c0d69361
ER
23%bcond_without libcap # libcap support
24%bcond_with libcec # libcec support
25%bcond_with libusb # libusb support
26%bcond_with mdnsembedded # mDNSEmbedded support
ceb94d36 27%bcond_without mysql # MySQL
c0d69361 28%bcond_with nfs # NFS support via libnfs
ceb94d36 29%bcond_without non_free # componentents with non-compliant licenses
c0d69361 30%bcond_with openmax # OpenMax decoding, requires OpenGLES
ceb94d36 31%bcond_without optical_drive # optical drive
98f23c16 32%bcond_without projectm # ProjectM visualisation
c0d69361 33%bcond_without pulse # PulseAudio support
98f23c16 34%bcond_without rsxs # really slick X screensavers
c0d69361 35%bcond_without rtmp # RTMP support via librtmp
ceb94d36 36%bcond_without samba # SAMBA support (default is enabled)
c0d69361 37%bcond_without sdl # SDL
98f23c16 38%bcond_without spectrum # Spectrum visualisation
ceb94d36 39%bcond_without ssh # SSH SFTP support (default is enabled)
98f23c16 40%bcond_without texturepacker # texturepacker support
c0d69361 41%bcond_without udev # udev support
ceb94d36 42%bcond_without upnp # UPnP support (default is enabled)
c0d69361
ER
43%bcond_without vaapi # VAAPI decoding
44%bcond_without vdpau # VDPAU decoding
45%bcond_with vtbdecoder # VTBDecoder decoding (VTB Decoder not supported on this platform)
98f23c16 46%bcond_without waveform # Waveform visualisation
ceb94d36 47%bcond_without webserver # webserver
98f23c16
ER
48%bcond_without x11 # x11 'Linux Only'
49%bcond_without xrandr # XRandR support
ceb94d36 50# System libs:
6e5f6f0e 51%bcond_without system_ffmpeg # build with system ffmpeg
e25cf996 52%bcond_without system_dvdread # build with system dvdread
92b96980 53
92b53b2c 54%define codename Helix
d61811e9 55Summary: Kodi is a free and open source media-player and entertainment hub
92b53b2c
ER
56Name: kodi
57Version: 14.0
58Release: 0.1
68612b1e 59License: GPL v2+ and GPL v3+
18b90c81 60Group: Applications/Multimedia
92b53b2c
ER
61Source0: http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
62# Source0-md5: 9717c539789789b8aeaf1dcfdb9f2c69
72cf5436 63Source1: https://github.com/xbmc/FFmpeg/archive/2.4.4-%{codename}.tar.gz
928406b7 64# Source1-md5: 19b5d29ef6b5a6fc202c652fe3905d9b
d2f0f4c7 65Patch0: jpeglib-boolean.patch
6e5f6f0e 66Patch1: dvddemux-ffmpeg.patch
e25cf996 67Patch2: dvdread.patch
92b53b2c 68URL: http://kodi.tv/
b85db44b
AF
69BuildRequires: Mesa-libGLU-devel
70BuildRequires: OpenGL-devel
658b3aff 71BuildRequires: SDL2-devel
18b90c81
SP
72BuildRequires: SDL_image-devel
73BuildRequires: SDL_mixer-devel
74BuildRequires: alsa-lib-devel
75BuildRequires: autoconf
76BuildRequires: automake
77BuildRequires: avahi-devel
b85db44b 78BuildRequires: bluez-libs-devel >= 4.99
5a2f2b01 79BuildRequires: boost-devel
18b90c81
SP
80BuildRequires: bzip2-devel
81BuildRequires: cmake
82BuildRequires: curl-devel
83BuildRequires: dbus-devel
501e1d3e 84BuildRequires: doxygen
64d462c0 85%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.4.4}
5a2f2b01 86BuildRequires: flac-devel
18b90c81
SP
87BuildRequires: fontconfig-devel
88BuildRequires: freetype-devel
89BuildRequires: fribidi-devel
90BuildRequires: gawk
63ff963e 91BuildRequires: gettext-autopoint
0747666f 92BuildRequires: gettext-tools
18b90c81
SP
93BuildRequires: glew-devel
94BuildRequires: gperf
5a2f2b01 95BuildRequires: jasper-devel
37fbe511 96BuildRequires: jre
b85db44b 97BuildRequires: libass-devel
37fbe511
KK
98BuildRequires: libbluray-devel >= 0.2.1
99BuildRequires: libcap-devel
18b90c81 100BuildRequires: libcdio-devel
c0d69361 101%{?with_libcec:BuildRequires: libcec-devel}
e25cf996 102%{?with_system_dvdread:BuildRequires: libdvdread-devel}
1aef2bca 103%ifarch i686 pentium4 athlon %{x8664}
5f83fc0f 104BuildRequires: libcrystalhd-devel
1aef2bca 105%endif
b85db44b 106BuildRequires: libgcrypt-devel
18b90c81 107BuildRequires: libjpeg-devel
45a200ab 108BuildRequires: libltdl-devel
18b90c81 109BuildRequires: libmad-devel
63ff963e 110BuildRequires: libmicrohttpd-devel
63ff963e 111BuildRequires: libmodplug-devel
c462fd57 112BuildRequires: libmpeg2-devel
18b90c81 113BuildRequires: libogg-devel
b85db44b 114BuildRequires: libplist-devel
5a2f2b01 115BuildRequires: libpng-devel
b85db44b 116BuildRequires: librtmp-devel
18b90c81
SP
117BuildRequires: libsamplerate-devel
118BuildRequires: libsmbclient-devel
b85db44b 119BuildRequires: libssh-devel
5a2f2b01 120BuildRequires: libtiff-devel
121BuildRequires: libtool
b85db44b 122BuildRequires: libva-devel
5f83fc0f 123BuildRequires: libva-glx-devel
5a2f2b01 124BuildRequires: libvdpau-devel
18b90c81 125BuildRequires: libvorbis-devel
501e1d3e 126BuildRequires: libxslt-devel
5a2f2b01 127BuildRequires: lzo-devel
128BuildRequires: mysql-devel
c1b45330 129%ifarch %{ix86}
26cae375 130BuildRequires: nasm
c1b45330 131%endif
18b90c81 132BuildRequires: openssl-devel
63ff963e 133BuildRequires: pcre-cxx-devel
5a2f2b01 134BuildRequires: pkgconfig
18b90c81 135BuildRequires: pulseaudio-devel
b85db44b 136BuildRequires: python-devel >= 2.4
3a71016a 137BuildRequires: rpm-pythonprov
6f41c837 138BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 139BuildRequires: sed >= 4.0
18b90c81 140BuildRequires: sqlite3-devel
37fbe511
KK
141BuildRequires: swig
142BuildRequires: taglib-devel >= 1.8
7613a43d 143BuildRequires: tinyxml-devel
b85db44b 144BuildRequires: udev-devel
5a2f2b01 145BuildRequires: unzip
b85db44b
AF
146BuildRequires: xorg-lib-libX11-devel
147BuildRequires: xorg-lib-libXext-devel
5a2f2b01 148BuildRequires: xorg-lib-libXinerama-devel
b85db44b 149BuildRequires: xorg-lib-libXmu-devel
18b90c81 150BuildRequires: xorg-lib-libXrandr-devel
b85db44b 151BuildRequires: xorg-lib-libXt-devel
5a2f2b01 152BuildRequires: xorg-lib-libXtst-devel
b85db44b 153BuildRequires: yajl-devel
501e1d3e 154BuildRequires: yasm
18b90c81
SP
155BuildRequires: zip
156BuildRequires: zlib-devel
b85db44b
AF
157#https://github.com/sahlberg/libnfs
158#BuildRequires: libnfs-devel
159#http://sites.google.com/site/alexthepuffin/home
160#BuildRequires: afpfs-ng-devel
161#http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
162#https://github.com/albertz/shairport
163#BuildRequires: libshairport
63ff963e 164Requires: /usr/bin/glxinfo
f4f8f308 165Requires: SDL >= 1.2.14-5
a58652d4
SP
166Requires: lsb-release
167Requires: xorg-app-xdpyinfo
06c1bb12 168# dlopened libraries:
d61811e9 169# grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
06c1bb12
ER
170Requires: curl-libs
171Requires: libass
172Requires: libbluray
173Requires: libmodplug
174Requires: libmpeg2-libs
175Requires: libogg
176Requires: libplist
177Requires: libvorbis
92b53b2c 178Obsoletes: xbmc < 14.0
18b90c81
SP
179BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
180
181%description
d61811e9
ER
182Kodi Entertainment Center (formerly XBMC) is a free and open-source
183media player software developed by the XBMC Foundation, a non-profit
184technology consortium. Kodi is available for multiple operating
185systems and hardware platforms, with a software 10-foot user interface
186for use with televisions and remote controls. It allows users to play
187and view most videos, music, such as podcasts from the internet, and
188all common digital media files from local and network storage media.
18b90c81
SP
189
190%prep
92b53b2c 191%setup -q -n xbmc-%{version}-%{codename}
bfa116d7 192%patch0 -p1
6e5f6f0e 193%patch1 -p0
18b90c81 194
5d47de93
ER
195rm -r lib/cximage-6.0/zlib
196#rm -r lib/libhdhomerun
197rm -r lib/libmpeg2
198rm -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
199rm -r lib/enca
200rm -r lib/libbluray
201rm -r lib/libmicrohttpd
202rm -r lib/libmodplug
203rm -r lib/librtmp
204rm -r lib/win32
205
72cf5436
ER
206%if %{without system_ffmpeg}
207ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
928406b7 208%endif
e25cf996
ER
209%if %{with system_dvdread}
210#rm -r lib/libdvd/libdvdread
211%endif
928406b7 212
18b90c81
SP
213%build
214./bootstrap
65712ad3 215%configure \
ace9791d 216 --disable-silent-rules \
51b524ca 217 --disable-debug \
ace9791d 218 --disable-ccache \
928406b7 219 --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
c0d69361
ER
220 %{__enable_disable afpclient} \
221 %{__enable_disable airplay} \
222 %{__enable_disable airtunes} \
ceb94d36
ER
223 %{__enable_disable alsa} \
224 %{__enable_disable avahi} \
225 %{__enable_disable dbus} \
98f23c16
ER
226 %{__enable_disable dvdcss} \
227 %{__enable_disable fishbmc} \
228 %{__enable_disable gl} \
b85db44b 229 %{__enable_disable goom} \
98f23c16 230 %{__enable_disable gtest} \
dc0a03c5 231 %{__enable_disable texturepacker} \
98f23c16 232 %{__enable_disable joystick} \
c0d69361 233 %{__enable_disable libcap} \
98f23c16 234 %{__enable_disable libcec} \
c0d69361
ER
235 %{__enable_disable libusb} \
236 %{__enable_disable mdnsembedded} \
ceb94d36 237 %{__enable_disable mysql} \
c0d69361 238 %{__enable_disable nfs} \
ceb94d36 239 %{__enable_disable non_free non-free} \
c0d69361 240 %{__enable_disable openmax} \
ceb94d36 241 %{__enable_disable optical_drive optical-drive} \
98f23c16 242 %{__enable_disable projectm} \
c0d69361 243 %{__enable_disable pulse} \
98f23c16 244 %{__enable_disable rsxs} \
c0d69361 245 %{__enable_disable rtmp} \
ceb94d36 246 %{__enable_disable samba} \
c0d69361 247 %{__enable_disable sdl} \
98f23c16 248 %{__enable_disable spectrum} \
ceb94d36 249 %{__enable_disable ssh} \
c0d69361 250 %{__enable_disable udev} \
ceb94d36 251 %{__enable_disable upnp} \
c0d69361
ER
252 %{__enable_disable vaapi} \
253 %{__enable_disable vdpau} \
254 %{__enable_disable vtbdecoder} \
98f23c16 255 %{__enable_disable waveform} \
ceb94d36 256 %{__enable_disable webserver} \
98f23c16
ER
257 %{__enable_disable x11} \
258 %{__enable_disable xrandr} \
259 %{nil}
68612b1e 260
00f4b5ab 261%{__make} V=1
18b90c81
SP
262
263%install
264rm -rf $RPM_BUILD_ROOT
18b90c81 265%{__make} install \
92b96980 266 DESTDIR=$RPM_BUILD_ROOT
18b90c81 267
25890c53
ER
268%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
269
270# no -devel package yet
271%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
272%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
273
18b90c81
SP
274%clean
275rm -rf $RPM_BUILD_ROOT
276
277%files
278%defattr(644,root,root,755)
25890c53
ER
279%doc README.md docs/README.linux
280%attr(755,root,root) %{_bindir}/kodi
281%attr(755,root,root) %{_bindir}/kodi-standalone
18b90c81 282%{_datadir}/%{name}
92b96980 283%attr(755,root,root) %{_libdir}/%{name}
25890c53
ER
284%{_desktopdir}/kodi.desktop
285%{_iconsdir}/hicolor/*/apps/%{name}.png
286%{_datadir}/xsessions/kodi.desktop
287
288# legacy xbmc compatibility links
289%attr(755,root,root) %{_bindir}/xbmc
290%attr(755,root,root) %{_bindir}/xbmc-standalone
291%{_libdir}/xbmc
292%{_datadir}/xbmc
293%{_datadir}/xsessions/xbmc.desktop
This page took 3.104025 seconds and 4 git commands to generate.