]> git.pld-linux.org Git - packages/kodi-addon-inputstream-adaptive.git/blob - kodi-addon-inputstream-adaptive.spec
new
[packages/kodi-addon-inputstream-adaptive.git] / kodi-addon-inputstream-adaptive.spec
1 %define         kodi_ver        19
2 %define         next_kodi_ver   %(echo $((%{kodi_ver}+1)))
3 %define         codename        Matrix
4 %define         addon           inputstream.adaptive
5
6 Summary:        Kodi InputStream addon for several manifest types
7 Name:           kodi-addon-inputstream-adaptive
8 Version:        %{kodi_ver}.0.2
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/Multimedia
12 Source0:        https://github.com/xbmc/inputstream.adaptive/archive/%{version}-%{codename}/%{version}-%{codename}.tar.gz
13 # Source0-md5:  1bfb4731c249e01535c2c4054e0e4ea6
14 URL:            https://github.com/xbmc/inputstream.adaptive
15 BuildRequires:  cmake >= 3.10
16 BuildRequires:  expat-devel
17 BuildRequires:  kodi-devel >= %{kodi_ver}
18 BuildRequires:  kodi-devel < %{next_kodi_ver}
19 BuildRequires:  libstdc++-devel >= 6:7
20 BuildRequires:  rpmbuild(macros) >= 1.605
21 Requires:       kodi >= %{kodi_ver}
22 Requires:       kodi < %{next_kodi_ver}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Kodi InputStream addon for several manifest types
27
28 %prep
29 %setup -q -n %{addon}-%{version}-%{codename}
30
31 %build
32 %cmake -B build \
33         -DBUILD_TESTING:BOOL=OFF
34 %{__make} -C build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %{__make} -C build install \
39         DESTDIR=$RPM_BUILD_ROOT
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %dir %{_libdir}/kodi/addons/%{addon}
47 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/%{addon}.so.%{version}
48 %attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/libssd_wv.so
49 %dir %{_datadir}/kodi/addons/%{addon}
50 %{_datadir}/kodi/addons/%{addon}/addon.xml
51 %{_datadir}/kodi/addons/%{addon}/resources
This page took 0.079695 seconds and 3 git commands to generate.