]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
- add kde-ac260-lt.patch; rel 2
[packages/kmplayer.git] / kmplayer.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # Do not build kgstplayer
4 %bcond_with     koffice         # Build koffice plugin
5 %bcond_without  xine            # Do not build kxineplayer
6 #
7 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
8 Summary(pl):    Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
9 Name:           kmplayer
10 Version:        0.9.3a
11 Release:        2
12 Epoch:          2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 # http://kmplayer.kde.org/pkgs/kmplayer-0.9.3-pre1.tar.bz2
16 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  d18749a254af3d54dd10ce651975527c
18 Patch0:         kde-common-PLD.patch
19 Patch1:         kde-ac260-lt.patch
20 URL:            http://kmplayer.kde.org/
21 BuildRequires:  arts-qt-devel
22 BuildRequires:  artsc-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  gettext-devel
26 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10.0}
27 BuildRequires:  kdelibs-devel >= 9:3.5.3
28 %{?with_koffice:BuildRequires:  koffice-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.129
31 BuildRequires:  sed >= 4.0
32 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
33 Requires:       kdebase-core >= 9:3.5.3
34 Requires:       kdelibs >= 9:3.5.3
35 Requires:       mplayer
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
40 GUI.
41
42 %description -l pl
43 W pe³ni zintegrowany z KDE frontend dla programów
44 MPlayer/Xine/ffmpeg/ffserver/VDR.
45
46 %package gstreamer
47 Summary:        Gstreamer wrapper
48 Summary(pl):    Wrapper gstreamera
49 Group:          X11/Applications/Multimedia
50 Requires:       %{name} = %{epoch}:%{version}-%{release}
51
52 %description gstreamer
53 Gstreamer wrapper.
54
55 %description gstreamer -l pl
56 Wrapper gstreamera.
57
58 %package koffice
59 Summary:        Kmplayer integration with Koffice
60 Summary(pl):    Integracja kmplayera z koffice
61 Group:          X11/Applications/Multimedia
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63 Requires:       koffice-common
64
65 %description koffice
66 Kmplayer integration with Koffice.
67
68 %description koffice -l pl
69 Integracja kmplayera z koffice.
70
71 %package xine
72 Summary:        Xine wrapper
73 Summary(pl):    Wrapper xine
74 Group:          X11/Applications/Multimedia
75 Requires:       %{name} = %{epoch}:%{version}-%{release}
76
77 %description xine
78 Xine wrapper.
79
80 %description xine -l pl
81 Wrapper xine.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
89         src/kmplayer.desktop
90
91 %build
92 cp /usr/share/automake/config.sub admin
93 %{__autoconf}
94
95 #%{__make} -f admin/Makefile.common cvs
96
97 %configure \
98         --disable-rpath \
99         --enable-final \
100         %{?with_koffice:--enable-koffice-plugin} \
101         %{!?with_gstreamer:--without-gstreamer} \
102         %{!?with_xine:--without-xine} \
103         --with-qt-libraries=%{_libdir}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         kde_htmldir=%{_kdedocdir}
113
114 # remove bogus translation
115 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
116
117 # already in kdelibs
118 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
119
120 %find_lang %{name} --with-kde
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog README
128 %attr(755,root,root) %{_bindir}/kmplayer
129 %attr(755,root,root) %{_bindir}/kxvplayer
130 %{_libdir}/libkdeinit_kmplayer.la
131 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
132 %{_libdir}/libkmplayercommon.la
133 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
134 %{_libdir}/kde3/kmplayer.la
135 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
136 %{_libdir}/kde3/libkmplayerpart.la
137 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
138 %{_datadir}/apps/kmplayer
139 %{_datadir}/config/kmplayerrc
140 %{_datadir}/mimelnk/application/x-kmplayer.desktop
141 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
142 %{_datadir}/services/kmplayer_part.desktop
143 %{_desktopdir}/kde/kmplayer.desktop
144 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
145
146 %if %{with gstreamer}
147 %files gstreamer
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/kgstplayer
150 %endif
151
152 %if %{with koffice}
153 %files koffice
154 %defattr(644,root,root,755)
155 %{_libdir}/kde3/libkmplayerkofficepart.la
156 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
157 %{_datadir}/services/kmplayer_koffice.desktop
158 %endif
159
160 %if %{with xine}
161 %files xine
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/kxineplayer
164 %endif
This page took 0.203556 seconds and 3 git commands to generate.