]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
2891277bd036ed20da99f6628d45c1029df1d38d
[packages/kmplayer.git] / kmplayer.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # Do not build kgstplayer
4 %bcond_with     koffice         # Build koffice plugin
5 %bcond_without  xine            # Do not build kxineplayer
6 #
7 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
8 Summary(pl):    Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
9 Name:           kmplayer
10 Version:        0.9.3a
11 Release:        1
12 Epoch:          2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 # http://kmplayer.kde.org/pkgs/kmplayer-0.9.3-pre1.tar.bz2
16 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  d18749a254af3d54dd10ce651975527c
18 Patch0:         kde-common-PLD.patch
19 URL:            http://kmplayer.kde.org/
20 BuildRequires:  arts-qt-devel
21 BuildRequires:  artsc-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gettext-devel
25 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10.0}
26 BuildRequires:  kdelibs-devel >= 9:3.5.3
27 %{?with_koffice:BuildRequires:  koffice-devel}
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.129
30 BuildRequires:  sed >= 4.0
31 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
32 Requires:       kdebase-core >= 9:3.5.3
33 Requires:       kdelibs >= 9:3.5.3
34 Requires:       mplayer
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
39 GUI.
40
41 %description -l pl
42 W pe³ni zintegrowany z KDE frontend dla programów
43 MPlayer/Xine/ffmpeg/ffserver/VDR.
44
45 %package gstreamer
46 Summary:        Gstreamer wrapper
47 Summary(pl):    Wrapper gstreamera
48 Group:          X11/Applications/Multimedia
49 Requires:       %{name} = %{epoch}:%{version}-%{release}
50
51 %description gstreamer
52 Gstreamer wrapper.
53
54 %description gstreamer -l pl
55 Wrapper gstreamera.
56
57 %package koffice
58 Summary:        Kmplayer integration with Koffice
59 Summary(pl):    Integracja kmplayera z koffice
60 Group:          X11/Applications/Multimedia
61 Requires:       %{name} = %{epoch}:%{version}-%{release}
62 Requires:       koffice-common
63
64 %description koffice
65 Kmplayer integration with Koffice.
66
67 %description koffice -l pl
68 Integracja kmplayera z koffice.
69
70 %package xine
71 Summary:        Xine wrapper
72 Summary(pl):    Wrapper xine
73 Group:          X11/Applications/Multimedia
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75
76 %description xine
77 Xine wrapper.
78
79 %description xine -l pl
80 Wrapper xine.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85
86 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
87         src/kmplayer.desktop
88
89 %build
90 cp /usr/share/automake/config.sub admin
91 %{__autoconf}
92
93 #%{__make} -f admin/Makefile.common cvs
94
95 %configure \
96         --disable-rpath \
97         --enable-final \
98         %{?with_koffice:--enable-koffice-plugin} \
99         %{!?with_gstreamer:--without-gstreamer} \
100         %{!?with_xine:--without-xine} \
101         --with-qt-libraries=%{_libdir}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         kde_htmldir=%{_kdedocdir}
111
112 # remove bogus translation
113 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
114
115 # already in kdelibs
116 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
117
118 %find_lang %{name} --with-kde
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog README
126 %attr(755,root,root) %{_bindir}/kmplayer
127 %attr(755,root,root) %{_bindir}/kxvplayer
128 %{_libdir}/libkdeinit_kmplayer.la
129 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
130 %{_libdir}/libkmplayercommon.la
131 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
132 %{_libdir}/kde3/kmplayer.la
133 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
134 %{_libdir}/kde3/libkmplayerpart.la
135 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
136 %{_datadir}/apps/kmplayer
137 %{_datadir}/config/kmplayerrc
138 %{_datadir}/mimelnk/application/x-kmplayer.desktop
139 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
140 %{_datadir}/services/kmplayer_part.desktop
141 %{_desktopdir}/kde/kmplayer.desktop
142 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
143
144 %if %{with gstreamer}
145 %files gstreamer
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/kgstplayer
148 %endif
149
150 %if %{with koffice}
151 %files koffice
152 %defattr(644,root,root,755)
153 %{_libdir}/kde3/libkmplayerkofficepart.la
154 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
155 %{_datadir}/services/kmplayer_koffice.desktop
156 %endif
157
158 %if %{with xine}
159 %files xine
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/kxineplayer
162 %endif
This page took 0.039501 seconds and 2 git commands to generate.