]> git.pld-linux.org Git - packages/klibc.git/commitdiff
- fix undefined ksh behaviour -> test with >= 4 arguments.
authorPaweł Sikora <pluto@pld-linux.org>
Fri, 30 Sep 2005 19:51:02 +0000 (19:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  http://www.opengroup.org/onlinepubs/009695399/utilities/test.html
  catched error: ./mkbuiltins[122]: [: #: unexpected operator/operand

Changed files:
    klibc-ksh-syntax.patch -> 1.1
    klibc.spec -> 1.44

klibc-ksh-syntax.patch [new file with mode: 0644]
klibc.spec

diff --git a/klibc-ksh-syntax.patch b/klibc-ksh-syntax.patch
new file mode 100644 (file)
index 0000000..74af5ab
--- /dev/null
@@ -0,0 +1,16 @@
+This patch fixes undefined ksh behaviour -> test with >= 4 arguments.
+( http://www.opengroup.org/onlinepubs/009695399/utilities/test.html )
+
+catched error: ./mkbuiltins[122]: [: #: unexpected operator/operand
+
+--- klibc-1.1.1/ash/mkbuiltins.orig    2005-09-06 22:49:34.000000000 +0200
++++ klibc-1.1.1/ash/mkbuiltins 2005-09-30 21:41:07.909992750 +0200
+@@ -108,7 +108,7 @@
+       }
+       echo 'int '"$func"'(int, char **);' >&4
+       while
+-              [ $# != 0 -a "$1" != '#' ]
++              [ $# != 0 ] && [ "$1" != '#' ]
+       do
+               [ "$1" = '-s' ] && {
+                       specials="$specials $2 $func"
index 171eb23ca3a2d2273a3ea2d07a7cd0f080378dcc..f7e86a04fc6f39224a8b9e2b4575d229646c435c 100644 (file)
@@ -18,6 +18,7 @@ Source0:      http://www.kernel.org/pub/linux/libs/klibc/Testing/%{name}-%{version}.t
 Patch0:                %{name}-ksh-quotation.patch
 Patch1:                %{name}-klcc.patch
 Patch2:                %{name}-fstype_jfs.patch
+Patch3:                %{name}-ksh-syntax.patch
 URL:           http://www.zytor.com/mailman/listinfo/klibc/
 %{?with_dist_kernel:BuildRequires:     kernel-headers >= 2.4}
 BuildRequires: rpmbuild(macros) >= 1.153
@@ -92,6 +93,7 @@ Narz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
+%patch3 -p1
 
 %build
 cd include
This page took 0.09604 seconds and 4 git commands to generate.