]> git.pld-linux.org Git - packages/kicad.git/commitdiff
- updated to 5.1.9 auto/th/kicad-5.1.9-1
authorBartek Szady <bszx@bszx.eu>
Sun, 3 Jan 2021 19:09:58 +0000 (20:09 +0100)
committerBartek Szady <bszx@bszx.eu>
Sun, 3 Jan 2021 19:09:58 +0000 (20:09 +0100)
gerbview.patch [deleted file]
kicad.spec

diff --git a/gerbview.patch b/gerbview.patch
deleted file mode 100644 (file)
index eb8cbef..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-commit 51708bab499464d164241ea486c288f653b95320
-Author: jean-pierre charras <jp.charras@wanadoo.fr>
-Date:   Mon Nov 9 10:32:12 2020 +0100
-
-    Gerbview, Legacy graphic mode: fix missing or incorrect inits related to zoom.
-    
-    Fixes #6326
-    https://gitlab.com/kicad/code/kicad/issues/6326
-
-diff --git a/gerbview/files.cpp b/gerbview/files.cpp
-index c6b555f36..a10c191f5 100644
---- a/gerbview/files.cpp
-+++ b/gerbview/files.cpp
-@@ -57,6 +57,8 @@ void GERBVIEW_FRAME::OnGbrFileHistory( wxCommandEvent& event )
-     {
-         Erase_Current_DrawLayer( false );
-         LoadGerberFiles( fn );
-+        Zoom_Automatique( false );
-+        m_canvas->Refresh();
-     }
- }
-@@ -71,6 +73,8 @@ void GERBVIEW_FRAME::OnDrlFileHistory( wxCommandEvent& event )
-     {
-         Erase_Current_DrawLayer( false );
-         LoadExcellonFiles( fn );
-+        Zoom_Automatique( false );
-+        m_canvas->Refresh();
-     }
- }
-@@ -84,6 +88,8 @@ void GERBVIEW_FRAME::OnZipFileHistory( wxCommandEvent& event )
-     {
-         Erase_Current_DrawLayer( false );
-         LoadZipArchiveFile( filename );
-+        Zoom_Automatique( false );
-+        m_canvas->Refresh();
-     }
- }
-@@ -93,7 +99,11 @@ void GERBVIEW_FRAME::OnJobFileHistory( wxCommandEvent& event )
-     wxString filename = GetFileFromHistory( event.GetId(), _( "Job files" ), &m_jobFileHistory );
-     if( !filename.IsEmpty() )
-+    {
-         LoadGerberJobFile( filename );
-+        Zoom_Automatique( false );
-+        m_canvas->Refresh();
-+    }
- }
-@@ -106,7 +116,9 @@ void GERBVIEW_FRAME::Files_io( wxCommandEvent& event )
-     {
-     case wxID_FILE:
-         LoadGerberFiles( wxEmptyString );
--        break;
-+        Zoom_Automatique( false );
-+        m_canvas->Refresh();
-+       break;
-     case ID_GERBVIEW_ERASE_ALL:
-         Clear_DrawLayers( false );
-@@ -148,21 +160,26 @@ void GERBVIEW_FRAME::Files_io( wxCommandEvent& event )
-         // Load the layers from stored paths
-         wxBusyCursor wait;
-         loadListOfGerberAndDrillFiles( wxEmptyString, listOfGerberFiles, &fileType );
-+        Zoom_Automatique( false );
-+        m_canvas->Refresh();
-     }
-     break;
-     case ID_GERBVIEW_LOAD_DRILL_FILE:
-         LoadExcellonFiles( wxEmptyString );
-+        Zoom_Automatique( false );
-         m_canvas->Refresh();
-         break;
-     case ID_GERBVIEW_LOAD_ZIP_ARCHIVE_FILE:
-         LoadZipArchiveFile( wxEmptyString );
-+        Zoom_Automatique( false );
-         m_canvas->Refresh();
-         break;
-     case ID_GERBVIEW_LOAD_JOB_FILE:
-         LoadGerberJobFile( wxEmptyString );
-+        Zoom_Automatique( false );
-         m_canvas->Refresh();
-         break;
-@@ -373,8 +390,6 @@ bool GERBVIEW_FRAME::loadListOfGerberAndDrillFiles( const wxString& aPath,
-     SetVisibleLayers( visibility );
--    Zoom_Automatique( false );
--
-     // Synchronize layers tools with actual active layer:
-     ReFillLayerWidget();
-@@ -700,8 +715,6 @@ bool GERBVIEW_FRAME::LoadZipArchiveFile( const wxString& aFullFileName )
-     if( filename.IsOk() )
-         unarchiveFiles( filename.GetFullPath(), &reporter );
--    Zoom_Automatique( false );
--
-     // Synchronize layers tools with actual active layer:
-     ReFillLayerWidget();
-     SetActiveLayer( GetActiveLayer() );
-diff --git a/gerbview/gerbview_frame.cpp b/gerbview/gerbview_frame.cpp
-index 6953243e0..890844501 100644
---- a/gerbview/gerbview_frame.cpp
-+++ b/gerbview/gerbview_frame.cpp
-@@ -222,6 +222,7 @@ GERBVIEW_FRAME::GERBVIEW_FRAME( KIWAY* aKiway, wxWindow* aParent ):
-     }
-     else
-     {
-+        UseGalCanvas( false );
-         m_colorsSettings->SetLegacyMode( true );
-         m_canvas->Refresh();
-     }
index 1bf080f3265c1d89b9f852eb55bdf367c6d21eba..1a93f1bff4c61c9174ff861658f2b2076b4ddd0e 100644 (file)
@@ -7,27 +7,26 @@
 Summary:       KiCad - is a GPL'd suite of programs for EDA
 Summary(pl.UTF-8):     KiCad - zestaw programów na licencji GPL zaliczany do kategorii EDA
 Name:          kicad
 Summary:       KiCad - is a GPL'd suite of programs for EDA
 Summary(pl.UTF-8):     KiCad - zestaw programów na licencji GPL zaliczany do kategorii EDA
 Name:          kicad
-Version:       5.1.8
+Version:       5.1.9
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       https://gitlab.com/kicad/code/kicad/-/archive/%{version}/%{name}-%{version}.tar.gz
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       https://gitlab.com/kicad/code/kicad/-/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c573140e521e29441d71f1a39b79752f
+# Source0-md5: b2c2f141b1a6342977b1192702b8d26d
 Source1:       https://gitlab.com/kicad/services/kicad-doc/-/archive/%{version}/%{name}-doc-%{version}.tar.gz
 Source1:       https://gitlab.com/kicad/services/kicad-doc/-/archive/%{version}/%{name}-doc-%{version}.tar.gz
-# Source1-md5: 32fcae80e827453f6a71bba837fdfd0f
+# Source1-md5: a33f909d55443a0fa313544f8a5d91e8
 Source2:       https://gitlab.com/kicad/code/kicad-i18n/-/archive/%{version}/%{name}-i18n-%{version}.tar.gz
 Source2:       https://gitlab.com/kicad/code/kicad-i18n/-/archive/%{version}/%{name}-i18n-%{version}.tar.gz
-# Source2-md5: 792388e3a74410786085314d4069d408
+# Source2-md5: 4fceb1f3080b7db7d66d40d1a61551df
 Source3:       https://gitlab.com/kicad/libraries/kicad-symbols/-/archive/%{version}/%{name}-symbols-%{version}.tar.bz2
 Source3:       https://gitlab.com/kicad/libraries/kicad-symbols/-/archive/%{version}/%{name}-symbols-%{version}.tar.bz2
-# Source3-md5: 35065c2ccd6f08a38a5557caf3ce26e2
+# Source3-md5: 62537b0b9d3492c01aa59ec09d599f58
 Source4:       https://gitlab.com/kicad/libraries/kicad-footprints/-/archive/%{version}/%{name}-footprints-%{version}.tar.bz2
 Source4:       https://gitlab.com/kicad/libraries/kicad-footprints/-/archive/%{version}/%{name}-footprints-%{version}.tar.bz2
-# Source4-md5: 7e6b08b971adba172fff71f3b50f3bdb
+# Source4-md5: ce648b6deb4cea3e2003e43bb07c1477
 Source5:       https://gitlab.com/kicad/libraries/kicad-packages3D/-/archive/%{version}/%{name}-packages3D-%{version}.tar.bz2
 Source5:       https://gitlab.com/kicad/libraries/kicad-packages3D/-/archive/%{version}/%{name}-packages3D-%{version}.tar.bz2
-# Source5-md5: c67bde6af35417e665ade4696d8adb16
+# Source5-md5: ef42e74c7c92303d8853b830a196df3b
 Source6:       https://gitlab.com/kicad/libraries/kicad-templates/-/archive/%{version}/%{name}-templates-%{version}.tar.bz2
 Source6:       https://gitlab.com/kicad/libraries/kicad-templates/-/archive/%{version}/%{name}-templates-%{version}.tar.bz2
-# Source6-md5: 24ae4642eeb0a3c08448d4aa878a5163
+# Source6-md5: 8fa78fabd2d121712875446e0bd05af4
 Patch0:                nostrip.patch
 Patch0:                nostrip.patch
-Patch1:                gerbview.patch
 URL:           http://www.kicad-pcb.org/
 BuildRequires: GLM >= 0.9.9.4
 BuildRequires: OCE-devel
 URL:           http://www.kicad-pcb.org/
 BuildRequires: GLM >= 0.9.9.4
 BuildRequires: OCE-devel
@@ -237,7 +236,6 @@ Documentation and tutorials for Kicad in Chinese.
 
 %prep
 %setup -q -a 1 -a 2 -a 3 -a 4 %{?with_packages3D:-a 5} -a 6
 
 %prep
 %setup -q -a 1 -a 2 -a 3 -a 4 %{?with_packages3D:-a 5} -a 6
-%patch1 -p1
 %patch0 -p1
 
 %build
 %patch0 -p1
 
 %build
This page took 0.186025 seconds and 4 git commands to generate.