]> git.pld-linux.org Git - packages/kicad.git/blob - kicad.spec
- an actually working 64bit fix
[packages/kicad.git] / kicad.spec
1 %define         _release        r304
2 Summary:        KiCad - is a GPL'd suite of programs for EDA
3 Summary(pl.UTF-8):      KiCad jest zestawem programów na licencji GPL zaliczanym do kategorii EDA
4 Name:           kicad
5 Version:        20071004
6 Release:        1
7 License:        GPL
8 Group:          Applications
9 Source0:        http://dl.sourceforge.net/kicad/%{name}-%{version}-%{_release}.tar.bz2
10 # Source0-md5:  8ef6310123e9361c5780d321ec07cc8b
11 URL:            http://kicad.sourceforge.net/
12 BuildRequires:  wxGTK2-unicode-devel
13 BuildRequires:  wxGTK2-unicode-gl-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 KiCad consists of a project manager and four main programs:
18 - kicad - the project manager.
19 - eeschema - the schematic editor.
20 - cvpcb - the footprint selector for components used in the circuit
21   design.
22 - pcbnew - the PCB layout program.
23 - gerbview - the Gerber (photoplotter documents) viewer.
24
25 %description -l pl.UTF-8
26 KiCad składa się z menadżera projektów oraz czterych głównych
27 programów:
28 - kicad - menadżer projektów.
29 - eeschema - edytor schematów.
30 - cvpcb - the footprint selector for components used in the circuit
31   design.
32 - pcbnew - the PCB layout program.
33 - gerbview - the Gerber (photoplotter documents) viewer.
34
35 %prep
36 %setup -q -n %{name}
37 %if "%{_lib}" == "lib64"
38         %{__sed} -i -e "s@/lib/@/lib64/@g" libs.linux
39 %endif
40
41 %build
42 export WX_CONFIG="`which wx-gtk2-unicode-config`"
43 %{__make} -f makefile.gtk \
44         WXXFLAGS="`$WX_CONFIG --cxxflags`" \
45         WXPATH=%{_libdir} \
46 %if "%{_lib}" == "lib64"
47         PREFIX_WX_LIBS="lib64`$WX_CONFIG --basename`" \
48 %else
49         PREFIX_WX_LIBS="lib`$WX_CONFIG --basename`" \
50 %endif
51         SUFFIX_WX_LIBSTD="`$WX_CONFIG --utility=`" \
52         SUFFIX_WX_LIBGL="_gl-`$WX_CONFIG --release`" \
53         LIBVERSION="`$WX_CONFIG --release`" \
54         WXSYSLIB="`$WX_CONFIG --libs std`" \
55         WXSYSLIB_WITH_GL="`$WX_CONFIG --libs std,gl`"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} -f makefile.gtk install \
61         DESTDIR=$RPM_BUILD_ROOT \
62         PREFIX=$RPM_BUILD_ROOT%{_prefix}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc change_log.txt news.txt regex_doc.txt todo.txt version.txt
70 %attr(755,root,root) %{_bindir}/*
71 %{_datadir}/%{name}
72 %{_libdir}/%{name}
73 %{_docdir}/%{name}
This page took 0.072181 seconds and 3 git commands to generate.