]> git.pld-linux.org Git - packages/kicad.git/blob - kicad.spec
- no idea for locales for now, commented according section
[packages/kicad.git] / kicad.spec
1 %define libver 1.0
2 %define docver 1.1
3 Summary:        KiCad - is a GPL'd suite of programs for EDA
4 Summary(pl.UTF-8):      KiCad - zestaw programów na licencji GPL zaliczany do kategorii EDA
5 Name:           kicad
6 Version:        20110429
7 Release:        0.1
8 License:        GPL v2+
9 Group:          X11/Applications
10 Source0:        http://iut-tice.ujf-grenoble.fr/cao/%{name}-sources_2011-04-29-BZR2986.zip
11 # Source0-md5:  e5d5311ad8a6387b1e96a9ee63088238
12 Source1:        http://downloads.sourceforge.net/kicad/%{name}-library-%{libver}.tar.bz2
13 # Source1-md5:  9c91940aa5f5563bb86c52ff07e8f99a
14 Source2:        http://downloads.sourceforge.net/kicad/%{name}-doc-%{docver}.tar.bz2
15 # Source2-md5:  fcfbc94f675a19db51370e97b88803b1
16 Source3:        %{name}.desktop
17 URL:            http://kicad.sourceforge.net/
18 BuildRequires:  boost-devel
19 BuildRequires:  cmake >= 2.6.4
20 BuildRequires:  rpmbuild(macros) >= 1.600
21 BuildRequires:  sed >= 4.0
22 BuildRequires:  which
23 BuildRequires:  wxGTK2-unicode-gl-devel >= 2.8.11
24 BuildRequires:  wxWidgets-devel >= 2.8.11
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 KiCad consists of a project manager and four main programs:
30 - kicad - the project manager.
31 - eeschema - the schematic editor.
32 - cvpcb - the footprint selector for components used in the circuit
33   design.
34 - pcbnew - the PCB layout program.
35 - gerbview - the Gerber (photoplotter documents) viewer.
36
37 %description -l pl.UTF-8
38 KiCad składa się z menadżera projektów oraz czterech głównych
39 programów:
40 - kicad - menadżer projektów.
41 - eeschema - edytor schematów.
42 - cvpcb - narzędzie do wybierania elementów używanych przy
43   projektowaniu płytek drukowanych.
44 - pcbnew - program do projektowania płytek drukowanych.
45 - gerbview - przeglądarka plików Gerber (dokumentów dla fotoplotera).
46
47 %prep
48 %setup -q  -n %{name}_sources
49
50 %build
51 install -d build
52 cd build
53 %cmake \
54         -DKICAD_STABLE_VERSION=ON \
55         -DwxWidgets_USE_STATIC=OFF \
56         -DwxWidgets_CONFIG_EXECUTABLE="%{_bindir}/wx-gtk2-unicode-config" \
57         -DKICAD_MINIZIP=ON \
58         -DKICAD_GOST=ON \
59         ..
60
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build install \
67         KICAD_INTERNAT=$RPM_BUILD_ROOT%{_localedir} \
68         KICAD_PLUGINS=$RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
69         KICAD_DATA=$RPM_BUILD_ROOT%{_datadir}/%{name} \
70         KICAD_DOCS=$RPM_BUILD_ROOT%{_datadir}/%{name}/help \
71         DESTDIR=$RPM_BUILD_ROOT \
72         PREFIX=$RPM_BUILD_ROOT%{_prefix}
73
74 install -d $RPM_BUILD_ROOT%{_desktopdir}
75 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
76
77 #for loc in $RPM_BUILD_ROOT%{_localedir}/*; do
78 #       install -d $loc/LC_MESSAGES
79 #       mv $loc/*.mo $loc/LC_MESSAGES
80 #done
81
82 for loc in $RPM_BUILD_ROOT%{_datadir}/%{name}/help/*; do
83         rm -rf $loc/docs_src
84 done
85
86 %find_lang %{name}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files -f %{name}.lang
92 %defattr(644,root,root,755)
93 %doc change_log.txt regex_doc.txt todo.txt version.txt
94 %attr(755,root,root) %{_bindir}/cvpcb
95 %attr(755,root,root) %{_bindir}/eeschema
96 %attr(755,root,root) %{_bindir}/gerbview
97 %dir %{_libdir}/%{name}
98 %dir %{_libdir}/%{name}/plugins
99 %attr(755,root,root) %{_libdir}/%{name}/plugins/netlist_form_pads-pcb
100 %{_datadir}/%{name}
101 %{_desktopdir}/%{name}.desktop
This page took 0.039755 seconds and 3 git commands to generate.