]> git.pld-linux.org Git - packages/kf5-sonnet.git/blob - kf5-sonnet.spec
updated build and runtime deps
[packages/kf5-sonnet.git] / kf5-sonnet.spec
1 # TODO:
2 # - fix build with aspell
3 %define         kdeframever     5.80
4 %define         qtver           5.14.0
5 %define         kfname          sonnet
6
7 Summary:        Multi-language spell checker
8 Summary(pl.UTF-8):      Wielojęzyczne narzędzie do sprawdzania pisowni
9 Name:           kf5-%{kfname}
10 Version:        5.80.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  4ff46551537d4ea6ef3ef0d0212e925a
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  aspell
21 BuildRequires:  aspell-devel
22 BuildRequires:  cmake >= 3.5
23 BuildRequires:  hspell-devel
24 BuildRequires:  hunspell-devel
25 BuildRequires:  kf5-extra-cmake-modules >= %{version}
26 BuildRequires:  libvoikko-devel
27 BuildRequires:  ninja
28 BuildRequires:  qt5-linguist >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRequires:  zlib-devel
33 Requires:       Qt5Core >= %{qtver}
34 Requires:       Qt5Widgets >= %{qtver}
35 Requires:       kf5-dirs
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         qt5dir          %{_libdir}/qt5
39
40 %description
41 Sonnet is a plugin-based spell checking library for Qt-based
42 applications. It supports several different plugins, including HSpell,
43 ASpell and HUNSPELL.
44
45 It also supports automated language detection, based on a combination
46 of different algorithms.
47
48 The simplest way to use Sonnet in your application is to use the
49 SpellCheckDecorator class on your QTextEdit.
50
51 %description -l pl.UTF-8
52 Sonnet to oparta na wtyczkach biblioteka do sprawdzania pisowni dla
53 aplikacji opartych na Qt. Obsługuje kilka różnych wtyzek, w tym
54 HSpell, ASpell i HUNSPELL.
55
56 Pozwala automatycznie wykrywać język w oparciu o połączenie różnych
57 algorytmów.
58
59 Najprostszy sposób użycia Sonneta w aplikacji to użycie klasy
60 SpellCheckDecorator w obiekcie QTextEdit.
61
62 %package devel
63 Summary:        Header files for %{kfname} development
64 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
65 Group:          X11/Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       Qt5Core-devel >= %{qtver}
68
69 %description devel
70 Header files for %{kfname} development.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe dla programistów używających %{kfname}.
74
75 %prep
76 %setup -q -n %{kfname}-%{version}
77
78 %build
79 install -d build
80 cd build
81 %cmake -G Ninja \
82         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
83         ../
84 %ninja_build
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %ninja_install -C build
89
90 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files -f %{kfname}5_qt.lang
99 %defattr(644,root,root,755)
100 %doc README.md
101 %attr(755,root,root) %{_bindir}/gentrigrams
102 %attr(755,root,root) %{_bindir}/parsetrigrams
103 %ghost %{_libdir}/libKF5SonnetCore.so.5
104 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
105 %ghost %{_libdir}/libKF5SonnetUi.so.5
106 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
107 %dir %{qt5dir}/plugins/kf5/sonnet
108 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
109 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
110 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
111 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
112 %attr(755,root,root) %{qt5dir}/plugins/designer/sonnetui5widgets.so
113 %{_datadir}/qlogging-categories5/sonnet.categories
114 %{_datadir}/qlogging-categories5/sonnet.renamecategories
115
116 %files devel
117 %defattr(644,root,root,755)
118 %{_includedir}/KF5/SonnetCore
119 %{_includedir}/KF5/SonnetUi
120 %{_includedir}/KF5/sonnet_version.h
121 %{_libdir}/cmake/KF5Sonnet
122 %{_libdir}/libKF5SonnetCore.so
123 %{_libdir}/libKF5SonnetUi.so
124 %{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
125 %{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.047424 seconds and 3 git commands to generate.