]> git.pld-linux.org Git - packages/kf5-sonnet.git/blob - kf5-sonnet.spec
- pl
[packages/kf5-sonnet.git] / kf5-sonnet.spec
1 # TODO:
2 # - fix build with aspell
3 %define         kdeframever     5.56
4 %define         qtver           5.10.0
5 %define         kfname          sonnet
6
7 Summary:        Multi-language spell checker
8 Summary(pl.UTF-8):      Wielojęzyczne narzędzie do sprawdzania pisowni
9 Name:           kf5-%{kfname}
10 Version:        5.56.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  0b42e1dd0873c54a9d06dc4ef95bdfff
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  aspell
22 BuildRequires:  aspell-devel
23 BuildRequires:  cmake >= 3.5
24 BuildRequires:  hspell-devel
25 BuildRequires:  hunspell-devel
26 BuildRequires:  kf5-extra-cmake-modules >= 5.56
27 BuildRequires:  libvoikko-devel
28 BuildRequires:  ninja
29 BuildRequires:  qt5-linguist >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  zlib-devel
34 Requires:       kf5-dirs
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         qt5dir          %{_libdir}/qt5
38
39 %description
40 Sonnet is a plugin-based spell checking library for Qt-based
41 applications. It supports several different plugins, including HSpell,
42 ASpell and HUNSPELL.
43
44 It also supports automated language detection, based on a combination
45 of different algorithms.
46
47 The simplest way to use Sonnet in your application is to use the
48 SpellCheckDecorator class on your QTextEdit.
49
50 %description -l pl.UTF-8
51 Sonnet to oparta na wtyczkach biblioteka do sprawdzania pisowni dla
52 aplikacji opartych na Qt. Obsługuje kilka różnych wtyzek, w tym
53 HSpell, ASpell i HUNSPELL.
54
55 Pozwala automatycznie wykrywać język w oparciu o połączenie różnych
56 algorytmów.
57
58 Najprostszy sposób użycia Sonneta w aplikacji to użycie klasy
59 SpellCheckDecorator w obiekcie QTextEdit.
60
61 %package devel
62 Summary:        Header files for %{kfname} development
63 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description devel
68 Header files for %{kfname} development.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe dla programistów używających %{kfname}.
72
73 %prep
74 %setup -q -n %{kfname}-%{version}
75
76 %build
77 install -d build
78 cd build
79 %cmake -G Ninja \
80         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
81         ../
82 %ninja_build
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 %ninja_install -C build
87
88 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files -f %{kfname}5_qt.lang
97 %defattr(644,root,root,755)
98 %doc README.md
99 %attr(755,root,root) %{_bindir}/gentrigrams
100 %attr(755,root,root) %{_bindir}/parsetrigrams
101 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
102 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
104 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
105 %dir %{qt5dir}/plugins/kf5/sonnet
106 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
107 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
108 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
109 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
110 %dir %{_datadir}/kf5/sonnet
111 %{_datadir}/kf5/sonnet/trigrams.map
112 /etc/xdg/sonnet.categories
113
114 %files devel
115 %defattr(644,root,root,755)
116 %{_includedir}/KF5/SonnetCore
117 %{_includedir}/KF5/SonnetUi
118 %{_includedir}/KF5/sonnet_version.h
119 %{_libdir}/cmake/KF5Sonnet
120 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so
121 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so
122 %{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
123 %{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.0559 seconds and 3 git commands to generate.