]> git.pld-linux.org Git - packages/kf5-sonnet.git/blob - kf5-sonnet.spec
- updated to 5.94.0
[packages/kf5-sonnet.git] / kf5-sonnet.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - fix build with aspell
6 %define         kdeframever     5.94
7 %define         qtver           5.15.2
8 %define         kfname          sonnet
9
10 Summary:        Multi-language spell checker
11 Summary(pl.UTF-8):      Wielojęzyczne narzędzie do sprawdzania pisowni
12 Name:           kf5-%{kfname}
13 Version:        5.94.0
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  4d9bb4004e793c74090b09c517a73ed3
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Test-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 BuildRequires:  aspell
24 BuildRequires:  aspell-devel
25 BuildRequires:  cmake >= 3.16
26 BuildRequires:  hspell-devel
27 BuildRequires:  hunspell-devel
28 BuildRequires:  kf5-extra-cmake-modules >= %{version}
29 BuildRequires:  libvoikko-devel
30 BuildRequires:  ninja
31 BuildRequires:  qt5-linguist >= %{qtver}
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  zlib-devel
36 Requires:       Qt5Core >= %{qtver}
37 Requires:       Qt5Widgets >= %{qtver}
38 Requires:       kf5-dirs
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 Sonnet is a plugin-based spell checking library for Qt-based
45 applications. It supports several different plugins, including HSpell,
46 ASpell and HUNSPELL.
47
48 It also supports automated language detection, based on a combination
49 of different algorithms.
50
51 The simplest way to use Sonnet in your application is to use the
52 SpellCheckDecorator class on your QTextEdit.
53
54 %description -l pl.UTF-8
55 Sonnet to oparta na wtyczkach biblioteka do sprawdzania pisowni dla
56 aplikacji opartych na Qt. Obsługuje kilka różnych wtyzek, w tym
57 HSpell, ASpell i HUNSPELL.
58
59 Pozwala automatycznie wykrywać język w oparciu o połączenie różnych
60 algorytmów.
61
62 Najprostszy sposób użycia Sonneta w aplikacji to użycie klasy
63 SpellCheckDecorator w obiekcie QTextEdit.
64
65 %package devel
66 Summary:        Header files for %{kfname} development
67 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       Qt5Core-devel >= %{qtver}
71
72 %description devel
73 Header files for %{kfname} development.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe dla programistów używających %{kfname}.
77
78 %prep
79 %setup -q -n %{kfname}-%{version}
80
81 %build
82 install -d build
83 cd build
84 %cmake -G Ninja \
85         %{!?with_tests:-DBUILD_TESTING=OFF} \
86         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
87         ../
88 %ninja_build
89
90 %if %{with tests}
91 ctest
92 %endif
93
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 %ninja_install -C build
98
99 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files -f %{kfname}5_qt.lang
108 %defattr(644,root,root,755)
109 %doc README.md
110 %attr(755,root,root) %{_bindir}/gentrigrams
111 %attr(755,root,root) %{_bindir}/parsetrigrams
112 %ghost %{_libdir}/libKF5SonnetCore.so.5
113 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
114 %ghost %{_libdir}/libKF5SonnetUi.so.5
115 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
116 %dir %{qt5dir}/plugins/kf5/sonnet
117 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
118 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
119 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
120 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
121 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/sonnet/libsonnetquickplugin.so
122 %dir %{_libdir}/qt5/qml/org/kde/sonnet
123 %{_libdir}/qt5/qml/org/kde/sonnet/plugins.qmltypes
124 %{_libdir}/qt5/qml/org/kde/sonnet/qmldir
125 %attr(755,root,root) %{qt5dir}/plugins/designer/sonnetui5widgets.so
126 %{_datadir}/qlogging-categories5/sonnet.categories
127 %{_datadir}/qlogging-categories5/sonnet.renamecategories
128
129 %files devel
130 %defattr(644,root,root,755)
131 %{_includedir}/KF5/SonnetCore
132 %{_includedir}/KF5/SonnetUi
133 %{_includedir}/KF5/Sonnet
134 %{_libdir}/cmake/KF5Sonnet
135 %{_libdir}/libKF5SonnetCore.so
136 %{_libdir}/libKF5SonnetUi.so
137 %{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
138 %{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.075259 seconds and 3 git commands to generate.