]> git.pld-linux.org Git - packages/kf5-solid.git/blob - kf5-solid.spec
5f5384d579d073f4c54009ca978a75cf5c6e8d42
[packages/kf5-solid.git] / kf5-solid.spec
1 %define         kdeframever     5.24
2 %define         qtver           5.4.0
3 %define         kfname          solid
4
5 Summary:        Desktop hardware abstraction
6 Name:           kf5-%{kfname}
7 Version:        5.24.0
8 Release:        2
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  197787ff95a49eb80cd8fae28d6e4638
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
15 BuildRequires:  Qt5Core-devel >= %{qtver}
16 BuildRequires:  Qt5DBus-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Qml-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  Qt5Xml-devel >= %{qtver}
22 BuildRequires:  bison
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  flex
25 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
26 BuildRequires:  qt5-linguist >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  udev-devel
30 BuildRequires:  xz
31 Requires:       kf5-dirs
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Solid is a device integration framework. It provides a way of querying
38 and interacting with hardware independently of the underlying
39 operating system.
40
41 It provides the following features for application developers:
42
43 - Hardware Discovery
44 - Power Management
45 - Network Management
46
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       Qt5Core-devel >= %{qtver}
54 Requires:       cmake >= 2.6.0
55
56 %description devel
57 Header files for %{kfname} development.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe dla programistów używających %{kfname}.
61
62 %prep
63 %setup -q -n %{kfname}-%{version}
64
65 %build
66 install -d build
67 cd build
68 %cmake \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ../
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build/ install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files -f %{kfname}5_qt.lang
88 %defattr(644,root,root,755)
89 %doc README.md TODO
90 %attr(755,root,root) %{_bindir}/solid-hardware5
91 %attr(755,root,root) %ghost %{_libdir}/libKF5Solid.so.5
92 %attr(755,root,root) %{_libdir}/libKF5Solid.so.*.*
93 %dir %{_libdir}/qt5/qml/org/kde/solid
94 %{_libdir}/qt5/qml/org/kde/solid/qmldir
95 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/solid/libsolidextensionplugin.so
96
97 %files devel
98 %defattr(644,root,root,755)
99 %{_includedir}/KF5/Solid
100 %{_includedir}/KF5/solid_version.h
101 %{_libdir}/cmake/KF5Solid
102 %attr (755,root,root) %{_libdir}/libKF5Solid.so
103 %{qt5dir}/mkspecs/modules/qt_Solid.pri
This page took 0.067522 seconds and 2 git commands to generate.