]> git.pld-linux.org Git - packages/kf5-qqc2-desktop-style.git/blob - kf5-qqc2-desktop-style.spec
- updated to 5.103.0
[packages/kf5-qqc2-desktop-style.git] / kf5-qqc2-desktop-style.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.103
5 %define         qtver           5.15.2
6 %define         kfname          qqc2-desktop-style
7
8 Summary:        QQC2StyleBridge
9 Name:           kf5-%{kfname}
10 Version:        5.103.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  c5c910fd595bfd611ac8c4bda27ef652
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Quick-controls2-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= %{version}
23 BuildRequires:  kf5-kconfig-devel >= %{version}
24 BuildRequires:  kf5-kirigami2-devel >= %{version}
25 BuildRequires:  ninja
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRequires:  zlib-devel
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 This is a style for QtQuickControls 2 that uses QWidget's QStyle for
37 painting, making possible to achieve an higher deree of consistency
38 between QWidget-based and QML-based apps. NOTE: the application must
39 be a QApplication rather than a QGuiApplication instance in order for
40 this style to be used
41
42 %package devel
43 Summary:        Header files for %{kfname} development
44 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for %{kfname} development.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe dla programistów używających %{kfname}.
53
54 %prep
55 %setup -q -n %{kfname}-%{version}
56
57 %build
58 install -d build
59 cd build
60 %cmake -G Ninja \
61         %{!?with_tests:-DBUILD_TESTING=OFF} \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
63         ../
64 %ninja_build
65
66 %if %{with tests}
67 ctest
68 %endif
69
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %dir %{_libdir}/qt5/plugins/kf5/kirigami
81 %{_libdir}/qt5/plugins/kf5/kirigami/org.kde.desktop.so
82 %{_libdir}/qt5/qml/QtQuick/Controls.2/org.kde.desktop
83 %{_libdir}/qt5/qml/org/kde/qqc2desktopstyle
84
85 %files devel
86 %defattr(644,root,root,755)
87 %{_libdir}/cmake/KF5QQC2DeskopStyle
88 %{_libdir}/cmake/KF5QQC2DesktopStyle
This page took 0.09606 seconds and 3 git commands to generate.