]> git.pld-linux.org Git - packages/kf5-kwidgetsaddons.git/blob - kf5-kwidgetsaddons.spec
9599137bcdb69eb5f9078b432b507427f7f109a2
[packages/kf5-kwidgetsaddons.git] / kf5-kwidgetsaddons.spec
1 %define         kdeframever     5.38
2 %define         qtver           5.4.0
3 %define         kfname          kwidgetsaddons
4
5 Summary:        Large set of desktop widgets
6 Name:           kf5-%{kfname}
7 Version:        5.38.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  4c6a5f0a06c4abeb962d26d05eb060a8
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5UiTools-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  qt5-linguist >= %{qtver}
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       kf5-dirs
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 This repository contains add-on widgets and classes for applications
32 that use the Qt Widgets module. If you are porting applications from
33 KDE Platform 4 "kdeui" library, you will find many of its classes
34 here.
35
36 Provided are action classes that can be added to toolbars or menus, a
37 wide range of widgets for selecting characters, fonts, colors,
38 actions, dates and times, or MIME types, as well as platform-aware
39 dialogs for configuration pages, message boxes, and password requests.
40
41 Further widgets and classes can be found in other KDE frameworks. For
42 a full list, please see
43 <https://projects.kde.org/projects/frameworks/>
44
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       Qt5Widgets-devel >= %{qtver}
52 Requires:       cmake >= 2.6.0
53
54 %description devel
55 Header files for %{kfname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kfname}.
59
60 %prep
61 %setup -q -n %{kfname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ../
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build/ install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files -f %{kfname}5_qt.lang
86 %defattr(644,root,root,755)
87 %doc README.md
88 %attr(755,root,root) %ghost %{_libdir}/libKF5WidgetsAddons.so.5
89 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so.*.*
90 %dir %{_datadir}/kf5/kcharselect
91 %{_datadir}/kf5/kcharselect/kcharselect-data
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/KF5/KWidgetsAddons
96 %{_includedir}/KF5/kwidgetsaddons_version.h
97 %{_libdir}/cmake/KF5WidgetsAddons
98 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so
99 %{qt5dir}/mkspecs/modules/qt_KWidgetsAddons.pri
This page took 0.285773 seconds and 2 git commands to generate.