]> git.pld-linux.org Git - packages/kf5-kwidgetsaddons.git/blob - kf5-kwidgetsaddons.spec
- updated to 5.39.0
[packages/kf5-kwidgetsaddons.git] / kf5-kwidgetsaddons.spec
1 %define         kdeframever     5.39
2 %define         qtver           5.4.0
3 %define         kfname          kwidgetsaddons
4
5 Summary:        Large set of desktop widgets
6 Name:           kf5-%{kfname}
7 Version:        5.39.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  285d6efcd5ac88a85f783b5cdbeeb9ae
13 Patch0:         failed-tests.patch
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel >= %{qtver}
16 BuildRequires:  Qt5Gui-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  Qt5UiTools-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
22 BuildRequires:  qt5-linguist >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       kf5-dirs
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt5dir          %{_libdir}/qt5
30
31 %description
32 This repository contains add-on widgets and classes for applications
33 that use the Qt Widgets module. If you are porting applications from
34 KDE Platform 4 "kdeui" library, you will find many of its classes
35 here.
36
37 Provided are action classes that can be added to toolbars or menus, a
38 wide range of widgets for selecting characters, fonts, colors,
39 actions, dates and times, or MIME types, as well as platform-aware
40 dialogs for configuration pages, message boxes, and password requests.
41
42 Further widgets and classes can be found in other KDE frameworks. For
43 a full list, please see
44 <https://projects.kde.org/projects/frameworks/>
45
46
47 %package devel
48 Summary:        Header files for %{kfname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       Qt5Widgets-devel >= %{qtver}
53 Requires:       cmake >= 2.6.0
54
55 %description devel
56 Header files for %{kfname} development.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe dla programistów używających %{kfname}.
60
61 %prep
62 %setup -q -n %{kfname}-%{version}
63 %patch0 -p1
64
65 %build
66 install -d build
67 cd build
68 %cmake \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ../
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build/ install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files -f %{kfname}5_qt.lang
88 %defattr(644,root,root,755)
89 %doc README.md
90 %attr(755,root,root) %ghost %{_libdir}/libKF5WidgetsAddons.so.5
91 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so.*.*
92 %dir %{_datadir}/kf5/kcharselect
93 %{_datadir}/kf5/kcharselect/kcharselect-data
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/KF5/KWidgetsAddons
98 %{_includedir}/KF5/kwidgetsaddons_version.h
99 %{_libdir}/cmake/KF5WidgetsAddons
100 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so
101 %{qt5dir}/mkspecs/modules/qt_KWidgetsAddons.pri
This page took 0.082435 seconds and 3 git commands to generate.