]> git.pld-linux.org Git - packages/kf5-kwidgetsaddons.git/blob - kf5-kwidgetsaddons.spec
- find_lang with kde
[packages/kf5-kwidgetsaddons.git] / kf5-kwidgetsaddons.spec
1 %define         kdeframever     5.13
2 %define         qtver           5.3.2
3 %define         kfname          kwidgetsaddons
4
5 Summary:        Large set of desktop widgets
6 Name:           kf5-%{kfname}
7 Version:        5.13.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  46d49208e2bd219a79fe2a54b956bc2f
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5UiTools-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  qt5-linguist >= %{qtver}
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 This repository contains add-on widgets and classes for applications
31 that use the Qt Widgets module. If you are porting applications from
32 KDE Platform 4 "kdeui" library, you will find many of its classes
33 here.
34
35 Provided are action classes that can be added to toolbars or menus, a
36 wide range of widgets for selecting characters, fonts, colors,
37 actions, dates and times, or MIME types, as well as platform-aware
38 dialogs for configuration pages, message boxes, and password requests.
39
40 Further widgets and classes can be found in other KDE frameworks. For
41 a full list, please see
42 <https://projects.kde.org/projects/frameworks/>
43
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kfname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kfname}.
56
57 %prep
58 %setup -q -n %{kfname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ../
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build/ install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files -f %{kfname}5_qt.lang
83 %defattr(644,root,root,755)
84 %doc README.md
85 %attr(755,root,root) %ghost %{_libdir}/libKF5WidgetsAddons.so.5
86 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so.*.*
87 %dir %{_datadir}/kf5/kcharselect
88 %{_datadir}/kf5/kcharselect/kcharselect-data
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/KF5/KWidgetsAddons
93 %{_includedir}/KF5/kwidgetsaddons_version.h
94 %{_libdir}/cmake/KF5WidgetsAddons
95 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so
96 %{qt5dir}/mkspecs/modules/qt_KWidgetsAddons.pri
This page took 0.056962 seconds and 3 git commands to generate.