]> git.pld-linux.org Git - packages/kf5-kpeople.git/blob - kf5-kpeople.spec
b62cf53fad294c3768c0990f6f3f390825951891
[packages/kf5-kpeople.git] / kf5-kpeople.spec
1 # Conditional build:
2 %bcond_with     tests           # build without tests
3 #
4 %define         kdeframever     5.24
5 %define         qtver           5.3.2
6 %define         kfname          kpeople
7 Summary:        Provides access to all contacts and the people who hold them
8 Name:           kf5-%{kfname}
9 Version:        5.24.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  d90d075c8b34755330429d23007ecf49
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Network-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 %if %{with tests}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 %endif
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
26 BuildRequires:  qt5-build >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Provides access to all contacts and the people who hold them.
35
36 %package devel
37 Summary:        Header files for %{kfname} development
38 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
39 Group:          X11/Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for %{kfname} development.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe dla programistów używających %{kfname}.
47
48 %prep
49 %setup -q -n %{kfname}-%{version}
50
51 %build
52 install -d build
53 cd build
54 %cmake \
55         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
56         ..
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} -C build install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %find_lang %{kfname}5 --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files -f %{kfname}5.lang
75 %defattr(644,root,root,755)
76 %doc README.md
77 %attr(755,root,root) %{_libdir}/libKF5People.so.*.*.*
78 %attr(755,root,root) %ghost %{_libdir}/libKF5People.so.5
79 %attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libKF5PeopleBackend.so.5
81 %attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libKF5PeopleWidgets.so.5
83 %dir %{_libdir}/qt5/qml/org/kde/people
84 %{_libdir}/qt5/qml/org/kde/people/qmldir
85 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/people/libKF5PeopleDeclarative.so
86 %{_datadir}/kf5/kpeople
87 %{_datadir}/kservicetypes5/kpeople_data_source.desktop
88 %{_datadir}/kservicetypes5/kpeople_plugin.desktop
89 %{_datadir}/kservicetypes5/persondetailsplugin.desktop
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_libdir}/libKF5People.so
94 %attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so
95 %attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so
96 %{_includedir}/KF5/KPeople
97 %{_libdir}/cmake/KF5People
98 %{_libdir}/qt5/mkspecs/modules/qt_KPeople*.pri
This page took 0.067209 seconds and 2 git commands to generate.