]> git.pld-linux.org Git - packages/kf5-knotifications.git/blob - kf5-knotifications.spec
- updated to 5.115.0
[packages/kf5-knotifications.git] / kf5-knotifications.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.115
5 %define         qtver           5.15.2
6 %define         kfname          knotifications
7
8 Summary:        Desktop notifications
9 Name:           kf5-%{kfname}
10 Version:        5.115.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  e3951d19de26c6b83e0fd2dc46b9ed55
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5DBus-devel >= %{qtver}
19 BuildRequires:  Qt5Quick-devel >= %{qtver}
20 BuildRequires:  Qt5Speech-devel >= %{qtver}
21 BuildRequires:  Qt5Test-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
24 BuildRequires:  cmake >= 3.16
25 BuildRequires:  kf5-extra-cmake-modules >= %{version}
26 BuildRequires:  kf5-kconfig-devel >= %{version}
27 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
28 BuildRequires:  kf5-kwindowsystem-devel >= %{version}
29 BuildRequires:  libcanberra-devel
30 BuildRequires:  libdbusmenu-qt5-devel
31 BuildRequires:  ninja
32 BuildRequires:  pkgconfig
33 BuildRequires:  qt5-linguist >= %{qtver}
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xorg-lib-libX11-devel
37 BuildRequires:  xz
38 Requires:       Qt5DBus >= %{qtver}
39 Requires:       Qt5Speech >= %{qtver}
40 Requires:       Qt5Widgets >= %{qtver}
41 Requires:       Qt5X11Extras >= %{qtver}
42 Requires:       kf5-dirs
43 Requires:       kf5-kconfig >= %{version}
44 Requires:       kf5-kcoreaddons >= %{version}
45 Requires:       kf5-kwindowsystem >= %{version}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         qt5dir          %{_libdir}/qt5
49
50 %description
51 KNotification is used to notify the user of an event. It covers
52 feedback and persistent events.
53
54 %package devel
55 Summary:        Header files for %{kfname} development
56 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       Qt5DBus-devel >= %{qtver}
60 Requires:       Qt5Widgets-devel >= %{qtver}
61
62 %description devel
63 Header files for %{kfname} development.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe dla programistów używających %{kfname}.
67
68 %prep
69 %setup -q -n %{kfname}-%{version}
70
71 %build
72 %cmake -B build \
73         -G Ninja \
74         %{!?with_tests:-DBUILD_TESTING=OFF} \
75         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
76
77 %ninja_build -C build
78
79 %if %{with tests}
80 %ninja_build -C build test
81 %endif
82
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 %ninja_install -C build
87
88 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files -f %{kfname}5_qt.lang
97 %defattr(644,root,root,755)
98 %doc README.md
99 %ghost %{_libdir}/libKF5Notifications.so.5
100 %attr(755,root,root) %{_libdir}/libKF5Notifications.so.*.*
101 %dir %{_libdir}/qt5/qml/org/kde/notification
102 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/notification/libknotificationqmlplugin.so
103 %{_libdir}/qt5/qml/org/kde/notification/qmldir
104 %{_datadir}/dbus-1/interfaces/kf5_org.kde.StatusNotifierItem.xml
105 %{_datadir}/dbus-1/interfaces/kf5_org.kde.StatusNotifierWatcher.xml
106 %{_datadir}/qlogging-categories5/knotifications.categories
107 %{_datadir}/qlogging-categories5/knotifications.renamecategories
108
109 %files devel
110 %defattr(644,root,root,755)
111 %{_includedir}/KF5/KNotifications
112 %{_libdir}/cmake/KF5Notifications
113 %{_libdir}/libKF5Notifications.so
114 %{qt5dir}/mkspecs/modules/qt_KNotifications.pri
This page took 0.135877 seconds and 3 git commands to generate.