]> git.pld-linux.org Git - packages/kf5-kinit.git/blob - kf5-kinit.spec
- up to 5.43.0
[packages/kf5-kinit.git] / kf5-kinit.spec
1 %define         kdeframever     5.43
2 %define         qtver           5.3.2
3 %define         kfname          kinit
4
5 Summary:        Helper library to speed up start of applications on KDE workspaces
6 Name:           kf5-%{kfname}
7 Version:        5.43.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  48f5100e0a11f24e9321fd2359408b1e
13 URL:            http://www.kde.org/
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  gettext-devel
16 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
17 BuildRequires:  kf5-kio-devel >= %{version}
18 BuildRequires:  libcap-devel
19 BuildRequires:  rpmbuild(macros) >= 1.164
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xorg-lib-libX11-devel
22 BuildRequires:  xz
23 Requires:       kf5-dirs
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 kdeinit is a process launcher somewhat similar to the famous init used
30 for booting UNIX.
31
32 It launches processes by forking and then loading a dynamic library
33 which should contain a 'kdemain(...)' function.
34
35 Using kdeinit to launch KDE applications makes starting a typical KDE
36 applications 2.5 times faster (100ms instead of 250ms on a P-III 500)
37 It reduces memory consumption by approx. 350Kb per application.
38
39 %package devel
40 Summary:        Header files for %{kfname} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{kfname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kfname}.
50
51 %prep
52 %setup -q -n %{kfname}-%{version}
53
54 %build
55 install -d build
56 cd build
57 %cmake \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ../
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build/ install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %find_lang %{kfname}5
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files -f %{kfname}5.lang
77 %defattr(644,root,root,755)
78 %doc README.md
79 %attr(755,root,root) %{_bindir}/kdeinit5
80 %attr(755,root,root) %{_bindir}/kdeinit5_shutdown
81 %attr(755,root,root) %{_bindir}/kdeinit5_wrapper
82 %attr(755,root,root) %{_bindir}/kshell5
83 %attr(755,root,root) %{_bindir}/kwrapper5
84 %attr(755,root,root) %{_libexecdir}/kf5/klauncher
85 %attr(755,root,root) %{_libexecdir}/kf5/start_kdeinit
86 %attr(755,root,root) %{_libexecdir}/kf5/start_kdeinit_wrapper
87 %attr(755,root,root) %{_libdir}/libkdeinit5_klauncher.so
88 %{_datadir}/dbus-1/interfaces/kf5_org.kde.KLauncher.xml
89 %{_mandir}/man8/kdeinit5.8*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_libdir}/cmake/KF5Init
This page took 0.038202 seconds and 3 git commands to generate.