]> git.pld-linux.org Git - packages/kf5-kidletime.git/blob - kf5-kidletime.spec
- new
[packages/kf5-kidletime.git] / kf5-kidletime.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kidletime
5
6 Summary:        Reporting of idle time of user and system
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  b08db7cd7b55461c6a198e458c928549
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5DBus-devel
17 BuildRequires:  Qt5Gui-devel >= 5.3.1
18 BuildRequires:  Qt5Test-devel
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  Qt5X11Extras-devel >= 5.2.0
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
23 BuildRequires:  qt5-linguist
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 KIdleTime is a singleton reporting information on idle time. It is
31 useful not only for finding out about the current idle time of the PC,
32 but also for getting notified upon idle time events, such as custom
33 timeouts, or user activity.
34
35 %package devel
36 Summary:        Header files for %{orgname} development
37 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for %{orgname} development.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe dla programistów używających %{orgname}.
46
47 %prep
48 %setup -q -n %{orgname}-%{version}
49
50 %build
51 install -d build
52 cd build
53 %cmake \
54         -DBIN_INSTALL_DIR=%{_bindir} \
55         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
56         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
57         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
58         -DQML_INSTALL_DIR=%{qt5dir}/qml \
59         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
60         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
61         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
62         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
63         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
64         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
65         ../
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build/ install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README.md
83 %attr(755,root,root) %ghost %{_libdir}/libKF5IdleTime.so.5
84 %attr(755,root,root) %{_libdir}/libKF5IdleTime.so.5.0.0
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_includedir}/KF5/KIdleTime
89 %{_includedir}/KF5/kidletime_version.h
90 %{_libdir}/cmake/KF5IdleTime
91 %attr(755,root,root) %{_libdir}/libKF5IdleTime.so
92 %{qt5dir}/mkspecs/modules/qt_KIdleTime.pri
This page took 0.06984 seconds and 3 git commands to generate.