]> git.pld-linux.org Git - packages/kf5-kiconthemes.git/blob - kf5-kiconthemes.spec
- updated to 5.19.0
[packages/kf5-kiconthemes.git] / kf5-kiconthemes.spec
1 %define         kdeframever     5.19
2 %define         qtver           5.3.2
3 %define         kfname          kiconthemes
4
5 Summary:        Icon GUI utilities
6 Name:           kf5-%{kfname}
7 Version:        5.19.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  234f1a331fcda7425061cc0667b62fc9
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5DBus-devel >= %{qtver}
16 BuildRequires:  Qt5Gui-devel >= %{qtver}
17 BuildRequires:  Qt5Svg-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  Qt5Xml-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
24 BuildRequires:  kf5-kauth-devel >= %{version}
25 BuildRequires:  kf5-kcodecs-devel >= %{version}
26 BuildRequires:  kf5-kconfig-devel >= %{version}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{version}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
29 BuildRequires:  kf5-kguiaddons-devel >= %{version}
30 BuildRequires:  kf5-ki18n-devel >= %{version}
31 BuildRequires:  kf5-kitemviews-devel >= %{version}
32 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
33 BuildRequires:  pkgconfig
34 BuildRequires:  qt5-linguist >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         qt5dir          %{_libdir}/qt5
41
42 %description
43 This library contains classes to improve the handling of icons in
44 applications using the KDE Frameworks. Provided are:
45
46 - KIconDialog: Dialog class to let the user select an icon from the
47   list of installed icons.
48 - KIconButton: Custom button class that displays an icon. When
49   clicking it, the user can change it using the icon dialog.
50 - KIconEffect: Applies various colorization effects to icons, which
51   can be used to create selected/disabled icon images.
52
53 Other classes in this repository are used internally by the icon theme
54 configuration dialogs, and should not be used by applications.
55
56 %package devel
57 Summary:        Header files for %{kfname} development
58 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
59 Group:          X11/Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for %{kfname} development.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe dla programistów używających %{kfname}.
67
68 %prep
69 %setup -q -n %{kfname}-%{version}
70
71 %build
72 install -d build
73 cd build
74 %cmake \
75         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
76         ../
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build/ install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %find_lang %{kfname}5
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{kfname}5.lang
94 %defattr(644,root,root,755)
95 %doc README.md
96 %attr(755,root,root) %{_bindir}/kiconfinder5
97 %attr(755,root,root) %ghost %{_libdir}/libKF5IconThemes.so.5
98 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_includedir}/KF5/KIconThemes
103 %{_includedir}/KF5/kiconthemes_version.h
104 %{_libdir}/cmake/KF5IconThemes
105 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so
106 %{qt5dir}/mkspecs/modules/qt_KIconThemes.pri
This page took 0.140228 seconds and 4 git commands to generate.