]> git.pld-linux.org Git - packages/kf5-kiconthemes.git/blob - kf5-kiconthemes.spec
d496594a3a279e1ad8905dbd61b8bd2bf19944ac
[packages/kf5-kiconthemes.git] / kf5-kiconthemes.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.110
5 %define         qtver           5.15.2
6 %define         kfname          kiconthemes
7
8 Summary:        Icon GUI utilities
9 Name:           kf5-%{kfname}
10 Version:        5.110.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  6490f0ef66821b67560f6b3363e1c5b4
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5DBus-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= %{qtver}
20 BuildRequires:  Qt5Svg-devel >= %{qtver}
21 BuildRequires:  Qt5Test-devel >= %{qtver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtver}
23 BuildRequires:  cmake >= 3.16
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  kf5-karchive-devel >= %{version}
26 BuildRequires:  kf5-kconfigwidgets-devel >= %{version}
27 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
28 BuildRequires:  kf5-ki18n-devel >= %{version}
29 BuildRequires:  kf5-kitemviews-devel >= %{version}
30 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
31 BuildRequires:  ninja
32 BuildRequires:  pkgconfig
33 BuildRequires:  qt5-linguist >= %{qtver}
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires:       Qt5DBus >= %{qtver}
38 Requires:       Qt5Gui >= %{qtver}
39 Requires:       Qt5Svg >= %{qtver}
40 Requires:       Qt5Widgets >= %{qtver}
41 Requires:       kf5-dirs
42 Requires:       kf5-karchive >= %{version}
43 Requires:       kf5-kconfigwidgets >= %{version}
44 Requires:       kf5-kcoreaddons >= %{version}
45 Requires:       kf5-ki18n >= %{version}
46 Requires:       kf5-kitemviews >= %{version}
47 Requires:       kf5-kwidgetsaddons >= %{version}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         qt5dir          %{_libdir}/qt5
51
52 %description
53 This library contains classes to improve the handling of icons in
54 applications using the KDE Frameworks. Provided are:
55
56 - KIconDialog: Dialog class to let the user select an icon from the
57   list of installed icons.
58 - KIconButton: Custom button class that displays an icon. When
59   clicking it, the user can change it using the icon dialog.
60 - KIconEffect: Applies various colorization effects to icons, which
61   can be used to create selected/disabled icon images.
62
63 Other classes in this repository are used internally by the icon theme
64 configuration dialogs, and should not be used by applications.
65
66 %package devel
67 Summary:        Header files for %{kfname} development
68 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
69 Group:          X11/Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       Qt5Widgets-devel >= %{qtver}
72 Requires:       cmake >= 3.16
73
74 %description devel
75 Header files for %{kfname} development.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe dla programistów używających %{kfname}.
79
80 %prep
81 %setup -q -n %{kfname}-%{version}
82
83 %build
84 %cmake -B build \
85         -G Ninja \
86         %{!?with_tests:-DBUILD_TESTING=OFF} \
87         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
88
89 %ninja_build -C build
90
91 %if %{with tests}
92 %ninja_build -C build test
93 %endif
94
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %ninja_install -C build
99
100 %find_lang %{kfname}5
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files -f %{kfname}5.lang
109 %defattr(644,root,root,755)
110 %doc README.md
111 %{_datadir}/qlogging-categories5/kiconthemes.categories
112 %attr(755,root,root) %{_bindir}/kiconfinder5
113 %ghost %{_libdir}/libKF5IconThemes.so.5
114 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so.*.*
115 %attr(755,root,root) %{_libdir}/qt5/plugins/iconengines/KIconEnginePlugin.so
116 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/kiconthemes5widgets.so
117 %{_datadir}/qlogging-categories5/kiconthemes.renamecategories
118
119 %files devel
120 %defattr(644,root,root,755)
121 %{_includedir}/KF5/KIconThemes
122 %{_libdir}/cmake/KF5IconThemes
123 %{_libdir}/libKF5IconThemes.so
124 %{qt5dir}/mkspecs/modules/qt_KIconThemes.pri
This page took 0.05044 seconds and 2 git commands to generate.