]> git.pld-linux.org Git - packages/kf5-kiconthemes.git/blob - kf5-kiconthemes.spec
c90067e24891228d6312c033b41c830df1879c4b
[packages/kf5-kiconthemes.git] / kf5-kiconthemes.spec
1 %define         kdeframever     5.24
2 %define         qtver           5.3.2
3 %define         kfname          kiconthemes
4
5 Summary:        Icon GUI utilities
6 Name:           kf5-%{kfname}
7 Version:        5.24.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  74b986efc24bec1e78b9e72b4c0defcd
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5DBus-devel >= %{qtver}
16 BuildRequires:  Qt5Gui-devel >= %{qtver}
17 BuildRequires:  Qt5Svg-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  Qt5Xml-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
24 BuildRequires:  kf5-kauth-devel >= %{version}
25 BuildRequires:  kf5-kcodecs-devel >= %{version}
26 BuildRequires:  kf5-kconfig-devel >= %{version}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{version}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
29 BuildRequires:  kf5-kguiaddons-devel >= %{version}
30 BuildRequires:  kf5-ki18n-devel >= %{version}
31 BuildRequires:  kf5-kitemviews-devel >= %{version}
32 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
33 BuildRequires:  pkgconfig
34 BuildRequires:  qt5-linguist >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 Requires:       kf5-dirs
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 This library contains classes to improve the handling of icons in
45 applications using the KDE Frameworks. Provided are:
46
47 - KIconDialog: Dialog class to let the user select an icon from the
48   list of installed icons.
49 - KIconButton: Custom button class that displays an icon. When
50   clicking it, the user can change it using the icon dialog.
51 - KIconEffect: Applies various colorization effects to icons, which
52   can be used to create selected/disabled icon images.
53
54 Other classes in this repository are used internally by the icon theme
55 configuration dialogs, and should not be used by applications.
56
57 %package devel
58 Summary:        Header files for %{kfname} development
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Header files for %{kfname} development.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe dla programistów używających %{kfname}.
68
69 %prep
70 %setup -q -n %{kfname}-%{version}
71
72 %build
73 install -d build
74 cd build
75 %cmake \
76         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
77         ../
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} -C build/ install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %find_lang %{kfname}5
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files -f %{kfname}5.lang
95 %defattr(644,root,root,755)
96 %doc README.md
97 %attr(755,root,root) %{_bindir}/kiconfinder5
98 %attr(755,root,root) %ghost %{_libdir}/libKF5IconThemes.so.5
99 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so.*.*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/KF5/KIconThemes
104 %{_includedir}/KF5/kiconthemes_version.h
105 %{_libdir}/cmake/KF5IconThemes
106 %attr(755,root,root) %{_libdir}/libKF5IconThemes.so
107 %{qt5dir}/mkspecs/modules/qt_KIconThemes.pri
This page took 0.578369 seconds and 2 git commands to generate.