]> git.pld-linux.org Git - packages/kf5-kguiaddons.git/blob - kf5-kguiaddons.spec
- up to 5.43.0
[packages/kf5-kguiaddons.git] / kf5-kguiaddons.spec
1 %define         kdeframever     5.43
2 %define         qtver           5.3.2
3 %define         kfname          kguiaddons
4
5 Summary:        Utilities for graphical user interfaces
6 Name:           kf5-%{kfname}
7 Version:        5.43.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  29a133ec1b1edf43fdcb64cdc0b3484a
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  qt5-linguist >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       kf5-dirs
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt5dir          %{_libdir}/qt5
30
31 %description
32 The KDE GUI addons provide utilities for graphical user interfaces in
33 the areas of colors, fonts, text, images, keyboard input.
34
35 %package devel
36 Summary:        Header files for %{kfname} development
37 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for %{kfname} development.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe dla programistów używających %{kfname}.
46
47 %prep
48 %setup -q -n %{kfname}-%{version}
49
50 %build
51 install -d build
52 cd build
53 %cmake \
54         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
55         ../
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -C build/ install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post -p /sbin/ldconfig
68 %postun -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README.md
73 %attr(755,root,root) %ghost %{_libdir}/libKF5GuiAddons.so.5
74 %attr(755,root,root) %{_libdir}/libKF5GuiAddons.so.*.*
75
76 %files devel
77 %defattr(644,root,root,755)
78 %{_includedir}/KF5/KGuiAddons
79 %{_includedir}/KF5/kguiaddons_version.h
80 %{_libdir}/cmake/KF5GuiAddons
81 %attr(755,root,root) %{_libdir}/libKF5GuiAddons.so
82 %{qt5dir}/mkspecs/modules/qt_KGuiAddons.pri
This page took 0.106031 seconds and 3 git commands to generate.