]> git.pld-linux.org Git - packages/kf5-kcoreaddons.git/blob - kf5-kcoreaddons.spec
- up to 5.10.0
[packages/kf5-kcoreaddons.git] / kf5-kcoreaddons.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.10
9 %define         qtver           5.3.2
10 %define         kfname          kcoreaddons
11 Summary:        Utilities for core application functionality and accessing the OS
12 Name:           kf5-%{kfname}
13 Version:        5.10.0
14 Release:        1
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  17142e16ed6e396771f5ae7e890d1084
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Test-devel >= %{qtver}
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  fam-devel
24 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  shared-mime-info
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 KCoreAddons provides classes built on top of QtCore to perform various
34 tasks such as manipulating mime types, autosaving files, creating
35 backup files, generating random sequences, performing text
36 manipulations such as macro replacement, accessing user information
37 and many more.
38
39 %package devel
40 Summary:        Header files for %{kfname} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{kfname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kfname}.
50
51 %prep
52 %setup -q -n %{kfname}-%{version}
53
54 %build
55 install -d build
56 cd build
57 %cmake \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ../
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} -C build install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %find_lang %{kfname}5_qt --with-qm --all-name
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files -f %{kfname}5_qt.lang
78 %defattr(644,root,root,755)
79 %doc README.md
80 %{_datadir}/mime/packages/kde5.xml
81 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libKF5CoreAddons.so.5
83
84 %files devel
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/desktoptojson
87 %{_includedir}/KF5/KCoreAddons
88 %{_includedir}/KF5/kcoreaddons_version.h
89 %{_libdir}/cmake/KF5CoreAddons
90 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so
91 %{_libdir}/qt5/mkspecs/modules/qt_KCoreAddons.pri
This page took 0.075745 seconds and 4 git commands to generate.