]> git.pld-linux.org Git - packages/kf5-kcoreaddons.git/blob - kf5-kcoreaddons.spec
-updated to 5.24.0; fetch sources
[packages/kf5-kcoreaddons.git] / kf5-kcoreaddons.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.24
9 %define         qtver           5.3.2
10 %define         kfname          kcoreaddons
11 Summary:        Utilities for core application functionality and accessing the OS
12 Name:           kf5-%{kfname}
13 Version:        5.24.0
14 Release:        1
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  03dfc4b55274c8ecb5290baa305c0a7d
19 Patch0:         flaky-tests.patch
20 URL:            http://www.kde.org/
21 BuildRequires:  Qt5Core-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  fam-devel
25 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
26 BuildRequires:  qt5-linguist >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  shared-mime-info
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       kf5-dirs
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 KCoreAddons provides classes built on top of QtCore to perform various
36 tasks such as manipulating mime types, autosaving files, creating
37 backup files, generating random sequences, performing text
38 manipulations such as macro replacement, accessing user information
39 and many more.
40
41 %package devel
42 Summary:        Header files for %{kfname} development
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for %{kfname} development.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe dla programistów używających %{kfname}.
52
53 %prep
54 %setup -q -n %{kfname}-%{version}
55 #%patch0 -p1
56
57 %build
58 install -d build
59 cd build
60 %cmake \
61         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
62         ../
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %{__make} -C build install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files -f %{kfname}5_qt.lang
81 %defattr(644,root,root,755)
82 %doc README.md
83 %{_datadir}/mime/packages/kde5.xml
84 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.*.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libKF5CoreAddons.so.5
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/desktoptojson
90 %{_includedir}/KF5/KCoreAddons
91 %{_includedir}/KF5/kcoreaddons_version.h
92 %{_libdir}/cmake/KF5CoreAddons
93 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so
94 %{_libdir}/qt5/mkspecs/modules/qt_KCoreAddons.pri
This page took 0.036456 seconds and 3 git commands to generate.