]> git.pld-linux.org Git - packages/kf5-kcoreaddons.git/blob - kf5-kcoreaddons.spec
- disabled flaky tests
[packages/kf5-kcoreaddons.git] / kf5-kcoreaddons.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.19
9 %define         qtver           5.3.2
10 %define         kfname          kcoreaddons
11 Summary:        Utilities for core application functionality and accessing the OS
12 Name:           kf5-%{kfname}
13 Version:        5.19.0
14 Release:        2
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  996db46c7e3b6a3b1837a0cc9373bcdd
19 Patch0:         flaky-tests.patch
20 URL:            http://www.kde.org/
21 BuildRequires:  Qt5Core-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  fam-devel
25 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
26 BuildRequires:  qt5-linguist >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  shared-mime-info
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 KCoreAddons provides classes built on top of QtCore to perform various
35 tasks such as manipulating mime types, autosaving files, creating
36 backup files, generating random sequences, performing text
37 manipulations such as macro replacement, accessing user information
38 and many more.
39
40 %package devel
41 Summary:        Header files for %{kfname} development
42 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{kfname} development.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe dla programistów używających %{kfname}.
51
52 %prep
53 %setup -q -n %{kfname}-%{version}
54 %patch0 -p1
55
56 %build
57 install -d build
58 cd build
59 %cmake \
60         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
61         ../
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} -C build install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files -f %{kfname}5_qt.lang
80 %defattr(644,root,root,755)
81 %doc README.md
82 %{_datadir}/mime/packages/kde5.xml
83 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libKF5CoreAddons.so.5
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_bindir}/desktoptojson
89 %{_includedir}/KF5/KCoreAddons
90 %{_includedir}/KF5/kcoreaddons_version.h
91 %{_libdir}/cmake/KF5CoreAddons
92 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so
93 %{_libdir}/qt5/mkspecs/modules/qt_KCoreAddons.pri
This page took 0.120284 seconds and 3 git commands to generate.