]> git.pld-linux.org Git - packages/kf5-kconfig.git/blob - kf5-kconfig.spec
tar.xz deps
[packages/kf5-kconfig.git] / kf5-kconfig.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kconfig
5
6 Summary:        Backend for storing application configuration
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  d7cdb25dd4645904332ef9eee71143ec
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5Gui-devel >= 5.3.1
17 BuildRequires:  Qt5Test-devel
18 BuildRequires:  Qt5Xml-devel >= 5.2.0
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  qt5-linguist
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 KConfig provides an advanced configuration system. It is made of two
31 parts: KConfigCore and KConfigGui.
32
33 KConfigCore provides access to the configuration files themselves. It
34 features:
35
36 - Code generation: describe your configuration in an XML file, and use
37   `kconfig_compiler to generate classes that read and write
38   configuration entries.
39 - Cascading configuration files (global settings overridden by local
40   settings).
41 - Optional shell expansion support (see [docs/options.md](@ref
42   options)).
43 - The ability to lock down configuration options (see
44   [docs/options.md](@ref options)).
45
46 KConfigGui provides a way to hook widgets to the configuration so that
47 they are automatically initialized from the configuration and
48 automatically propagate their changes to their respective
49 configuration files.
50
51 %package devel
52 Summary:        Header files for %{orgname} development
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 Header files for %{orgname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{orgname}.
62
63 %prep
64 %setup -q -n %{orgname}-%{version}
65
66 %build
67 install -d build
68 cd build
69 %cmake \
70         -DBIN_INSTALL_DIR=%{_bindir} \
71         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
72         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
73         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
74         -DQML_INSTALL_DIR=%{qt5dir}/qml \
75         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
76         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
77         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
78         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
79         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
80         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
81         ../
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build/ install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %find_lang %{orgname}5_qt --with-qm
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files -f %{orgname}5_qt.lang
99 %defattr(644,root,root,755)
100 %doc DESIGN README.md TODO
101 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigCore.so.5
102 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.5.0.0
103 %attr(755,root,root) %ghost %{_libdir}/libKF5ConfigGui.so.5
104 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.5.0.0
105 %attr(755,root,root) %{_bindir}/kconfig_compiler_kf5
106 %attr(755,root,root) %{_bindir}/kreadconfig5
107 %attr(755,root,root) %{_bindir}/kwriteconfig5
108 %attr(755,root,root) %{_libdir}/kf5/kconf_update
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/libKF5ConfigCore.so
113 %attr(755,root,root) %{_libdir}/libKF5ConfigGui.so
114 %{_includedir}/KF5/KConfigCore
115 %{_includedir}/KF5/KConfigGui
116 %{_includedir}/KF5/kconfig_version.h
117 %{_libdir}/cmake/KF5Config
118 %{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
119 %{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.038985 seconds and 4 git commands to generate.