]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
- updated to 5.115.0
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 %define         kdeframever     5.115
7 %define         qtver           5.15.2
8 %define         kfname          kcodecs
9
10 Summary:        String encoding
11 Name:           kf5-%{kfname}
12 Version:        5.115.0
13 Release:        1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  c87402505994a05fbf4c368a22016ef5
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Test-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.16
22 BuildRequires:  gperf
23 BuildRequires:  kf5-extra-cmake-modules >= %{version}
24 BuildRequires:  ninja
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       Qt5Core >= %{qtver}
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 KCodecs provide a collection of methods to manipulate strings using
35 various encodings. It supports:
36
37 - base64
38 - uu
39 - quoted-printable
40
41 %package devel
42 Summary:        Header files for %{kfname} development
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       Qt5Core-devel >= %{qtver}
47 Requires:       cmake >= 3.16
48
49 %description devel
50 Header files for %{kfname} development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla programistów używających %{kfname}.
54
55 %prep
56 %setup -q -n %{kfname}-%{version}
57
58 %build
59 %cmake -B build \
60         -G Ninja \
61         %{!?with_tests:-DBUILD_TESTING=OFF} \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
63
64 %ninja_build -C build
65
66 %if %{with tests}
67 %ninja_build -C build test
68 %endif
69
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kfname}5_qt.lang
84 %defattr(644,root,root,755)
85 %doc README.md
86 %ghost %{_libdir}/libKF5Codecs.so.5
87 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
88 %{_datadir}/qlogging-categories5/kcodecs.categories
89 %{_datadir}/qlogging-categories5/kcodecs.renamecategories
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_libdir}/libKF5Codecs.so
94 %{_includedir}/KF5/KCodecs
95 %{_libdir}/cmake/KF5Codecs
96 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.049528 seconds and 4 git commands to generate.