]> git.pld-linux.org Git - packages/kf5-karchive.git/blob - kf5-karchive.spec
- updated to 5.59.0
[packages/kf5-karchive.git] / kf5-karchive.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.59
4 %define         qtver           5.9.0
5 %define         kfname          karchive
6
7 Summary:        Reading, creating, and manipulating file archives
8 Name:           kf5-%{kfname}
9 Version:        5.59.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  9d06b19821edadb57f0892bafbd41560
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  bzip2-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
21 BuildRequires:  ninja
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  xz-devel
26 BuildRequires:  zlib-devel
27 Requires:       kf5-dirs
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         qt5dir          %{_libdir}/qt5
31
32 %description
33 KArchive provides classes for easy reading, creation and manipulation
34 of "archive" formats like ZIP and TAR.
35
36 If also provides transparent compression and decompression of data,
37 like the GZip format, via a subclass of QIODevice.
38
39 %package devel
40 Summary:        Header files for %{kfname} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{kfname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kfname}.
50
51 %prep
52 %setup -q -n %{kfname}-%{version}
53
54 %build
55 install -d build
56 cd build
57 %cmake -G Ninja \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ..
60 %ninja_build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS README.md
75 %attr(755,root,root) %ghost %{_libdir}/libKF5Archive.so.5
76 %attr(755,root,root) %{_libdir}/libKF5Archive.so.*.*
77 %config(noreplace) %verify(not md5 mtime size) /etc/xdg/karchive.categories
78
79 %files devel
80 %defattr(644,root,root,755)
81 %{_includedir}/KF5/KArchive
82 %{_includedir}/KF5/karchive_version.h
83 %attr(755,root,root) %{_libdir}/libKF5Archive.so
84 %{_libdir}/cmake/KF5Archive
85 %{qt5dir}/mkspecs/modules/qt_KArchive.pri
This page took 0.053116 seconds and 3 git commands to generate.