]> git.pld-linux.org Git - packages/kf5-karchive.git/blob - kf5-karchive.spec
751502a54079c202225d1ae10536fdf6643162e6
[packages/kf5-karchive.git] / kf5-karchive.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 # TODO:
5 # - runtime Requires if any
6 %define         kdeframever     5.102
7 %define         qtver           5.15.2
8 %define         kfname          karchive
9
10 Summary:        Reading, creating, and manipulating file archives
11 Name:           kf5-%{kfname}
12 Version:        5.102.0
13 Release:        1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  a0671c96496698f513e251753d5b828c
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Network-devel >= %{qtver}
21 BuildRequires:  Qt5Test-devel >= %{qtver}
22 BuildRequires:  bzip2-devel
23 BuildRequires:  cmake >= 3.16
24 BuildRequires:  kf5-extra-cmake-modules >= %{version}
25 BuildRequires:  ninja
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRequires:  xz-devel
31 BuildRequires:  zlib-devel
32 BuildRequires:  zstd-devel
33 Requires:       Qt5Core >= %{qtver}
34 Requires:       kf5-dirs
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         qt5dir          %{_libdir}/qt5
38
39 %description
40 KArchive provides classes for easy reading, creation and manipulation
41 of "archive" formats like ZIP and TAR.
42
43 If also provides transparent compression and decompression of data,
44 like the GZip format, via a subclass of QIODevice.
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       Qt5Core-devel >= %{qtver}
52 Requires:       cmake >= 3.16
53
54 %description devel
55 Header files for %{kfname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kfname}.
59
60 %prep
61 %setup -q -n %{kfname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake -G Ninja \
67         %{!?with_tests:-DBUILD_TESTING=OFF} \
68         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
69         ..
70 %ninja_build
71
72 %if %{with tests}
73 ctest
74 %endif
75
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %ninja_install -C build
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS README.md
90 %ghost %{_libdir}/libKF5Archive.so.5
91 %attr(755,root,root) %{_libdir}/libKF5Archive.so.*.*
92 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/qlogging-categories5/karchive.categories
93 %{_datadir}/qlogging-categories5/karchive.renamecategories
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/KF5/KArchive
98 %{_libdir}/libKF5Archive.so
99 %{_libdir}/cmake/KF5Archive
100 %{qt5dir}/mkspecs/modules/qt_KArchive.pri
This page took 0.117342 seconds and 2 git commands to generate.