]> git.pld-linux.org Git - packages/kf5-karchive.git/blob - kf5-karchive.spec
- up to 5.38.0
[packages/kf5-karchive.git] / kf5-karchive.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.38
4 %define         qtver           5.3.2
5 %define         kfname          karchive
6
7 Summary:        Reading, creating, and manipulating file archives
8 Name:           kf5-%{kfname}
9 Version:        5.38.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  99ba8008d22e71af13376240f94ec742
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  bzip2-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRequires:  xz-devel
25 BuildRequires:  zlib-devel
26 Requires:       kf5-dirs
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt5dir          %{_libdir}/qt5
30
31 %description
32 KArchive provides classes for easy reading, creation and manipulation
33 of "archive" formats like ZIP and TAR.
34
35 If also provides transparent compression and decompression of data,
36 like the GZip format, via a subclass of QIODevice.
37
38 %package devel
39 Summary:        Header files for %{kfname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 install -d build
55 cd build
56 %cmake \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
58         ..
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} -C build/ install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS README.md
76 %attr(755,root,root) %ghost %{_libdir}/libKF5Archive.so.5
77 %attr(755,root,root) %{_libdir}/libKF5Archive.so.*.*
78 %config(noreplace) %verify(not md5 mtime size) /etc/xdg/karchive.categories
79
80 %files devel
81 %defattr(644,root,root,755)
82 %{_includedir}/KF5/KArchive
83 %{_includedir}/KF5/karchive_version.h
84 %attr(755,root,root) %{_libdir}/libKF5Archive.so
85 %{_libdir}/cmake/KF5Archive
86 %{qt5dir}/mkspecs/modules/qt_KArchive.pri
This page took 0.187043 seconds and 3 git commands to generate.