]> git.pld-linux.org Git - packages/kf5-karchive.git/blob - kf5-karchive.spec
- up to 5.13.0
[packages/kf5-karchive.git] / kf5-karchive.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.13
4 %define         qtver           5.3.2
5 %define         kfname          karchive
6
7 Summary:        Reading, creating, and manipulating file archives
8 Name:           kf5-%{kfname}
9 Version:        5.13.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  dd01dc1252cb3d862959970ef7d7f5eb
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  bzip2-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRequires:  xz-devel
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 KArchive provides classes for easy reading, creation and manipulation
32 of "archive" formats like ZIP and TAR.
33
34 If also provides transparent compression and decompression of data,
35 like the GZip format, via a subclass of QIODevice.
36
37 %package devel
38 Summary:        Header files for %{kfname} development
39 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
40 Group:          X11/Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{kfname} development.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla programistów używających %{kfname}.
48
49 %prep
50 %setup -q -n %{kfname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake \
56         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
57         ..
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} -C build/ install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS README.md
75 %attr(755,root,root) %ghost %{_libdir}/libKF5Archive.so.5
76 %attr(755,root,root) %{_libdir}/libKF5Archive.so.*.*
77
78 %files devel
79 %defattr(644,root,root,755)
80 %{_includedir}/KF5/KArchive
81 %{_includedir}/KF5/karchive_version.h
82 %attr(755,root,root) %{_libdir}/libKF5Archive.so
83 %{_libdir}/cmake/KF5Archive
84 %{qt5dir}/mkspecs/modules/qt_KArchive.pri
This page took 0.105151 seconds and 3 git commands to generate.