]> git.pld-linux.org Git - packages/kf5-attica.git/commitdiff
state is pointless too, use kfname instead of orgname as it looks cooler
authorElan Ruusamäe <glen@delfi.ee>
Thu, 20 Nov 2014 10:27:10 +0000 (12:27 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 20 Nov 2014 10:27:10 +0000 (12:27 +0200)
kf5-attica.spec

index c2f0f0e53f69b235b5caecff6fddd4b5ba3d759e..08febf516511ac5d611751b44895e40c5231ee59 100644 (file)
@@ -1,30 +1,30 @@
+#
+# Conditional build:
+%bcond_without tests           # build without tests
+
 # TODO:
 # - runtime Requires if any
 # - dir /usr/include/KF5 not packaged
 
-%bcond_without tests
-
-%define                _state          stable
-%define                orgname         attica
 %define                kdeframever     5.4
-%define                qt_ver          5.3.2
-
+%define                qtver           5.3.2
+%define                kfname          attica
 Summary:       A Qt library that implements the Open Collaboration Services API
-Name:          kf5-%{orgname}
+Name:          kf5-%{kfname}
 Version:       5.4.0
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/%{_state}/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
+Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
 # Source0-md5: 493c08ce82d5ab34bf2efeb1a01349ab
 URL:           http://www.kde.org/
-BuildRequires: Qt5Core-devel >= %{qt_ver}
-BuildRequires: Qt5Gui-devel >= %{qt_ver}
-BuildRequires: Qt5Network-devel >= %{qt_ver}
-BuildRequires: Qt5Test-devel >= %{qt_ver}
+BuildRequires: Qt5Core-devel >= %{qtver}
+BuildRequires: Qt5Gui-devel >= %{qtver}
+BuildRequires: Qt5Network-devel >= %{qtver}
+BuildRequires: Qt5Test-devel >= %{qtver}
 %if %{with tests}
-BuildRequires: Qt5Gui-devel >= %{qt_ver}
-BuildRequires: Qt5Widgets-devel >= %{qt_ver}
+BuildRequires: Qt5Gui-devel >= %{qtver}
+BuildRequires: Qt5Widgets-devel >= %{qtver}
 %endif
 BuildRequires: cmake >= 2.8.12
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
@@ -36,7 +36,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 Attica is a Qt library that implements the Open Collaboration Services
 API version 1.6. The REST API is defined here:
-http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/
+<http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
 
 It grants easy access to the services such as querying information
 about persons and contents. The library is used in KNewStuff3 as
@@ -44,19 +44,19 @@ content provider. In order to integrate with KDE's Plasma Desktop, a
 platform plugin exists in kdebase.
 
 %package devel
-Summary:       Header files for %{orgname} development
-Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{orgname}
+Summary:       Header files for %{kfname} development
+Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kfname}
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
-Header files for %{orgname} development.
+Header files for %{kfname} development.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla programistów używających %{orgname}.
+Pliki nagłówkowe dla programistów używających %{kfname}.
 
 %prep
-%setup -q -n %{orgname}-%{version}
+%setup -q -n %{kfname}-%{version}
 
 %build
 install -d build
@@ -70,21 +70,20 @@ cd build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS README.md
-%attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
 %attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.037132 seconds and 4 git commands to generate.