]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
- rel 5; BR qt5-build
[packages/kf5-attica.git] / kf5-attica.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.4
9 %define         qtver           5.3.2
10 %define         kfname          attica
11 Summary:        A Qt library that implements the Open Collaboration Services API
12 Name:           kf5-%{kfname}
13 Version:        5.4.0
14 Release:        2
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  493c08ce82d5ab34bf2efeb1a01349ab
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Network-devel >= %{qtver}
23 BuildRequires:  Qt5Test-devel >= %{qtver}
24 %if %{with tests}
25 BuildRequires:  Qt5Gui-devel >= %{qtver}
26 BuildRequires:  Qt5Widgets-devel >= %{qtver}
27 %endif
28 BuildRequires:  cmake >= 2.8.12
29 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
30 BuildRequires:  qt5-build >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Attica is a Qt library that implements the Open Collaboration Services
38 API version 1.6. The REST API is defined here:
39 <http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
40
41 It grants easy access to the services such as querying information
42 about persons and contents. The library is used in KNewStuff3 as
43 content provider. In order to integrate with KDE's Plasma Desktop, a
44 platform plugin exists in kdebase.
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{kfname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{kfname}.
57
58 %prep
59 %setup -q -n %{kfname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ..
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} -C build install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS README.md
85 %attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libKF5Attica.so
91 %{_includedir}/KF5/Attica
92 %{_includedir}/KF5/attica_version.h
93 %{_libdir}/cmake/KF5Attica
94 %{_pkgconfigdir}/libKF5Attica.pc
95 %{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.049731 seconds and 4 git commands to generate.