]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
- up to 5.4.0; drop tons of unneded defines; run tests
[packages/kf5-attica.git] / kf5-attica.spec
1 # TODO:
2 # - runtime Requires if any
3 # - dir /usr/include/KF5 not packaged
4
5 %bcond_without  tests
6
7 %define         _state          stable
8 %define         orgname         attica
9 %define         kdeframever     5.4
10 %define         qt_ver          5.3.2
11
12 Summary:        A Qt library that implements the Open Collaboration Services API
13 Name:           kf5-%{orgname}
14 Version:        5.4.0
15 Release:        1
16 License:        GPL v2+/LGPL v2.1+
17 Group:          X11/Libraries
18 Source0:        http://download.kde.org/%{_state}/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  493c08ce82d5ab34bf2efeb1a01349ab
20 URL:            http://www.kde.org/
21 BuildRequires:  Qt5Core-devel >= %{qt_ver}
22 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
23 BuildRequires:  Qt5Network-devel >= %{qt_ver}
24 BuildRequires:  Qt5Test-devel >= %{qt_ver}
25 %if %{with tests}
26 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
27 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
28 %endif
29 BuildRequires:  cmake >= 2.8.12
30 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Attica is a Qt library that implements the Open Collaboration Services
38 API version 1.6. The REST API is defined here:
39 http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/
40
41 It grants easy access to the services such as querying information
42 about persons and contents. The library is used in KNewStuff3 as
43 content provider. In order to integrate with KDE's Plasma Desktop, a
44 platform plugin exists in kdebase.
45
46 %package devel
47 Summary:        Header files for %{orgname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{orgname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{orgname}.
57
58 %prep
59 %setup -q -n %{orgname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ..
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build/ install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS README.md
86 %attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
87 %attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libKF5Attica.so
92 %{_includedir}/KF5/Attica
93 %{_includedir}/KF5/attica_version.h
94 %{_libdir}/cmake/KF5Attica
95 %{_pkgconfigdir}/libKF5Attica.pc
96 %{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.536763 seconds and 4 git commands to generate.