]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
- tar.xz deps
[packages/kf5-attica.git] / kf5-attica.spec
1 # TODO:
2 # - proper place for *.pri,
3 # - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
4 # - runtime Requires if any
5 # - dir /usr/include/KF5 not packaged
6 %define         _state          stable
7 %define         orgname         attica
8
9 Summary:        A Qt library that implements the Open Collaboration Services API
10 Name:           kf5-%{orgname}
11 Version:        5.0.0
12 Release:        0.1
13 License:        GPL v2+/LGPL v2.1+
14 Group:          X11/Libraries
15 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
16 # Source0-md5:  73d1d1953b12eda42f6f4010df889b73
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= 5.2.0
19 BuildRequires:  Qt5Gui-devel >= 5.3.1
20 BuildRequires:  Qt5Network-devel
21 BuildRequires:  Qt5Test-devel
22 BuildRequires:  Qt5Widgets-devel >= 5.2.0
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         qt5dir          %{_libdir}/qt5
31
32 %description
33 Attica is a Qt library that implements the Open Collaboration Services
34 API version 1.6. The REST API is defined here:
35 http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/
36
37 It grants easy access to the services such as querying information
38 about persons and contents. The library is used in KNewStuff3 as
39 content provider. In order to integrate with KDE's Plasma Desktop, a
40 platform plugin exists in kdebase.
41
42 %package devel
43 Summary:        Header files for %{orgname} development
44 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for %{orgname} development.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe dla programistów używających %{orgname}.
53
54 %prep
55 %setup -q -n %{orgname}-%{version}
56
57 %build
58 install -d build
59 cd build
60 %cmake \
61         -DBIN_INSTALL_DIR=%{_bindir} \
62         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
63         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
64         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
65         -DQML_INSTALL_DIR=%{qt5dir}/qml \
66         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
67         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
68         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
69         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
70         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
71         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
72         -D_IMPORT_PREFIX=%{_prefix} \
73         ..
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} -C build/ install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS README.md
91 %attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
92 %attr(755,root,root) %{_libdir}/libKF5Attica.so.5.0.0
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_includedir}/KF5/Attica
97 %{_includedir}/KF5/attica_version.h
98 %{_libdir}/cmake/KF5Attica
99 %attr(755,root,root) %{_libdir}/libKF5Attica.so
100 %{_pkgconfigdir}/libKF5Attica.pc
101 %{qt5dir}/mkspecs/modules/qt_Attica.pri
This page took 0.497013 seconds and 4 git commands to generate.