]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
- new
[packages/kf5-attica.git] / kf5-attica.spec
1 # TODO:
2 # - proper place for *.pri,
3 # - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
4 # - runtime Requires if any
5 # - dir /usr/include/KF5 not packaged
6 %define         _state          stable
7 %define         orgname         attica
8
9 Summary:        A Qt library that implements the Open Collaboration Services API
10 Name:           kf5-%{orgname}
11 Version:        5.0.0
12 Release:        0.1
13 License:        GPL v2+/LGPL v2.1+
14 Group:          X11/Libraries
15 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
16 # Source0-md5:  73d1d1953b12eda42f6f4010df889b73
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= 5.2.0
19 BuildRequires:  Qt5Gui-devel >= 5.3.1
20 BuildRequires:  Qt5Network-devel
21 BuildRequires:  Qt5Test-devel
22 BuildRequires:  Qt5Widgets-devel >= 5.2.0
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 Attica is a Qt library that implements the Open Collaboration Services
32 API version 1.6. The REST API is defined here:
33 http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/
34
35 It grants easy access to the services such as querying information
36 about persons and contents. The library is used in KNewStuff3 as
37 content provider. In order to integrate with KDE's Plasma Desktop, a
38 platform plugin exists in kdebase.
39
40 %package devel
41 Summary:        Header files for %{orgname} development
42 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{orgname} development.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe dla programistów używających %{orgname}.
51
52 %prep
53 %setup -q -n %{orgname}-%{version}
54
55 %build
56 install -d build
57 cd build
58 %cmake \
59         -DBIN_INSTALL_DIR=%{_bindir} \
60         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
61         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
62         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
63         -DQML_INSTALL_DIR=%{qt5dir}/qml \
64         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
65         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
66         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
67         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
68         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
69         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
70         -D_IMPORT_PREFIX=%{_prefix} \
71         ..
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} -C build/ install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS README.md
89 %attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
90 %attr(755,root,root) %{_libdir}/libKF5Attica.so.5.0.0
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_includedir}/KF5/Attica
95 %{_includedir}/KF5/attica_version.h
96 %{_libdir}/cmake/KF5Attica
97 %attr(755,root,root) %{_libdir}/libKF5Attica.so
98 %{_pkgconfigdir}/libKF5Attica.pc
99 %{qt5dir}/mkspecs/modules/qt_Attica.pri
This page took 0.060842 seconds and 4 git commands to generate.