]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
- todo item dropped
[packages/kf5-attica.git] / kf5-attica.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.4
9 %define         qtver           5.3.2
10 %define         kfname          attica
11 Summary:        A Qt library that implements the Open Collaboration Services API
12 Name:           kf5-%{kfname}
13 Version:        5.4.0
14 Release:        1
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  493c08ce82d5ab34bf2efeb1a01349ab
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Network-devel >= %{qtver}
23 BuildRequires:  Qt5Test-devel >= %{qtver}
24 %if %{with tests}
25 BuildRequires:  Qt5Gui-devel >= %{qtver}
26 BuildRequires:  Qt5Widgets-devel >= %{qtver}
27 %endif
28 BuildRequires:  cmake >= 2.8.12
29 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Attica is a Qt library that implements the Open Collaboration Services
37 API version 1.6. The REST API is defined here:
38 <http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
39
40 It grants easy access to the services such as querying information
41 about persons and contents. The library is used in KNewStuff3 as
42 content provider. In order to integrate with KDE's Plasma Desktop, a
43 platform plugin exists in kdebase.
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kfname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kfname}.
56
57 %prep
58 %setup -q -n %{kfname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ..
66 %{__make}
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS README.md
84 %attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/libKF5Attica.so
90 %{_includedir}/KF5/Attica
91 %{_includedir}/KF5/attica_version.h
92 %{_libdir}/cmake/KF5Attica
93 %{_pkgconfigdir}/libKF5Attica.pc
94 %{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.037456 seconds and 4 git commands to generate.