]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- fix NULL pointer dereference in netlink_seq_next auto/th/kernel-3.13.3-2
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 20 Feb 2014 12:53:42 +0000 (13:53 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 20 Feb 2014 12:53:42 +0000 (13:53 +0100)
- rel 2

kernel-vserver-2.3.patch
kernel.spec

index ee514f64f75f5d63459f94d17eabac50b60d0e26..9a026991fae84f035989c8a681b77c96d6472579 100644 (file)
@@ -24880,8 +24880,8 @@ diff -NurpP --minimal linux-3.13.1/net/netlink/af_netlink.c linux-3.13.1-vs2.3.6
        do {
                s = sk_next(s);
 -      } while (s && !nl_table[s->sk_protocol].compare(net, s));
-+      } while ((s && !nl_table[s->sk_protocol].compare(net, s)) ||
-+              !nx_check(s->sk_nid, VS_WATCH_P | VS_IDENT));
++      } while (s && (!nl_table[s->sk_protocol].compare(net, s) ||
++              !nx_check(s->sk_nid, VS_WATCH_P | VS_IDENT)));
        if (s)
                return s;
  
@@ -24890,8 +24890,8 @@ diff -NurpP --minimal linux-3.13.1/net/netlink/af_netlink.c linux-3.13.1-vs2.3.6
                        s = sk_head(&hash->table[j]);
  
 -                      while (s && !nl_table[s->sk_protocol].compare(net, s))
-+                      while ((s && !nl_table[s->sk_protocol].compare(net, s)) ||
-+                              !nx_check(s->sk_nid, VS_WATCH_P | VS_IDENT))
++                      while (s && (!nl_table[s->sk_protocol].compare(net, s) ||
++                              !nx_check(s->sk_nid, VS_WATCH_P | VS_IDENT)))
                                s = sk_next(s);
                        if (s) {
                                iter->link = i;
index 40047b178ed09b67baafd3db0350f1f84ffa1829..819d33d42989e6cf56657d999cccccf41943bcac 100644 (file)
@@ -66,7 +66,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         3.13
 %define                postver         .3
 
This page took 1.845695 seconds and 4 git commands to generate.