]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- aufs from 3.13 branch
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 27 Jan 2014 22:21:06 +0000 (23:21 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 27 Jan 2014 22:21:06 +0000 (23:21 +0100)
kernel-aufs3.patch
kernel-imq.patch
kernel.spec

index f3f1d5e664beba1c2c666f0f3313572a90a1771f..3a7860af4598033fdefa398b9940444651632f5d 100644 (file)
@@ -1,4 +1,4 @@
-aufs3.x-rcN kbuild patch
+aufs3.13 kbuild patch
 
 diff --git a/fs/Kconfig b/fs/Kconfig
 index c229f82..397b473 100644
@@ -33,7 +33,7 @@ index 33d2b8f..b55eeb9 100644
  header-y += auto_fs.h
  header-y += auto_fs4.h
  header-y += auxvec.h
-aufs3.x-rcN base patch
+aufs3.13 base patch
 
 diff --git a/drivers/block/loop.c b/drivers/block/loop.c
 index c8dac73..2e229ac 100644
@@ -132,7 +132,7 @@ index 74575cb..bfc6fb6 100644
 +                       struct pipe_inode_info *pipe, size_t len,
 +                       unsigned int flags);
  #endif
-aufs3.x-rcN standalone patch
+aufs3.13 standalone patch
 
 diff --git a/fs/inode.c b/fs/inode.c
 index bc83168..6dd1207 100644
@@ -155,7 +155,7 @@ index bc83168..6dd1207 100644
  /**
   *    touch_atime     -       update the access time
 diff --git a/fs/namespace.c b/fs/namespace.c
-index ac2ce8a..83b0135 100644
+index be32ebc..d3f6f59 100644
 --- a/fs/namespace.c
 +++ b/fs/namespace.c
 @@ -425,6 +425,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@@ -400,11 +400,11 @@ index 15b6928..ae6eba6 100644
  {
 diff -urN /usr/share/empty/Documentation/ABI/testing/debugfs-aufs linux/Documentation/ABI/testing/debugfs-aufs
 --- /usr/share/empty/Documentation/ABI/testing/debugfs-aufs    1970-01-01 01:00:00.000000000 +0100
-+++ linux/Documentation/ABI/testing/debugfs-aufs       2013-07-06 13:20:47.716863966 +0200
++++ linux/Documentation/ABI/testing/debugfs-aufs       2014-01-27 23:16:52.651751827 +0100
 @@ -0,0 +1,50 @@
 +What:         /debug/aufs/si_<id>/
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              Under /debug/aufs, a directory named si_<id> is created
 +              per aufs mount, where <id> is a unique id generated
@@ -412,7 +412,7 @@ diff -urN /usr/share/empty/Documentation/ABI/testing/debugfs-aufs linux/Document
 +
 +What:         /debug/aufs/si_<id>/plink
 +Date:         Apr 2013
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It has three lines and shows the information about the
 +              pseudo-link. The first line is a single number
@@ -425,7 +425,7 @@ diff -urN /usr/share/empty/Documentation/ABI/testing/debugfs-aufs linux/Document
 +
 +What:         /debug/aufs/si_<id>/xib
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It shows the consumed blocks by xib (External Inode Number
 +              Bitmap), its block size and file size.
@@ -434,7 +434,7 @@ diff -urN /usr/share/empty/Documentation/ABI/testing/debugfs-aufs linux/Document
 +
 +What:         /debug/aufs/si_<id>/xino0, xino1 ... xinoN
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It shows the consumed blocks by xino (External Inode Number
 +              Translation Table), its link count, block size and file
@@ -444,7 +444,7 @@ diff -urN /usr/share/empty/Documentation/ABI/testing/debugfs-aufs linux/Document
 +
 +What:         /debug/aufs/si_<id>/xigen
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It shows the consumed blocks by xigen (External Inode
 +              Generation Table), its block size and file size.
@@ -454,11 +454,11 @@ diff -urN /usr/share/empty/Documentation/ABI/testing/debugfs-aufs linux/Document
 +              will be empty. About XINO files, see the aufs manual.
 diff -urN /usr/share/empty/Documentation/ABI/testing/sysfs-aufs linux/Documentation/ABI/testing/sysfs-aufs
 --- /usr/share/empty/Documentation/ABI/testing/sysfs-aufs      1970-01-01 01:00:00.000000000 +0100
-+++ linux/Documentation/ABI/testing/sysfs-aufs 2013-10-26 16:51:32.269706994 +0200
++++ linux/Documentation/ABI/testing/sysfs-aufs 2014-01-27 23:16:52.651751827 +0100
 @@ -0,0 +1,31 @@
 +What:         /sys/fs/aufs/si_<id>/
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              Under /sys/fs/aufs, a directory named si_<id> is created
 +              per aufs mount, where <id> is a unique id generated
@@ -466,21 +466,21 @@ diff -urN /usr/share/empty/Documentation/ABI/testing/sysfs-aufs linux/Documentat
 +
 +What:         /sys/fs/aufs/si_<id>/br0, br1 ... brN
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It shows the abolute path of a member directory (which
 +              is called branch) in aufs, and its permission.
 +
 +What:         /sys/fs/aufs/si_<id>/brid0, brid1 ... bridN
 +Date:         July 2013
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It shows the id of a member directory (which is called
 +              branch) in aufs.
 +
 +What:         /sys/fs/aufs/si_<id>/xi_path
 +Date:         March 2009
-+Contact:      J. R. Okajima <hooanon05@yahoo.co.jp>
++Contact:      J. R. Okajima <hooanon05g@gmail.com>
 +Description:
 +              It shows the abolute path of XINO (External Inode Number
 +              Bitmap, Translation Table and Generation Table) file
@@ -6404,7 +6404,7 @@ diff -urN /usr/share/empty/fs/aufs/debug.h linux/fs/aufs/debug.h
 +#endif /* __AUFS_DEBUG_H__ */
 diff -urN /usr/share/empty/fs/aufs/dentry.c linux/fs/aufs/dentry.c
 --- /usr/share/empty/fs/aufs/dentry.c  1970-01-01 01:00:00.000000000 +0100
-+++ linux/fs/aufs/dentry.c     2014-01-20 20:16:14.736130059 +0100
++++ linux/fs/aufs/dentry.c     2014-01-27 23:16:52.701753487 +0100
 @@ -0,0 +1,1081 @@
 +/*
 + * Copyright (C) 2005-2014 Junjiro R. Okajima
@@ -7304,7 +7304,7 @@ diff -urN /usr/share/empty/fs/aufs/dentry.c linux/fs/aufs/dentry.c
 +                      goto err;
 +              continue;
 +
-+      err:
++err:
 +              err = -EINVAL;
 +              break;
 +      }
@@ -8272,7 +8272,7 @@ diff -urN /usr/share/empty/fs/aufs/dinfo.c linux/fs/aufs/dinfo.c
 +}
 diff -urN /usr/share/empty/fs/aufs/dir.c linux/fs/aufs/dir.c
 --- /usr/share/empty/fs/aufs/dir.c     1970-01-01 01:00:00.000000000 +0100
-+++ linux/fs/aufs/dir.c        2014-01-20 20:16:14.736130059 +0100
++++ linux/fs/aufs/dir.c        2014-01-27 23:16:52.701753487 +0100
 @@ -0,0 +1,639 @@
 +/*
 + * Copyright (C) 2005-2014 Junjiro R. Okajima
@@ -8308,7 +8308,7 @@ diff -urN /usr/share/empty/fs/aufs/dir.c linux/fs/aufs/dir.c
 +      nlink += h_dir->i_nlink - 2;
 +      if (h_dir->i_nlink < 2)
 +              nlink += 2;
-+      smp_mb();
++      smp_mb(); /* for i_nlink */
 +      /* 0 can happen in revaliding */
 +      set_nlink(dir, nlink);
 +}
@@ -8323,7 +8323,7 @@ diff -urN /usr/share/empty/fs/aufs/dir.c linux/fs/aufs/dir.c
 +      nlink -= h_dir->i_nlink - 2;
 +      if (h_dir->i_nlink < 2)
 +              nlink -= 2;
-+      smp_mb();
++      smp_mb(); /* for i_nlink */
 +      /* nlink == 0 means the branch-fs is broken */
 +      set_nlink(dir, nlink);
 +}
@@ -13496,7 +13496,7 @@ diff -urN /usr/share/empty/fs/aufs/hfsplus.c linux/fs/aufs/hfsplus.c
 +}
 diff -urN /usr/share/empty/fs/aufs/hnotify.c linux/fs/aufs/hnotify.c
 --- /usr/share/empty/fs/aufs/hnotify.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux/fs/aufs/hnotify.c    2014-01-20 20:16:14.739463504 +0100
++++ linux/fs/aufs/hnotify.c    2014-01-27 23:16:52.711753818 +0100
 @@ -0,0 +1,710 @@
 +/*
 + * Copyright (C) 2005-2014 Junjiro R. Okajima
@@ -13892,7 +13892,7 @@ diff -urN /usr/share/empty/fs/aufs/hnotify.c linux/fs/aufs/hnotify.c
 +                      break;
 +              }
 +
-+      cont_unlock:
++cont_unlock:
 +              spin_unlock(&d->d_lock);
 +      }
 +      spin_unlock(&parent->d_lock);
@@ -16558,7 +16558,7 @@ diff -urN /usr/share/empty/fs/aufs/i_op_add.c linux/fs/aufs/i_op_add.c
 +}
 diff -urN /usr/share/empty/fs/aufs/i_op.c linux/fs/aufs/i_op.c
 --- /usr/share/empty/fs/aufs/i_op.c    1970-01-01 01:00:00.000000000 +0100
-+++ linux/fs/aufs/i_op.c       2014-01-20 20:16:14.739463504 +0100
++++ linux/fs/aufs/i_op.c       2014-01-27 23:16:52.715087263 +0100
 @@ -0,0 +1,1127 @@
 +/*
 + * Copyright (C) 2005-2014 Junjiro R. Okajima
@@ -17435,7 +17435,7 @@ diff -urN /usr/share/empty/fs/aufs/i_op.c linux/fs/aufs/i_op.c
 +              n = inode->i_nlink;
 +              n -= nlink;
 +              n += st->nlink;
-+              smp_mb();
++              smp_mb(); /* for i_nlink */
 +              /* 0 can happen */
 +              set_nlink(inode, n);
 +      }
@@ -20672,7 +20672,7 @@ diff -urN /usr/share/empty/fs/aufs/mvdown.c linux/fs/aufs/mvdown.c
 +}
 diff -urN /usr/share/empty/fs/aufs/opts.c linux/fs/aufs/opts.c
 --- /usr/share/empty/fs/aufs/opts.c    1970-01-01 01:00:00.000000000 +0100
-+++ linux/fs/aufs/opts.c       2014-01-20 20:16:14.742796949 +0100
++++ linux/fs/aufs/opts.c       2014-01-27 23:16:52.715087263 +0100
 @@ -0,0 +1,1701 @@
 +/*
 + * Copyright (C) 2005-2014 Junjiro R. Okajima
@@ -22060,7 +22060,7 @@ diff -urN /usr/share/empty/fs/aufs/opts.c linux/fs/aufs/opts.c
 +              goto add;
 +      case Opt_prepend:
 +              opt->add.bindex = 0;
-+      add:
++      add: /* indented label */
 +      case Opt_add:
 +              err = au_br_add(sb, &opt->add,
 +                              au_ftest_opts(opts->flags, REMOUNT));
@@ -32163,7 +32163,7 @@ diff -urN /usr/share/empty/fs/aufs/xino.c linux/fs/aufs/xino.c
 +}
 diff -urN /usr/share/empty/include/uapi/linux/aufs_type.h linux/include/uapi/linux/aufs_type.h
 --- /usr/share/empty/include/uapi/linux/aufs_type.h    1970-01-01 01:00:00.000000000 +0100
-+++ linux/include/uapi/linux/aufs_type.h       2014-01-20 20:16:14.752797282 +0100
++++ linux/include/uapi/linux/aufs_type.h       2014-01-27 23:17:06.205534916 +0100
 @@ -0,0 +1,281 @@
 +/*
 + * Copyright (C) 2005-2014 Junjiro R. Okajima
@@ -32206,7 +32206,7 @@ diff -urN /usr/share/empty/include/uapi/linux/aufs_type.h linux/include/uapi/lin
 +
 +#include <linux/limits.h>
 +
-+#define AUFS_VERSION  "3.x-rcN-20140120"
++#define AUFS_VERSION  "3.13-20140127"
 +
 +/* todo? move this to linux-2.6.19/include/magic.h */
 +#define AUFS_SUPER_MAGIC      ('a' << 24 | 'u' << 16 | 'f' << 8 | 's')
@@ -32446,4 +32446,3 @@ diff -urN /usr/share/empty/include/uapi/linux/aufs_type.h linux/include/uapi/lin
 +                                    struct aufs_mvdown)
 +
 +#endif /* __AUFS_TYPE_H__ */
-
index 41e8c0f6f98a3131805e46e1b0a542af161edac3..e2ad985d50fd1d71b651f966c1bb13d1b6485795 100644 (file)
@@ -2,18 +2,20 @@ net: add Intermediate Queueing Device (imq)
 
 From: Jussi Kivilinna <jussi.kivilinna@iki.fi>
 
+This patch is for kernel version 3.12.4+.
+
 See: http://linuximq.net/
 
 Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
 ---
  drivers/net/Kconfig                     |  119 ++++
  drivers/net/Makefile                    |    1 
- drivers/net/imq.c                       | 1001 +++++++++++++++++++++++++++++++
+ drivers/net/imq.c                       | 1007 +++++++++++++++++++++++++++++++
  include/linux/imq.h                     |   13 
  include/linux/netfilter/xt_IMQ.h        |    9 
  include/linux/netfilter_ipv4/ipt_IMQ.h  |   10 
  include/linux/netfilter_ipv6/ip6t_IMQ.h |   10 
- include/linux/skbuff.h                  |   23 +
+ include/linux/skbuff.h                  |   22 +
  include/net/netfilter/nf_queue.h        |    6 
  include/uapi/linux/netfilter.h          |    3 
  net/core/dev.c                          |    8 
@@ -25,7 +27,7 @@ Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
  net/netfilter/nf_internals.h            |    2 
  net/netfilter/nf_queue.c                |   36 +
  net/netfilter/xt_IMQ.c                  |   72 ++
- 19 files changed, 1444 insertions(+), 10 deletions(-)
+ 19 files changed, 1449 insertions(+), 10 deletions(-)
  create mode 100644 drivers/net/imq.c
  create mode 100644 include/linux/imq.h
  create mode 100644 include/linux/netfilter/xt_IMQ.h
@@ -34,10 +36,10 @@ Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
  create mode 100644 net/netfilter/xt_IMQ.c
 
 diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
-index 3835321..77550a9 100644
+index b45b240..5a20da0 100644
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -207,6 +207,125 @@ config RIONET_RX_SIZE
+@@ -203,6 +203,125 @@ config RIONET_RX_SIZE
        depends on RIONET
        default "128"
  
@@ -164,7 +166,7 @@ index 3835321..77550a9 100644
        tristate "Universal TUN/TAP device driver support"
        select CRC32
 diff --git a/drivers/net/Makefile b/drivers/net/Makefile
-index ef3d090..b474ff4 100644
+index 3fef8a8..12dafc0 100644
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
 @@ -9,6 +9,7 @@ obj-$(CONFIG_BONDING) += bonding/
@@ -177,10 +179,10 @@ index ef3d090..b474ff4 100644
  obj-$(CONFIG_MII) += mii.o
 diff --git a/drivers/net/imq.c b/drivers/net/imq.c
 new file mode 100644
-index 0000000..fd3e6c5
+index 0000000..801bc8c
 --- /dev/null
 +++ b/drivers/net/imq.c
-@@ -0,0 +1,1001 @@
+@@ -0,0 +1,1007 @@
 +/*
 + *             Pseudo-driver for the intermediate queue device.
 + *
@@ -318,6 +320,12 @@ index 0000000..fd3e6c5
 + *              - Fixed GSO handling for 3.10, see imq_nf_queue() for comments.
 + *              - Don't copy skb->cb_next when copying or cloning skbuffs.
 + *
++ *             2013/09/16 - Jussi Kivilinna <jussi.kivilinna@iki.fi>
++ *              - Port to 3.11
++ *
++ *             2013/11/12 - Jussi Kivilinna <jussi.kivilinna@iki.fi>
++ *              - Port to 3.12
++ *
 + *           Also, many thanks to pablo Sebastian Greco for making the initial
 + *           patch and to those who helped the testing.
 + *
@@ -1249,7 +1257,7 @@ index 0000000..198ac01
 +#endif /* _IP6T_IMQ_H */
 +
 diff --git a/include/linux/skbuff.h b/include/linux/skbuff.h
-index dec1748..1f17280 100644
+index f66f346..d699b19 100644
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
 @@ -33,6 +33,9 @@
@@ -1262,7 +1270,7 @@ index dec1748..1f17280 100644
  
  /* Don't change this without changing skb_csum_unnecessary! */
  #define CHECKSUM_NONE 0
-@@ -420,6 +423,9 @@ struct sk_buff {
+@@ -418,6 +421,9 @@ struct sk_buff {
         * first. This is owned by whoever has the skb queued ATM.
         */
        char                    cb[48] __aligned(8);
@@ -1272,9 +1280,9 @@ index dec1748..1f17280 100644
  
        unsigned long           _skb_refdst;
  #ifdef CONFIG_XFRM
-@@ -458,6 +464,9 @@ struct sk_buff {
- #ifdef NET_SKBUFF_NF_DEFRAG_NEEDED
-       struct sk_buff          *nfct_reasm;
+@@ -453,6 +459,9 @@ struct sk_buff {
+ #if defined(CONFIG_NF_CONNTRACK) || defined(CONFIG_NF_CONNTRACK_MODULE)
+       struct nf_conntrack     *nfct;
  #endif
 +#if defined(CONFIG_IMQ) || defined(CONFIG_IMQ_MODULE)
 +      struct nf_queue_entry   *nf_queue_entry;
@@ -1282,18 +1290,17 @@ index dec1748..1f17280 100644
  #ifdef CONFIG_BRIDGE_NETFILTER
        struct nf_bridge_info   *nf_bridge;
  #endif
-@@ -510,6 +510,10 @@ struct sk_buff {
+@@ -490,6 +499,9 @@ struct sk_buff {
+        */
+       __u8                    encapsulation:1;
        /* 6/8 bit hole (depending on ndisc_nodetype presence) */
-       kmemcheck_bitfield_end(flags2);
 +#if defined(CONFIG_IMQ) || defined(CONFIG_IMQ_MODULE)
 +      __u8                    imq_flags:IMQ_F_BITS;
 +#endif
-+
+       kmemcheck_bitfield_end(flags2);
  #if defined CONFIG_NET_DMA || defined CONFIG_NET_RX_BUSY_POLL
-       union {
-               unsigned int    napi_id;
-@@ -626,6 +639,12 @@ static inline struct rtable *skb_rtable(const struct sk_buff *skb)
+@@ -625,6 +637,12 @@ static inline struct rtable *skb_rtable(const struct sk_buff *skb)
        return (struct rtable *)skb_dst(skb);
  }
  
@@ -1306,9 +1313,9 @@ index dec1748..1f17280 100644
  extern void kfree_skb(struct sk_buff *skb);
  extern void kfree_skb_list(struct sk_buff *segs);
  extern void skb_tx_error(struct sk_buff *skb);
-@@ -2754,6 +2773,10 @@ static inline void __nf_copy(struct sk_buff *dst, const struct sk_buff *src)
-       dst->nfct_reasm = src->nfct_reasm;
-       nf_conntrack_get_reasm(src->nfct_reasm);
+@@ -2635,6 +2653,10 @@ static inline void __nf_copy(struct sk_buff *dst, const struct sk_buff *src)
+       nf_conntrack_get(src->nfct);
+       dst->nfctinfo = src->nfctinfo;
  #endif
 +#if defined(CONFIG_IMQ) || defined(CONFIG_IMQ_MODULE)
 +      dst->imq_flags = src->imq_flags;
@@ -1349,10 +1356,10 @@ index f7dc0eb..58c46a9 100644
  /* we overload the higher bits for encoding auxiliary data such as the queue
   * number or errno values. Not nice, but better than additional function
 diff --git a/net/core/dev.c b/net/core/dev.c
-index 7ddbb31..125b7b9 100644
+index 3d13874..9842f21 100644
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -129,6 +129,9 @@
+@@ -131,6 +131,9 @@
  #include <linux/static_key.h>
  #include <linux/hashtable.h>
  #include <linux/vmalloc.h>
@@ -1362,7 +1369,7 @@ index 7ddbb31..125b7b9 100644
  
  #include "net-sysfs.h"
  
-@@ -2573,7 +2576,12 @@ int dev_hard_start_xmit(struct sk_buff *skb, struct net_device *dev,
+@@ -2595,7 +2598,12 @@ int dev_hard_start_xmit(struct sk_buff *skb, struct net_device *dev,
                        }
                }
  
@@ -1376,7 +1383,7 @@ index 7ddbb31..125b7b9 100644
  
                skb_len = skb->len;
 diff --git a/net/core/skbuff.c b/net/core/skbuff.c
-index 1c1738c..5d1b75b 100644
+index c28c7fe..a5f1888 100644
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
 @@ -73,6 +73,9 @@
@@ -1472,7 +1479,7 @@ index 1c1738c..5d1b75b 100644
  
  /* Pipe buffer operations for a socket. */
  static const struct pipe_buf_operations sock_pipe_buf_ops = {
-@@ -582,6 +661,28 @@ static void skb_release_head_state(struct sk_buff *skb)
+@@ -577,6 +656,28 @@ static void skb_release_head_state(struct sk_buff *skb)
                WARN_ON(in_irq());
                skb->destructor(skb);
        }
@@ -1501,7 +1508,7 @@ index 1c1738c..5d1b75b 100644
  #if IS_ENABLED(CONFIG_NF_CONNTRACK)
        nf_conntrack_put(skb->nfct);
  #endif
-@@ -716,6 +817,10 @@ static void __copy_skb_header(struct sk_buff *new, const struct sk_buff *old)
+@@ -709,6 +810,10 @@ static void __copy_skb_header(struct sk_buff *new, const struct sk_buff *old)
        new->sp                 = secpath_get(old->sp);
  #endif
        memcpy(new->cb, old->cb, sizeof(old->cb));
@@ -1512,7 +1519,7 @@ index 1c1738c..5d1b75b 100644
        new->csum               = old->csum;
        new->local_df           = old->local_df;
        new->pkt_type           = old->pkt_type;
-@@ -3095,6 +3200,13 @@ void __init skb_init(void)
+@@ -3112,6 +3217,13 @@ void __init skb_init(void)
                                                0,
                                                SLAB_HWCACHE_ALIGN|SLAB_PANIC,
                                                NULL);
@@ -1527,10 +1534,10 @@ index 1c1738c..5d1b75b 100644
  
  /**
 diff --git a/net/ipv6/ip6_output.c b/net/ipv6/ip6_output.c
-index 6e3ddf8..ddae387 100644
+index b6fa35e..08dcfef 100644
 --- a/net/ipv6/ip6_output.c
 +++ b/net/ipv6/ip6_output.c
-@@ -89,9 +89,6 @@ static int ip6_finish_output2(struct sk_buff *skb)
+@@ -64,9 +64,6 @@ static int ip6_finish_output2(struct sk_buff *skb)
        struct in6_addr *nexthop;
        int ret;
  
@@ -1540,7 +1547,7 @@ index 6e3ddf8..ddae387 100644
        if (ipv6_addr_is_multicast(&ipv6_hdr(skb)->daddr)) {
                struct inet6_dev *idev = ip6_dst_idev(skb_dst(skb));
  
-@@ -167,6 +164,13 @@ int ip6_output(struct sk_buff *skb)
+@@ -143,6 +140,13 @@ int ip6_output(struct sk_buff *skb)
                return 0;
        }
  
@@ -1555,10 +1562,10 @@ index 6e3ddf8..ddae387 100644
                            ip6_finish_output,
                            !(IP6CB(skb)->flags & IP6SKB_REROUTED));
 diff --git a/net/netfilter/Kconfig b/net/netfilter/Kconfig
-index 56d22ca..58f40f8 100644
+index 6e839b6..45ac31c 100644
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -641,6 +641,18 @@ config NETFILTER_XT_TARGET_LOG
+@@ -630,6 +630,18 @@ config NETFILTER_XT_TARGET_LOG
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -1578,7 +1585,7 @@ index 56d22ca..58f40f8 100644
        tristate '"MARK" target support'
        depends on NETFILTER_ADVANCED
 diff --git a/net/netfilter/Makefile b/net/netfilter/Makefile
-index a1abf87..2c0cbf4 100644
+index c3a0a12..9647f06 100644
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
 @@ -82,6 +82,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CT) += xt_CT.o
@@ -1590,7 +1597,7 @@ index a1abf87..2c0cbf4 100644
  obj-$(CONFIG_NETFILTER_XT_TARGET_LOG) += xt_LOG.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_NETMAP) += xt_NETMAP.o
 diff --git a/net/netfilter/core.c b/net/netfilter/core.c
-index 857ca9f..93fe11b 100644
+index 593b16e..740cd69 100644
 --- a/net/netfilter/core.c
 +++ b/net/netfilter/core.c
 @@ -191,9 +191,11 @@ next_hook:
index 2ecb5ca02413676ddea77416f7a4670e3d3f8190..4433ff09d84976375604f2e7e63c0f47fecdd288 100644 (file)
@@ -211,7 +211,7 @@ Patch118:   ovl09-fs-limit-filesystem-stacking-depth.patch
 # Patch creation:
 # git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
 # cd aufs3-standalone
-# git checkout -b aufs3.10 origin/aufs3.10
+# git checkout -b aufs3.13 origin/aufs3.13
 # cat aufs3-kbuild.patch aufs3-base.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
 # mkdir linux
 # cp -a Documentation fs include linux
This page took 0.130324 seconds and 4 git commands to generate.