]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- 4.14.10 auto/th/kernel-4.14.10-1 auto/th/kernel-nopae-4.14.10-1
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 29 Dec 2017 20:44:23 +0000 (21:44 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 29 Dec 2017 20:44:23 +0000 (21:44 +0100)
kernel-small_fixes.patch
kernel.spec

index 81d01fa5d8010ed2deeb2a05f0564b6b4925f757..d4b603499b05f64e51b96e527678c26a94700ef8 100644 (file)
                                exit
                        fi
                done
-
-; kernel-orc.patch
-Index: linux-2.6/tools/objtool/orc_dump.c
-===================================================================
---- linux-2.6.orig/tools/objtool/orc_dump.c
-+++ linux-2.6/tools/objtool/orc_dump.c
-@@ -76,7 +76,8 @@ int orc_dump(const char *_objname)
-       int fd, nr_entries, i, *orc_ip = NULL, orc_size = 0;
-       struct orc_entry *orc = NULL;
-       char *name;
--      unsigned long nr_sections, orc_ip_addr = 0;
-+      size_t nr_sections;
-+      Elf64_Addr orc_ip_addr = 0;
-       size_t shstrtab_idx;
-       Elf *elf;
-       Elf_Scn *scn;
-@@ -187,10 +188,10 @@ int orc_dump(const char *_objname)
-                               return -1;
-                       }
--                      printf("%s+%lx:", name, rela.r_addend);
-+                      printf("%s+%llx:", name, (unsigned long long)rela.r_addend);
-               } else {
--                      printf("%lx:", orc_ip_addr + (i * sizeof(int)) + orc_ip[i]);
-+                      printf("%llx:", (unsigned long long)(orc_ip_addr + (i * sizeof(int)) + orc_ip[i]));
-               }
-Index: linux-2.6/tools/objtool/Makefile
-===================================================================
---- linux-2.6.orig/tools/objtool/Makefile
-+++ linux-2.6/tools/objtool/Makefile
-@@ -7,8 +7,9 @@ ARCH := x86
- endif
- # always use the host compiler
--CC = gcc
--LD = ld
-+CC = $(HOSTCC)
-+HOSTLD ?= ld
-+LD = $(HOSTLD)
- AR = ar
- ifeq ($(srctree),)
index b59f767fda74eae3faec22b3125df31fb0d9bb20..1c6002c46ad521032a7faf8b4401b02711484002 100644 (file)
@@ -70,7 +70,7 @@
 
 %define                rel             1
 %define                basever         4.14
-%define                postver         .9
+%define                postver         .10
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -122,7 +122,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: bacdb9ffdcd922aa069a5e1520160e24
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  623ac9e64733d008d11e8d35d17d99f8
+# Patch0-md5:  986c6711da939de924926a7f5033218d
 %endif
 Source1:       kernel.sysconfig
 
@@ -700,6 +700,8 @@ rm -f localversion-rt
 # Do not remove this, please!
 #%%patch50000 -p1
 
+chmod 755 tools/objtool/sync-check.sh
+
 # Fix EXTRAVERSION in main Makefile
 sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makefile
 
This page took 1.24984 seconds and 4 git commands to generate.